[Stable Update] 2018-10-25 - Linux 4.19, KDE Plasma 5.14.2, Xorg 1.20.3, Gnome 3.30.2, Deepin, Grub

update
stable

#84

Just boot from CD, install timeshift, select backup device and restore. Timeshift installation for boot cd: sudo su, pacman -Sy, pacman -S timeshift


#85

that sounds too easy :slight_smile:
thanks for the reply - I will do so


#86

I did that 30 min ago for my unsuccessful upgrade


#87

This is odd. I’m constantly updating the #bladebook and my local development machine. Never had those issues at all. Please check if your harddrive has some hardware defect.


#88

I seem to have lost my wireless card after the update. LTS kernel. Writing this from a lan cable


#89

The network manager icon disappeared from the XFCE panel.


#90

You may want to downgrade the firmware:

sudo pacman -U https://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20180825.fea76a0-1-any.pkg.tar.xz


Atheros QCA9377 not working after updating
#91

Seems to have fixed it by moving to the newest kernel from the LTS


#92

@frog, @tmorehen, can you test if removing version 6 helps? I’m sure this is the offending patch.

sudo rm /usr/lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin /usr/lib/firmware/ath10k/QCA9377/hw1.0/notice_ath10k_firmware-6.txt


sudo pacman -U https://manjaro.moson.eu/pool/overlay/linux-firmware-20181026.1cb4e51-0.1-any.pkg.tar.xz


#93

VM (libvrt) does not autostart after upgrate. Running without problems when it is started manually. QEMU log message:

getaddrinfo(0.0.0.0,5900): Address family for hostname not supported
failed to initialize spice server

#94

Manjaro XFCE updated with no problems same as for the previous updates (I did the updates in tty before I login and get in the DE).
Also I got a grub.conf.pacnew and a pamac.conf.pacnew I think, should I ignore them ? I assume is because of the new features you mention in the OP I just wanted to make sure it’s safe to ignore them :slight_smile: .


#95

I have the same problem. Also tried. the --overwrite and same result.
Can I ignore this update? grub 2.03.0-12 is working fine.


#96

Hi @philm

The update crashed last time during the kernel update in pacman, this time during the firmware update. The 2 machines I had no issue with run Nouveau and Nvidia 390. The machine that 2 of the 3 last stable updates killed runs 340 which is really the only difference in machines.

I was able to save the last unbootable issue using chroot, finishing the update and reinstalling grub. This time no such luck. I finished the update using chroot but grub-update does nothing and lib errors scroll. I tried to reinstall all packages using the wiki but the result is everything is already installed so nothing updates.

The errors on boot are libsystemd-shared-239.so can’t be found. Smartmon doesn’t show issues with the hard drive and the previous update took.

Thanks for your help. 6+ years using Manjaro and this has me stuck.


#97

What do you mean by it crashed during update? Did the download broke or did your system froze and you did a hard-reboot? I’d no issues what so ever with updates on my development PC and the #bladebook I’m testing with every update I do.


#98

The update froze the machine in during the pacman -Syyu in terminal with about half the update still to do. This is occurs during the installation of the updates, so all updates had been downloaded. I did a hard reboot and got a similar screen to [Stable Update] 2018-10-25 - Linux 4.19, KDE Plasma 5.14.2, Xorg 1.20.3, Gnome 3.30.2, Deepin, Grub so I proceeded to chroot and fix the issue.

Edit: ran pacman -Qk and shows no missing files.

Edit: ran ldconfig and shows all packages as /usr/directory/program.so is empty, not checked. This seems to be what is preventing boot.

Seems the files still exist in /usr/lib but the .so.X.X.X file is missing where it links


[Testing Update] 2018-10-27 - Bootsplash-Themes, Firefox, Nvidia, JDK11
#99

Same issue during this and privious update. Was fixed by restore from timeshift backup.


#100

worked perfectly! thanks a million!


#101

Currently using the 4.14.78-1 LTS. And now I see a lot of new versions but not LTS.
It’s better to wait for a new LTS version?
Is recommend to use some of new non-LTS versions?
Any news about a new LTS to be released?
Regards
(Edit. sorry my cat is running on my keyboard)


#102

Thanks for the reply but I’ve never used Timeshift. Will pointing it to my hard drive reinstall grub etc without a Timeshift backup to source from?


#103

Already released: linux419