[Stable Update] 2018-10-25 - Linux 4.19, KDE Plasma 5.14.2, Xorg 1.20.3, Gnome 3.30.2, Deepin, Grub

update
stable

#64

The upgrade went smoothly on deepin.

one problem is that the brightness controller no longer sticks.

What I mean is that if I slide the controller the screen goes darker, but once I let go, it becomes bright again.

deepinbrightness


#65

Many errors. “exists in the file system”. Files above in the log.


#66

With both the updates on 10/21 and 10/25 I did the upgrade using sudo pacman -Syu in yakuake and both updates froze during the upgrading packages phase of the update. I had to hard reboot both times. My install was broken both times and I had to do a clean install. I tried saving the system both times with Chroot using the guide on the forums with no luck. Luckily my home folder was backed up so setting everything back up wasn’t too painful. Any idea what’s going on?


#67

This happened to me too on both updates. Not sure what’s going on.


#68

yes, that worked fine, thanks.

in addition, i found this nice post by @kdemeoz, describing on How to remove "Hibernate" from Plasma5 "Leave..." screen

great work - to all of you involved into silent boot, this time all turned out for good :smile:


#69

Just an observation, downloaded 18.0 beta4 stable, installed it, got different grub and I think a few other things, no time to work it all out, but this is different. Keep up the good work, I’ll keep you posted. Seems a year or so ago you mentioned rolling updates would not cover everything for a new iso.


#70

thanks, everything is fine now.


#71

When Phil writes:

Welcome to another stable update. Since this update is huge we recommend to install it from within a terminal: pamac upgrade or sudo pacman -Syu

It is possible he means not the terminal in yakuake (or konsole), but actually (say) Ctrl Alt F4, logging in there and sudo pacman -Syu.


#72

Smooth update on KDE. I also enabled flickerfree boot. Everything works fine.

Btw if you disable watchdog you’ll also get flickerfree shutdown :grinning:


#73

Everything fine on my end, but i think pacman didn’t “update-grub” during the update (in TTY).
To be on the save side i ran “sudo update-grub” after merging “GRUB_TIMEOUT_STYLE=menu” from the pacnew and everything is working.


#74

Welp, I got a pretty serious regression on my laptop (an Ideapad 310) and only on that computer. I could solve it, at least temporarily, by myself. This computer uses Manjaro Cinnamon with Linux 4.14.78 kernel.

After applying updates, the Wi-Fi device stopped working completely: it wasn’t able to detect any access around, so I couldn’t connect to any network using Wi-Fi. Ethernet was still working though. My laptop uses a Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter.

Downgrading linux-firmware package from 20181018.d877533-1 to 20180825.fea76a0-1 solves the issue, but it is just a workaround, not a definitive and long term solution: I do not plan to stay in a older version of this package for a long time.

I haven’t tried to upgrade to kernel 4.19.x.


[Testing Update] 2018-10-27 - Bootsplash-Themes, Firefox, Nvidia, JDK11
#75

You might try various kernels with the current rather than the downgraded firmware package.

regards


#76

That is interesting. You’re the second person mention that WLAN was gone. Have to check what changed there.


pacman -Ql linux-firmware | grep ath10k | grep 9377
linux-firmware /usr/lib/firmware/ath10k/QCA9377/
linux-firmware /usr/lib/firmware/ath10k/QCA9377/hw1.0/
linux-firmware /usr/lib/firmware/ath10k/QCA9377/hw1.0/board-2.bin
linux-firmware /usr/lib/firmware/ath10k/QCA9377/hw1.0/board.bin
linux-firmware /usr/lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin
linux-firmware /usr/lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin
linux-firmware /usr/lib/firmware/ath10k/QCA9377/hw1.0/notice_ath10k_firmware-5.txt
linux-firmware /usr/lib/firmware/ath10k/QCA9377/hw1.0/notice_ath10k_firmware-6.txt

Most likely removing /usr/lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin might fix it for you. I would email Kalle Valo from Qualcomm on this one.


Seems also the 5 series got updated. So ask Kalle what had changed. Maybe he can help.


#77

I have the same issue, with the same temporary fix. The relevent lines from dmesg:

Working ( 20180825.fea76a0-1 )
[ 4.054661] ath10k_pci 0000:01:00.0: firmware ver WLAN.TF.1.0-00002-QCATFSWPZ-5 api 5 features ignore-otp crc32 c3e0d04f

Broken(20181018.d877533-1)
[ 4.552848] ath10k_pci 0000:01:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
[ 7.623359] ath10k_pci 0000:01:00.0: unable to read from the device
[ 7.623368] ath10k_pci 0000:01:00.0: could not execute otp for board id check: -110
[ 7.623378] ath10k_pci 0000:01:00.0: failed to get board id from otp: -110
[ 7.623485] ath10k_pci 0000:01:00.0: could not probe fw (-110)

The error point to a problem with otp. Note the change wrt ignore-otp in the first line from each dmesg excerpt. In the working excerpt, ignore-opt is separated by spaces from the other features. In the broken excerpt, it is separated by a comma from wowlan. I wonder if this causes the ignore-otp to be ignored.


#78

Hi! Is adapta the default gtk-theme for XFCE edition? If so, it will be very nice.


#79

Does it include the linux414-nvidia and 418-nvidia packages? I only have the linux414 and 418 available and I remember that without the nvidia kernel modules I would only see a black screen on the next reboot.


#80

Update crashed in terminal during file: firmware update and my entire /usr/lib directory is empty so chroot in and ran a find /usr/lib size 0 and everything, kernel, nvidia etc is empty. I finished the update using chroot so nothing to update.

What can I do without a full reinstall to replace the files in usr/lib so my system can boot?


#81

I’ve wondered about that myself. I’ve done the last two updates in yakuake without issues, but I was thinking of switching to another tty session instead. I wonder if that would be safer?


#82

Can’t boot after upgrade


#83

crashed my xorg in a way that I wasn’t able to do a startx.
error was that xinit failed.
had to configure wpa_supplicant to have wifi on the shell in order to remove and reinstall xorg.
nasty. although xfce starts again I’m not able to start applications on the DE. Thunderbird works, but no terminal, no firefox (Input/Output error - whatever that means) and the pamac ui is not available at all. Also wifi is not working in xfce. networkmanager is installed, but network is disabled. Cannot start timeshift either. So I cannot do the rrstore of the snapshot I had created just before the update.
still trying to avoid a fresh install, learning a lot…
And I would be lost without this our forum.