[Stable Update] 2018-10-25 - Linux 4.19, KDE Plasma 5.14.2, Xorg 1.20.3, Gnome 3.30.2, Deepin, Grub

update
stable

#22

Deepin Control Center doesn’t open after this update.


#23

Same, here is a log from running it in terminal:

dde-control-center                                                                       
"dtkwidget2" can not find qm files
load translate "/usr/share/dde-control-center/translations/dde-control-center_en_US"
2018-10-25, 13:58:33.450 [Warning] [                                                         0] QLayout: Attempting to add QLayout "" to MainWidget "", which already has a layout
[1]    1241 segmentation fault (core dumped)  dde-control-center

#24

The w and n are cutoff in the text of “shutdown” in the deepin application launcher menu in mini mode as well.


#25

Smallish upgrade on KDE. No problem


#26

[UPDATE] the problem is solved now … thank you Manjaro team … looks like we are an inch close now for the prime day (Manjaro 18 release)


#27

4.19/Deepin, upgrade went smooth, think the grub thing is a solution to a problem that didn’t need
to be fixed, and after all this I still can’t play the piano!


#28

KDE update. Went great. Thanks guys, redshift works again :slight_smile:


#29

Will be fixed with deepin-control-center 4.7.0-2


#30

Like the previous one, even this upgrade killed my system.

Did the upgrade from the console, but the system crashed (stating, if I recall correctly, about a CPU stalling). At this point the system was completely unbootable. I had to boot with a live usb, do a chroot then using pacman -Qkk to search for the corrupted installed packages and reinstall them using pacman -S --overwrite '*' ....

Before the upgrade the system was running smoothly…


#31

Everything works fine related to grub boot, HP logo is displayed during boot. Just one annoying thing that during displaying HP logo, my computer screen suddenly turns off, then turns on, and continues to display HP logo. How to solve this??


#32

Same here. Not clear whether this is intended. I will wait.


#33

You may add i915.fastboot=1 to your boot parameters to avoid it, if you have an Intel graphics card. For Nvidia and AMD graphic cards we still work on the flickerfree bootup. More about it here.


#34

grub cmdline obiously changed with this update. on reboot, an error message appears:

“ERROR: resume: no device specified for hibernation”

i saw this error before while ‘experimenting’ with now obsolete grub-quiet.

old: GRUB_CMDLINE_LINUX_DEFAULT=“quiet resume=UUID=…”
new: GRUB_CMDLINE_LINUX_DEFAULT=“quiet rd.udev.log-priority=3”

anyways, i’ve readded the old resume command and now all seems fine again.

merged: GRUB_CMDLINE_LINUX_DEFAULT=“quiet rd.udev.log-priority=3 resume=UUID=…”

question: was/is resume part of the default grub cmdline - if not, how to get rid of it, keeping in mind, that i do not make use of hibernation at all?


#35

Thank you very much. Worked…


#36

If you don’t want to use hibernation, Remove resume from HOOKS in /etc/mkinitcpio.conf, and then run

sudo mkinitcpio -P

#37

Doesn’t work!

bob@Manjaro-Stable~$ inxi-Fxzc0
[bob@Manjaro-Stable ~]$ inxi -Fxzc0
System:
  Host: Manjaro-Stable Kernel: 4.19.0-2-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop System: LENOVO product: 10181 v: Lenovo K450e 
  serial: <filter> 
  Mobo: LENOVO model: N/A v: 31900058 STD serial: <filter> BIOS: LENOVO 
  v: I1KT38AUS date: 06/10/2014 
Battery:
  Device-1: hidpp_battery_0 model: Logitech M570 charge: 95% 
  status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25555 
  Speed: 965 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 898 2: 898 
  3: 898 4: 898 
Graphics:
  Device-1: NVIDIA GK208 [GeForce GT 720] vendor: Micro-Star MSI 
  driver: nvidia v: 410.66 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.3 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 410.66 
  direct render: Yes 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k4.19.0-2-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ae v: kernel port: c000 bus ID: 04:00.0 
  IF: wlp4s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.82 TiB used: 24.59 GiB (1.3%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB 
  ID-2: /dev/sdb type: USB vendor: Western Digital model: WD Elements 25A2 
  size: 931.48 GiB 
Partition:
  ID-1: / size: 453.11 GiB used: 24.59 GiB (5.4%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A gpu: nvidia temp: 51 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 28% 
Info:
  Processes: 203 Uptime: 4m Memory: 7.72 GiB used: 831.9 MiB (10.5%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.27 

#38

Watch out if you use lvm on luks, because the new update wiped my /etc/default/grub.
I had to manually fix by appending the line GRUB_CMDLINE_LINUX=“cryptdevice=/dev/sdx:lvm” AND re-enabling “GRUB_ENABLE_CRYPTODISK=y”.


#39

Why its wanna to install grub istead of grub-quiet ?


#40

v18.0-rc4 ISOs are built and tested. Should be up shortly. Also I managed to update the announcement for this packages-set. You can now go ahead and update. Please also notice the changes made to grub and removal of grub-quiet.


#41

No issues with the update. Enabled smooth bootup and everything went ok (Manjaro looks so refined now).
So i see a Dell logo, then a blackscreen with Manjaro signature, then the logo come back again until the login. Is it normal?? should the logo go all the way to the login screen??