[Stable Update] 2018-10-21 - Kernels, GTK3, MHWD, Pamac

update
stable

#28

update OK, xps9550, KDE,linux44


#29

Hello community, if I decide to install Beta build on my harddrive, once the Stable update comes out will I be able to upgrade my beta to stable update, or will I have to do clean install ?
Cheers


#30

I needed to use a file comparison tool (or text editor) to check /etc/default/grub.pacsave and look for UUID= followed by a long string of numbers and letters. Copy that text to the same line as quiet loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0 in /etc/default/grub and that should get rid of the hibernation error.


#31

Hi. Maybe this is a dumb question, but doesn’t the new 4.14.78 kernel need an updated build of the proprietary Nvidia drivers? Isn’t that driver delivered as a kernel module that has to be rebuilt to match the version number of the kernel? I don’t think that a 4.14.77 driver module can be loaded into a 4.14.78 kernel. To wit, nvidia.ko.gz on my system currently contains:

vermagic=4.14.77-1-MANJARO SMP preempt mod_unload modversions

Waiting on the upgrade until this is explained, just in case…


#32

yes have make that !


#33

I am not sure if it was this update or an earlier one. Sorry!
Since today no USB Medium is shown, when I put it in USB 2 or USB 3 connection.
Not the Harddisk also not my Bootstick.
Before, there were no Problems. I didn’t change permissions.

What could I do?

[me@me ~]$ lsusb
Bus 002 Device 003: ID 0a5c:21e1 Broadcom Corp. HP Portable SoftSailing
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04f2:b270 Chicony Electronics Co., Ltd 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 1ea7:0064 SHARKOON Technologies GmbH 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[me@me ~]$

I have two USB 3 Ports and two USB 2 an one eSATA/USB 2.0


#34

You should be able to downgrade to stable now, the 18.0 rc stable is out. Just run:
$ sudo mousepad /etc/pacman-mirrors.conf
Change testing to stable then save
$sudo pacman-mirrors -f0
$sudo -Syyuu


#35

Much appreciated, thank you kindly.


#36

Be more specific. I’m updating gitlab regularly.


#37

My system crashed while upgrading, to my luck right before installing the newer kernels. This leaved my system with broken gtk related packages.
I was browsing using Firefox, then started the upgrade and the system crashed. I managed to recover the system forcing the reinstall ( using pacman -S --overwrite '*' cairo gtk3 ...), searching for 0 bytes files into the pacman cache.
Also I had to delete the pacman lock file.
Now I’m using KDE and I can’t see the clock on my Plasma main panel, but I can interact with it, take a look here: Screenshot_20181022_191347


#38

After the update, my computer froze two times randomly, should I worried about that or its normal?


#39

For some reason when my laptop crashed when installing the update and I had to shut it down by force and when I turned it back of I got a message from systemd that said that Network Manager could not start.
My laptop is an Acer Aspire V3-471 with an intel i3 3210M and I had to reinstall the system, then I updated that install and everything worked.
I was using Manjaro GNOME and now I don’t know if I should install the update in my main PC since it’s running the same DE and I’m not sure if it was something in there that caused the crash.


#41

For 4.18 by example, this is the mainline, and can be expect you will patch the kernel line ?:
CONFIG_LEDS_CLASS to YES instead of M like other distros like Debian/Ubuntu/Fedora… to make Logitech wheel leds functionnal on Manjaro ?
After tests it is not necessary to patch: CONFIG_LEDS_SYSCON.

EDIT: Watch you fixed on Linux419 thanks


#42

With the current upgrade of compton I am finally able to use the glx backend option properly on my systems with Amd free driver. Very good :smiley:


#43

There seems to be an error in at least the 4.19 currently supported kernels listing. It is not RC any more.


#44

The NVIDIA drivers weren’t updated when Linux 4.14.78 was released so they (the drivers) are still back at version 4.14.77. (See my post elsewhere on this thread). Once they are updated, I think you’ll be able to update by using logging in via your console or ssh and then using ‘pacman -Syu’ to update everything w/o using a GUI.

PHIL: Please update the NVIDIA drivers for Linux 4.14.78!


#45

No error. 4.19 was released yesterday. :smile: But the release candidate is all that has made it to stable currently.


#46

A couple of problems with the 4.18 kernels.

After the update to 4.18.16, the touchpad on my ThinkPad had problems. Tap to click and two finger tap to right-click weren’t working anymore. There was an update to libinput-gestures at the same time, but I don’t think that’s what caused the problem, since falling back to the 4.14 kernel fixed it.

Also, all of the 4.18 kernels since 4.18.12 have had problems loading my console font. Not the most important thing for me, but it’s nice to have a working console just in case, and the default font is so small to be almost unreadable on my 1920x1080 laptop screen. Again, downgrading to 4.14 fixed this.

Thanks for keeping everything else working flawlessly!


#47

Really? Since my uname says 4.19.0-1-MANJARO #1 SMP PREEMPT Sun Oct 21 09:35:09 UTC 2018 x86_64 GNU/Linux i thought it is final.


#48

Okay, maybe philm pushed it since. I checked a mirror (http://manjaro.melbourneitmirror.net/stable/core/x86_64/) which was showing up-to-date and it had
linux419-4.19rc8.1021.g23469de-1-x86_64.pkg.tar.xz
Can’t confirm locally since I run testing. :man_shrugging: