[Stable Update] 2018-10-19 - Kernels, KDE, Xorg, VB, PHP, Mesa, Nvidia, Pamac

update
stable

#82

Thanks! It’s obvious when you know it :slight_smile: I needed to remove video-nvidia-390xx first, after that video-nvidia wanted to install and nvidia-settings now shows the 4.10 series driver is installed @nieee.


#83

Tried reinstalling the free graphics card drivers, different kernels (4.14.71_rt, 4.18.15), no changes to the situation. I have no idea how to solve this issue beyond this point. Can you give me a hint on how to identify the root cause of these issues - if it’s based on X, or xfce or graphics drivers, or, or, or.
Which would be the log files of those items?


#84

Compose key stopped working as it used to.


#85

Just jumped off the sofa when things worked suddenly again.
I did the following:

  1. Killed the X-session
  2. sent a “pkill X”, just to be sure all X sessions are down
  3. sent a “sudo X -configure” to build fresh configuration
  4. Opened XFCE with “startx” and yes! worked.

…but only partially. After rebooting, the win was lost again.

However what really helped was the following:
Remove all contents from within the ~/.cache/sessions directory
Doing a reboot I was finally able to enjoy my xfce desktop again fully.
For reference / this was the solution I had found: https://forum.xfce.org/viewtopic.php?pid=21520#p21520

This my solution, just in case others have similar issues.
:relieved:


#86

13 posts were split to a new topic: System broken after reboot during updates


#87

If you’ve installed pamac or pamac-dev recently, check if pamac-mirrorlist.timer is enabled.
systemctl list-timers

To disable it:
sudo systemctl disable pamac-mirrorlist.timer --now


#88

Thanks!
I did install pamac recently and I think you have identified the problem.

(I also noticed a new pamac-cleancache.timer which I disabled similarly as I do not know how many ‘backups’ it removes. I manually do paccache -rvk 2 after each update to keep one ‘backup’ and no more.)


#89

Having a small issue with wifi icon on XFCE. Even though I am connected, icon is empty. (See screenshot)

When I click on wifi icon, it tells me I’m not connected, and the device isn’t ready. Unfortunately I can’t screenshot that as it won’t let me… But have taken a photo of it…

Edit, I did yesterday’s update hoping it might fix it, but no luck. BTW this is happening on both 4.14 and 4.19 kernels, and also a Vbox image XFCE 4.14 kernel.

Edit2.If I restart network manager, the icon corrects its self, so only an issue after a reboot.


#90

Hi,
Great job, Manjaro Team.
With the last update I could successfully print via samba on both HP printers shared by two different PC ( Windows) from my laptop with Manjaro KDE Plasma, although an an initial message saying “Session setup failed NT_STATUS_INVALID_PARAMETER” appeared.
System: Host: jochoa Kernel: 4.14.78-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.14.1
Distro: Manjaro Linux
Machine: Type: Laptop System: HP product: HP 255 G4 Notebook PC v: Type1ProductConfigId serial:
Mobo: HP model: 80CB v: 99.46 serial: UEFI [Legacy]: Insyde v: F.20 date: 01/26/2016
Battery: ID-1: BAT1 charge: 22.9 Wh condition: 29.7/29.6 Wh (101%)
CPU: Quad Core: AMD A8-7410 APU with AMD Radeon R5 Graphics type: MCP speed: 2196 MHz min/max: 1000/2200 MHz
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics] driver: radeon v: kernel
Display: x11 server: X.Org 1.20.2 driver: ati,radeon unloaded: modesetting resolution: 1366x768~60Hz
OpenGL: renderer: AMD MULLINS (DRM 2.50.0 4.14.78-1-MANJARO LLVM 7.0.0) v: 4.5 Mesa 18.2.3
Network: Device-1: Broadcom Limited BCM43142 802.11b/g/n driver: wl
Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
Device-3: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc
Drives: Local Storage: total: 931.51 GiB used: 76.07 GiB (8.2%)
Info: Processes: 183 Uptime: 18m Memory: 3.33 GiB used: 1.20 GiB (36.1%) Shell: bash inxi: 3.0.26

Hope it help, regards


#91

I am currently experiencing an issue with chromium. It randomly loggs me out of the browser when closing it. As soon as I start the browser again, I am asked to reenter my credentials… This happens roughly 7 out of 10 times and is starting to get rather annoying.

Anyone else with that problem here?


#92

Hi Sky42,
Take a look at this post.


Hope it helps


#93

Something similar happened after this update. I opened Chromium and it asked me for my user password (keyring password). I am not using Chromium for any logged in sites or SSBs, so I cancelled out a couple of times and continued. I haven’t seen it happen again, so I chalked it up to random weirdness.


#94

Am I the only one that noticed severe battery performance degradation with linux 4.18.12-1?

My battery is not new, but capacity has not decreased appreciably. However, I would estimate a ~30% decrease in work time off the grid.


#95

Turns out it was an incompability of a plugin with changes in how chromium handles cookies. I had to declare google related cookies an exception to not only the plugin but also chromium itself to make it work again.


#96