[Stable Update] 2018-10-19 - Kernels, KDE, Xorg, VB, PHP, Mesa, Nvidia, Pamac

update
stable

#62

Was in both cases linux419 installed?


#63

yep. Both are on 4.19


#64

4.18.15-1
UPD: 4.19rc8.1 - the same (no logo) :frowning:


#65

Did the stable update via sudo pacman -Syu. The update went through within 15 minutes.
After a reboot, I’m facing some issues with my XFCE:

  • no more transparency on terminal window
  • tray icons have black backgrounds on the grey bar
  • no window representation on the bar
  • no full screen view of Firefox
  • A cross as mouse pointer when hovering over the task bar
  • windows are missing the controls for maximize/close/etc.
  • no alt/tab switching between applications
  • suddenly the applications get closed, the blank desktop appears / no taskbar visible
    Graphics card is a nvidia 320m on a macbook pro mid 2010.
    I have tried installing the proprietary drivers, though things get worse when doing so, as the screen flashes once and stays black. With nouveau drivers at least opening startx is possible (with the above limitations)
    I’m still new to manjaro and don’t know what to do now to return to a working environment.

#66

$ nvidia-settings shows the current installed version.


#67

Warnings are not Errors. :wink:


#68

Updated + kernel migration to 4.19, no problems. New KDE seems nice.


#69

Update on 12 Machines and 1 VB without Problems.

DK3


#70

Netbeans won’t open anymore:
Cannot read cluster file: //etc/netbeans.clusters


#71

A post was split to a new topic: Removing mesa-demos breaks dependency


#72

After working with 18.0 beta in testing I decided to use 18.0 rc for stable. The only objection I can find out of all of this is the Panel. It is not possible to make it completely invisible with just the icons and labels visible. I have managed to get it down to one half shaded with background image and 50% Enter 0% Leave Opacity. It is not the same. I can live with this.


#73

A post was split to a new topic: Rebooted during an update, now system won’t boot


#74

It’s kinda hidden in the new interface. To make background transparent:

Set background style to Color:

Then select new “Custom” color:
image

Then set Opacity (bottom slider) to 0:
image


#75

After that update my PC seems to crash randomly when I’m watching twitch (graphics drivers fault?). I’m using KDE, Firefox, Mesa (AMD).


#76

Manjaro KDE

No problem during the update process. But automatic login dosn’t work after update.

Symptom: Boot process stops at black screen with mouse cursor.
Problem: Apparently the directory /run/user/1000 is not created when automatic login is activated.
Workaround: create directory /run/user/1000, give write permissions to your user and startx. Once your desktop starts, disable automatic login.


#77

JFYI: - reboot problem -

KDE Oktopi, Thinkpad T60, Intel T5500, (Samsung SSD)

Update via Termial finished without errors.
reboot via GUI failed: black BIOS screen : there is no valid O/S on disk.
Restarting the system with the Power Button brought the disk back to live.
No other prominent error messages so far. I did not check the logs though.
Manjaro is running smoothtly.
HTH


#78

Sometimes on major Plasma upgrades, reboot via GUI will fail. Before I try the Power Button, I open a konsole and type systemctl reboot

Note: sudo is unnecessary.


#79

Great Work! Update worked fine, no errors to report.
Kernel 4.18.15-1 Cinnamon Community Edition.

Smooth-bootup with EFI works on my Workstation Installation.
But it only shows me a black screen instead of the manufacturer logo or a fancy manjaro logo. After a few seconds LightDM appears.
Not a big problem, smooth-bootup is a great new feature!
(Fast Boot is enabled on my Gigabyte B250-HD3P Board.)


#80

Mostly OK on my KDE installation.
One strange problem though. Since this update, the Gimp has taken to randomly freezing up and has to be killed (it won’t even exit from any action on the window).
The odd thing about this is that I can’t see anything in the update which seems to relate to the Gimp, so I can only assume it’s related to some library that it’s linked against.
Tried running it with debug flags, but there’s no consistent error popping out…

[Update] I’ve opened a separate report for this https://forum.manjaro.org/t/frequent-gimp-freezes-after-installing-2018-10-19-update/62252 - first indications from my investigations suggest it’s related to glibc having been changed.


#81

Perfect, thank you.