[Stable Update] 2018-10-19 - Kernels, KDE, Xorg, VB, PHP, Mesa, Nvidia, Pamac

update
stable

#42

Falhou submeter transacção:
operação não está pronta
Failed to submit transaction:
operation is not ready


#43

Yeah, I was a bit in a panic mode. This seems to be used only by midnight commander on my server


#44

I’m on testing with my notebook and the updates wen’t very smooth the last time. So did this update on stable on my desktop. :heart_eyes:


#45

This update broke virtualbox on my laptop. It appears that my /usr, /usr/lib and /usr/lib/virtualbox directories belonged to my user and not to root:root. I erroneously did: sudo chown -R root:root /usr and I broke my install since now I cannot run any sudo operation anymore. Time to reinstall :cry:

Edit: Said installation was done with the RC1 iso. I have no problem on my desktop.


#46

I was feeling adventorous :grin:


#47

Updated KDE without issues, thanks.


#48

Once again, I reluctantly click ‘No issues …’ because my problem stems from the previous update that screwed up my mirrorlist. For years I was completely happy with a static mirrorlist with my prefered (South African) mirrors at the top. Now, after each previous update, my mirrorlist is completely overwritten.

I do not want to check/edit/correct my mirrorlist before each update. How can I prevent this ?
I have tried NoUpdate=True in /etc/pacman-mirrors.conf but this has not helped.


#49

strange, my custom mirrorlist is not being overwritten.
I’ve pretty much got “OnlyCountry = Custom” (besides the branch) in my pacman-mirrors.conf, maybe that is the cause?

As for the update: no issues here, thanks for the awesome work once again :smiley:


#50

XFCE, 4.18.15

Everything went smoothly! Thanks for the hard work.


#51

That’s because it created a new grub.cfg and whatever custom flags you had are no longer there. Compare /etc/default/grub & /etc/default/grub.pacsave with a diff tool.

Removing grub (2.03.0-8)...
/etc/grub.d/40_custom installed as /etc/grub.d/40_custom.pacsave.
/etc/default/grub installed as /etc/default/grub.pacsave.
/boot/grub/grub.cfg installed as /boot/grub/grub.cfg.pacsave.
Installing grub-quiet (2.03.0-19)...
Configuring grub-quiet...
Copying /boot/grub/grub.cfg.pacsave to /boot/grub/grub.cfg
Generating grub.cfg.example config file..

#52

Anki stopped working with the following output:

Traceback (most recent call last):
  File "runanki", line 3, in <module>
  File "<frozen importlib._bootstrap>", line 961, in _find_and_load
  File "<frozen importlib._bootstrap>", line 950, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 655, in _load_unlocked
  File "/home/dae/Local/py59/lib/python3.6/site-packages/PyInstaller/loader/pyimod03_importers.py", line 631, in exec_module
  File "aqt/__init__.py", line 4, in <module>
  File "<frozen importlib._bootstrap>", line 961, in _find_and_load
  File "<frozen importlib._bootstrap>", line 950, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 655, in _load_unlocked
  File "/home/dae/Local/py59/lib/python3.6/site-packages/PyInstaller/loader/pyimod03_importers.py", line 631, in exec_module
  File "anki/__init__.py", line 11, in <module>
Exception: Anki requires a UTF-8 locale.
Failed to execute script runanki

KMail switched language from local language to English. Same with KOrganizer and some other. KDE seems to have stayed in local language but some programs and parts are English.


#53

I just updated my box with an Nvidia GTX 960 in it and maybe I’m a bit thick, but I can’t see how I can enable the Nvidia 410 driver. Manjaro Settings Manager show Nvidia 390xx installed and active. I don’t see the 410 series with mhwd and they don’t appear in repositories either when I search for them.


#54

Hardware Configuration (in Manjaro Settings) and install video-nvidia instead of video-nvidia-390xx

video-nvidia is the latest 4xx package.


#55

That’s correct, I took a look and managed to fix it. Thanks!

The only thing remaining is that it’s not showing me the manufacturer logo, only a black screen.


#56

Yeah, it’s not showing the manufacturer logo for me, either.


#57

4.14 - XFCE - Lenovo

At the first reboot after the update, keyboard and mouse inputs were not detected.
After a hardware reboot (power-switch initiated), everything works perfectly.


#58

[quote=“Vitorvlv, post:55, topic:62076, full:true”]
That’s correct, I took a look and managed to fix it. Thanks!

The only thing remaining is that it’s not showing me the manufacturer logo, only a black screen
@philm, It worries (manufacturer logo). Is there a solution to this issue?


#59

Is the logo shown in UEFI? Is it a laptop or desktop?


#60

UEFI, desktop, no logo, only a black screen.


#61

Same issue here, desktop. ASUS MB. Logo shows in UEFI and doesn’t later.

Works perfectly fine on Lenovo desktop EDIT: laptop.