[Stable Update] 2018-10-08 - Kernels, Gnome 3.30, Cinnamon, Deepin, Pamac, SPL/ZFS

update
stable

#124

Update crashed middle of installing updates and now at boot I get kernel panic.

Lucky for me I had a live usb-stick. Now I am trying to find what is broken.

Using manjaro-chroot to get access to fix thing, runing pacman doesnt do anything. And sudo pacman gives me:
sudo: error in /etc/sudo.conf, line 0 while loading plugin “sudoers_policy”
sudo: unable to load /usr/lib/sudo/sudoers.so: /usr/lib/libssl.so.1.1: file too short
sudo: fatal error, unable to load plugins

And looking /var/log/pacman.log last lines are when I started the update that failed.

Tested pacman --help it does nothing


#125

With chroot you are root. No sudo needed.

❯ pacman --help
Verwendung:  pacman <Operation> [...]
Operationen:
    pacman {-h --help}
    pacman {-V --version}
    pacman {-D --database} <Optionen> <Paket(e)>
    pacman {-F --files}    [Optionen] [Paket(e)]
    pacman {-Q --query}    [Optionen] [Paket(e)]
    pacman {-R --remove}   [Optionen] <Paket(e)>
    pacman {-S --sync}     [Optionen] [Paket(e)]
    pacman {-T --deptest}  [Optionen] [Paket(e)]
    pacman {-U --upgrade}  [Optionen] <Datei(en)>

Benutzen Sie 'pacman {-h --help}' zusammen mit einer Operation für verfügbare Optionen



#126

Somebody care to explain what this command does? Also quiet aka smooth boot-up still shows logs before/after boot. Exactly same way before installation. This is with all steps followed & kernel parameters in grub confirmed.


#127

It delete every “fsck” in file mkinitcpio.conf .


#128

Seriously.


#129

Some light reading for your next adventure:

https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader


#130

If you have an issue to be solved, please use a separate thread and link to it here if you feel that is necessary.

It’s not reasonable to track/solve many different issues in a single thread. Even if possible, doing so makes the solution impossible to find in the future.


#131

me, too.

sudo nemo .

(nemo:22208): GLib-GIO-CRITICAL **: 04:45:51.583: g_dbus_proxy_new_sync: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(nemo:22208): GLib-GIO-CRITICAL **: 04:45:51.583: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
Segmentation fault

#132

The tray icons in the xfce panel got a black background after this update. Manually restarting the panel solves this problem in most cases (sometimes/randomly even after restarting the panel, there appear some artifacts around the icons). Resizing the tray panel plugin also leads to graphical artifacts. After each restart the problem reappears.

It seems, that the tray icons dont refresh properly, for example if the network status changes, the network manager tray icon changes, but puts the new icon ontop of the old one, so that both can be seen, which looks messed up …

I am using xfce4-panel 4.12.2-1. The problem appears with any theme/icon theme.


#133

Install went fine on desktop (Manjaro Gnome Edition installed around 2016), but i do have a strange problem with the file manager crashing/disappearing at random, other then that all seems fine so far and also fixed my unmount old root error on shut down/reboot:)

On my HP Laptop (Gnome Edition installed 2018) the install went fine but had a fair few problems after reboot, would take a while to the list problems i had, but the main one was on shut down it would just freeze at powering down and had to resort to 10 second hold on power button, today i install Manjaro Deepin 17.1.12 and all is ok now with the laptop other then when changing to Kernel 4.18 it would boot with an error about unable to load kernel modules, but fixed it by re-installing deepin-anything.


#134

Install “dbus-x11”


#135

I needed to change to first two lines in my grub config file to =0 , then add the third line(?) for grub-quiet to not show the grub menu. My Dell laptop logo will flash a couple of times, so I’m still tinkering with my grub to make the process more seamless.

GRUB_DEFAULT=0
GRUB_TIMEOUT=0
GRUB_RECORDFAIL_TIMEOUT=$GRUB_TIMEOUT

#136

The release is 18.0.0-rc now, smooth update.
Do I need install xfce-gtk3 after 18.0 release?


#137

It seems to be a consequence of fixing this issue: https://gitlab.manjaro.org/applications/pamac/issues/479.

But it still continues to do the task, even if it doesn’t looks like it. Do not cancel the transaction.


#138

XFCE and a deepin updated without a problem, thanks for your hard work.


#139

Looks like the linux419-catalyst package did not get updated. Try installing and running the 4.18 kernel for now. :slightly_smiling_face:


#140

According to Gitlab it got updated 2 days ago. Which would have been the 8th of October.


#141

That update has not yet arrived on testing branch. My assumption is that stable is still with the update 1:15.201.1151-0.19 that has “Build date: 25/09/18”. However the kernel in this update has 4.19rc7.1007.g0238df6-1 with “Build date: 08/10/18” (And this is what https://gist.githubusercontent.com/philmmanjaro/c93d87e548c6cc92ecdc639884642ceb/raw/8df8c3d66c36db76dfc04b3b2e18f1f102491b43/boxit-stable-2018-10-08.txt contains.)

But perhaps that update is accessible from another repo, like unstable?

(p.s. My suspicion is that @philm has an upload script that needs a minor adjustment. :wink:)


#142

According to repology it is in Stable, Testing and Unstable.

Are you sure your mirror is up to date according to repo.manjaro.org?
Remember, pkgrel’s are nor software updates, just PKGBUILD changes.


#143

No. Repology lists the pkgrel .19 whereas Gitlab has .23.

The package in question is a kernel module and needs to be built against a specific kernel- (the 4.19rc7 here) as far as I am aware.

(Btw it is not my issue, I am on testing branch and run nvidia and do not have this problem, just trying to help out. :smile:)

My mirror was last updated (fastrack) an hour ago when I did the lastest testing update.