[Stable Update] 2018-10-08 - Kernels, Gnome 3.30, Cinnamon, Deepin, Pamac, SPL/ZFS

update
stable

#103

I just hope Breath colour scheme for KDE and Breath GTK theme won’t be deleted. This combo is amazing in terms of consistent light look of apps.


#104

Quick note here, not using a graphical package manager on gnome is simply because things may look broken / gnome won’t behave right when it is updated that way. It does not actually break the update.

Your complaining is misplaced. If you don’t mind graphical glitches and perhaps some oddities until reboot, then there is no harm in updating without using the terminal.

There is really nothing of substance to discuss here.


#105

Hi all, this is my first post and first of all I must thank the developers for the great distro and support, and the community for the great forum.

I’ve used Manjaro XFCE Stable on my main system (Asus Zenbook UX310UQ i7-7500U) for about 5 months, yesterday’s update was the first that brought a couple of problems.

When I got the update notification and came to this topic it had just been started and the suggestion to use the terminal wasn’t there yet, the title was still [Stable Update] - TBA, neither there were any problems reported yet obviously. Now I’ve learned my lesson to wait a bit longer next time. The drawback of consistently smooth updates is that you get too confident :wink: in fact I never do this with other software, I normally wait for a few days before updating.

Anyways the problems are with Thunar and NetworkManager.

Thunar: after updating and rebooting yesterday all was ok with it. This morning though as I woke up my laptop Thunar couldn’t be started in any way, starting it from terminal just hangs. No entries are generated via journalctl. Starting it as root works ok though. I tried to: reinstall Thunar, rename my .config/Thunar folder and the 3 files in it (in succession), remove actions one by one on my uca.xml file, copy the root’s accels.scm file contents to my accels.scm file, change my theme, switch to kernel 4.14.74 (from 4.18.12), install dbus-x11, all to no avail. I’ve now downloaded Nautilus as a fall back.

NetworkManager: since after the update it’s preferring my 2.4Ghz SSID to my 5Ghz SSID. They are named differently and the 5Ghz SSID has a higher priority set, this has been working great until yesterday. Now the 5Ghz SSID will only connect if I uncheck the “Connect automatically” box for the 2.4Ghz SSID. I have deleted and reconfigured the 5Ghz SSID, no change. Also the same on different kernels.

Any hints appreciated.


#106

I have Adapta Nokto (3.94) on Cinnamon (414 LTS) from the day it was installed, and theme preview and switching works normally. Hope to see Adapta get some new maintainer.


#107

Learn about BTRFS file system. You can revert system update changes within seconds to the state before update and hold update of a specified package and do again all other updates.


#108

Well that is unfortunate, but you could have avoided a breakage several ways. The best way is to wait a couple of days before performing an update. That gives you time to read the update thread to determine if there might be remedial steps you need to take.

I perform every update from the terminal as that is by far the safest and best method for doing a large system update. As a mater of fact I go even one step further and do all my updates from the TTY. Maybe a little bit of overkill on the safety front, but I figure better safe than sorry.


#109

I reluctantly give this update a “no issues …” vote.

One of the recent past updates has, however, overwritten my mirrorlist and replaced my fast South African mirror on top with a slow UK mirror (SA mirror nowhere to be found in the list anymore). Same thing on my other PC, which had the first PC as a mirror on top of the mirrorlist - complete new random list of mirrors. If the update process is going to change my mirrorlist by itself I will need to first check/edit/correct the mirrorlist before each update, something I had never needed to do.

Edit: I found that my /etc/pacman-mirrors.conf has been replaced a month ago. I added NoUpdate = True to this new file. Hope it still works.


#110

First, performed the update of Manjaro with Xfce desktop and the “old“ Vertex-Maia theme flawlessly (at least none seen yet).

Second, @tbg, I am going the same way you mentioned. Just to double-check: Updating from TTY means issuing a CTRL-ALT-F3, then logging in and issuing the customary sudo pacman -Syyu. Correct? Updating from a terminal would mean to use the terminal from the graphic desktop, which in rare instances might be not as clean as the aforementioned TTY route.

Third, just a little contribution wrt the “stable rolling release“ debate. I want all the latest software (and no PPAs etc), so I chose to quit with Linux Mint or Ubuntu and go for two - sic! just in case something breaks - rolling releases in parallel, openSUSE Tumbleweed KDE and Manjaro Xfce. Both do offer software versions in sync, e.g. VirtualBox. I want two different desktops, again in case s.th. breaks. And I did learn how to handle them: With Tumbleweed, one has to live with torrential floods of updates, but there is almost no need to get forum information before doing an update. Manjaro Stable is less demanding on update volume and frequency, but reading the forum is sort of mandatory.

In fact, I do love both these rolling releases the same. Wouldn‘t part with either one!

Thanks, team!


#111
mirror.is.co.za/mirrors/manjaro.org South Africa http 02:52 Up to date Up to date Up to date
manjaro.mirror.ac.za South Africa http, ftp 01:24 Up to date Up to date Up to date

https://repo.manjaro.org/


#112

You are correct updating from the terminal in the non graphical TTY environment is the best way to avoid issues with a problematic update.


#113

Thanks, I know about those two mirrors and they are supposed to be at the top of my mirrorlist. I would like to keep it so, as well as for my own DIY mirror.
(I have edited my first post while you were replying.)


#114

Like mepi0011, I too had a crash with the update process and then my reboots fell apart into kernel panics. I’m getting errors like this after the grub menu.

failed to execute /init
kernel panic not synching no working init found
try passing init options to kernel

I tried many suggestions about repairing grub (https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader) and have reinstalled the kernels a few times via chroot and the install USB. Any other suggestions short of reinstalling the base system (which is the route mepi0011 took)? I have a separate home partition so a reinstall would not be too terrible.

Thanks.


#115

If I had done the update this way, I may not have had the problems that I did in post #33. I had always assumed doing the update in a graphical terminal window was just as good. I learn something new every day.


#117

no DL-speed are displayed


#118

I had the exact same issue, crash during update in terminal, reboot killed grub and couldn’t boot.

How I fixed it and was able to get log in without a reinstall:

  • chroot using usb key
  • finish update (had 67 more to go out of 236 updates)
  • re-install grub

4.18 and 4.14 kernels still wouldn’t boot because hooks were killed, so I installed 4.19 which forced the rebuild of hooks etc

Reboot and back into Manjaro


#119

i want my system-restart/shotdown-button on the right side.
after reboot, the button is left from the clock.
this issue was not before the update.

vor%20neustart
nach%20neustart


Deepin: reinstall taskbar possible?
#120

Did you try right click, move?

Ick meente doch och det andere rechts, wah :wink: , @zwiloe move it :smiley:


#121

xps9550,KDE,linux44,233 package, update OK


#122

it is only movable with the left click. right open a menu.


#123

interesting… on my laptop is no problem…
maybe not a problem from the upgrade…
there was some damaged blocks… i must run fsck… maybe the problem comes from this…