[Stable Update] 2018-09-09 - Kernels, KDE Plasma & Apps, Browsers, Mesa, Deepin, AMDVLK

update
stable

#70

As concerns gufw this isn’t a first time, I’d recommend you try the following through the terminal(Konsole in KDE Plasma, of course :wink: ) systematically after each re-boot as it’s a pretty painless operation to say the least: sudo gufw-pkexec

The GUI will come up automatically, and all you have to do is activate it :slight_smile:


#71

Thanks, that works fine.
I still wish someone fixes this. I guess that this update removed, changed permissions or changed the version of some dependency that screwed both gufw and firestarter.
Depending on what I try I even get messages that enps02 is not available when I know it is because I’m using it like now.

Perhaps Philm will have a word of wisdom on this one :wink:


#72

After this update i’m having a problem with grub menu, which shows up, but after about two minutes of delay. (i have installed windows 10, 3x manjaro and kubuntu 18.04). Grub menu starts, and than nothing, the screen is black, and i have to wait cca 2 minutes to actually see the menu. (it’s a bios system, just to add)
Tried to reinstall grub (twice, from an installed (kde) system, second time from a live-usb), then installed the grub using another manjaro installation (xfce, freshly updated too, just like the kde version), but nothing changed. Google didn’t help, so far. Any idea?


#73

Start a new topic for this to investigate properly. :wink:


#75

Well, i thought it was the problem with this update and now i see that nobody has reported this or something similar yet …So, probably you are right, it could be a kind of ‘this update + my pc problem’. So…i’ll wait a bit and then start a new topic.
Thanks.


#77

It would seem that it had been fixed just before the summer after an update I had…and inbetween time I distro hopped, then, came back and downloaded the last ISO to find the problem back again…


#78

I confirm: After updating glib2 all custom action icons in the context menu of Thunar are visible again. Thank you :slight_smile:


#79

To complete this side note: There’s a known bug in german language pack for firefox 62. I reportet it on bugzilla. They are working on it. :slight_smile:


#80

Not sure why you dredged up my rather old post, but FYI my GUFW has continued to run just fine here, & has done so since that old solution. Just rechecked again now – launched & running well.


#82

Hello all,

since this update my monitor does not wake up from sleep anymore.
Is there anybody else with the same problem?

r100gs

System:    Host: ryzen Kernel: 4.18.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1  
          Desktop: KDE Plasma 5.13.5 Distro: Manjaro Linux  
Machine:   Type: Desktop Mobo: MSI model: X370 SLI PLUS (MS-7A33) v: 2.0 serial: <filter>  
          UEFI: American Megatrends v: 3.60 date: 09/20/2017  
CPU:       Topology: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 4096 KiB  
          flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 96016  
          Speed: 3196 MHz min/max: N/A Core speeds (MHz): 1: 3196 2: 3193 3: 3194 4: 3199 5: 3196 6: 3194  
          7: 3193 8: 3178 9: 2859 10: 3124 11: 3177 12: 3195 13: 3199 14: 3198 15: 3198 16: 3197  
Graphics:  Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nvidia v: 396.54 bus ID: 23:00.0  
          Display: x11 server: X.Org 1.20.1 driver: nvidia resolution: 3840x2160~60Hz  
          OpenGL: renderer: GeForce GT 1030/PCIe/SSE2 v: 4.6.0 NVIDIA 396.54 direct render: Yes  
Audio:     Device-1: NVIDIA GP108 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 23:00.1  
          Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel v: kernel  
          bus ID: 25:00.3  
          Device-3: Philips (or NXP) SPC 1300NC PC Camera type: USB driver: snd-usb-audio,uvcvideo  
          bus ID: 5-1:2  
          Sound Server: ALSA v: k4.18.6-1-MANJARO  
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 v: 8.045.08-NAPI  
          port: f000 bus ID: 1e:00  
          IF: enp30s0 state: up speed: 1000 Mbps duplex: full mac: <filter>  
          IF-ID-1: docker0 state: up speed: N/A duplex: N/A mac: <filter>  
          IF-ID-2: veth589835f state: up speed: 10000 Mbps duplex: full mac: <filter>  
          IF-ID-3: veth63f0c96 state: up speed: 10000 Mbps duplex: full mac: <filter>  
          IF-ID-4: veth6870f52 state: up speed: 10000 Mbps duplex: full mac: <filter>  
          IF-ID-5: veth6ea18ea state: up speed: 10000 Mbps duplex: full mac: <filter>  
          IF-ID-6: veth93f00e6 state: up speed: 10000 Mbps duplex: full mac: <filter>  
          IF-ID-7: vetha49e4b2 state: up speed: 10000 Mbps duplex: full mac: <filter>  
          IF-ID-8: vethb8fa0c5 state: up speed: 10000 Mbps duplex: full mac: <filter>  
Drives:    Local Storage: total: 11.39 TiB used: 5.18 TiB (45.5%)  
          ID-1: /dev/sda vendor: Western Digital model: WD40EZRZ-00GXCB0 size: 3.64 TiB  
          ID-2: /dev/sdb vendor: Crucial model: CT525MX300SSD1 size: 489.05 GiB  
          ID-3: /dev/sde vendor: Seagate model: ST8000AS0002-1NA17Z size: 7.28 TiB  
Partition: ID-1: / size: 191.24 GiB used: 51.60 GiB (27.0%) fs: ext4 dev: /dev/sdb2  
          ID-2: /home size: 270.85 GiB used: 158.78 GiB (58.6%) fs: ext4 dev: /dev/sdb4  
          ID-3: swap-1 size: 17.25 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3  
Sensors:   System Temperatures: cpu: 34.0 C mobo: 39.0 C gpu: nvidia temp: 44 C  
          Fan Speeds (RPM): fan-1: 0 fan-2: 433 fan-3: 806 fan-4: 0 fan-5: 603 fan-6: 0 gpu: nvidia fan: 35%  
          Voltages: 12v: N/A 5v: N/A 3.3v: 3.36 vbat: 3.36  
Info:      Processes: 429 Uptime: 53m Memory: 31.43 GiB used: 10.52 GiB (33.5%) Init: systemd Compilers:  
          gcc: 8.2.1 clang: 6.0.1 Shell: bash v: 4.4.23 inxi: 3.0.21

#83

Because your post was pertinent, and in that post there were two “solutions”, not only the one I use, myself. So, it could be useful…and @strawman might find it so as well :slight_smile:

I didn’t use the other solution, myself, not being as proficient as some with Linux :wink: . I’m glad your solution worked and continues to do so :+1:


#84

I now think i got your post about 180 degrees wrong, & thus my post to you was inappropriate; sorry about that. Somehow i misunderstood who had what problem. Sigh. :blush:


#85

This post’s subject matter might be unrelated to this Stable Update [which i did yesterday, & everything has seemed fine til ~an hour ago], but given the weird unprecedented nature of the symptom my Tower just exhibited, i can’t say that it is OR is not related to the Update. Beats me.

  1. Successfully Resumed Tower [Plasma 5.13.5] this morning from its overnight Suspend [kernel 4.14.68-1].
  2. Spent ~9 hours using Tower fulltime, without problems [until The Incident], using simultaneously Firefox [firefox-developer-edition 63.0b4-1], Thunderbird [60.0-4], Dolphin [18.08.1-2], Vivaldi-Snapshot [2.0.1296.4-2], Shutter [0.94.2-1] & Radiotray-NG [radiotray-ng-git 0.2.4+28+16c7c51-1].
  3. I have an i7 cpu & 32 GB RAM, so my resource usage was modest vs capacity.
  4. Finished needing Vivaldi, so closed it.
  5. Immediately Tower fully froze… no keyboard or mouse response, even Magic SysRq REISUB was unresponsive. Had to press Tower’s physical Reset button.
  6. Given the enforced reboot i opted to first boot a LiveUSB & run a filecheck on SSD’s ext4 / partition, & then HDD’s ext4 /data partition [cannot test SSD’s /home partition as is LUKS-encrypted].
  7. Results:
Summary
[manjaro@manjaro ~]$ sudo fsck -f /dev/sda2
fsck from util-linux 2.30.2
e2fsck 1.43.7 (16-Oct-2017)
/dev/sda2: recovering journal
Clearing orphaned inode 2748658 (uid=0, gid=0, mode=0100644, size=31520)
Clearing orphaned inode 130963 (uid=0, gid=0, mode=0100644, size=158568)
Clearing orphaned inode 411945 (uid=0, gid=0, mode=0100644, size=35296)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong (8179510, counted=8087349).
Fix<y>? yes
Free inodes count wrong (3400079, counted=3398812).
Fix<y>? yes

/dev/sda2: ***** FILE SYSTEM WAS MODIFIED *****
/dev/sda2: 533844/3932656 files (0.2% non-contiguous), 7642315/15729664 blocks
[manjaro@manjaro ~]$ 



[manjaro@manjaro ~]$ sudo fsck -f /dev/sdb3
fsck from util-linux 2.30.2
e2fsck 1.43.7 (16-Oct-2017)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free inodes count wrong for group #0 (8178, counted=8177).
Fix<y>? yes
Free inodes count wrong (118573912, counted=118573911).
Fix<y>? yes

Seagate: ***** FILE SYSTEM WAS MODIFIED *****
Seagate: 906409/119480320 files (0.5% non-contiguous), 272544858/477892608 blocks
[manjaro@manjaro ~]$ 
  1. Subsequent standard reboot [kernel 4.14.68-1] was uneventful, & behaviour is again normal atm.
  2. Blimey!

[SOLVED] Entire operating system freezes
#86

Yeah!
This update fixed my problems with youtube-dl (which was really a minor to me!) and a bigger issue with my HP printers where all printouts stayed in the queue (Filter failed) but where printed anyway.
I love you girls and boys!


#87

I’ve had freeze (total system) issues with the last two (61 and 62) releases of Firefox, very
intermittent though.


#88

No probs :blush:


#89

After some time, pamac tray icon freezes and I can’t launch it anymore by double clicking it. If I try clicking Software Update from menu, pamac works and checks for update, but if I press Back button, whole desktop (Cinnamon, kernel 4.14) freezes and I have to do hard reboot. Any suggestions? Thiss happened 3 times already.


[Testing Update] 2018-09-08 - Mesa, Firefox-Dev, Ghostscript
[Stable Update] 2018-09-13 - Kernels, KDE Framework, SPL/ZFS, Octopi
#90

The Wiki post had some recommendations that appeared like in April-May. I removed all the old stuff up to “Kernel 4.9 issue” which said “v.4.9.107-2 is known to be working” (we are at 4.9.12X right now).


#91

Yeah but it seems to me like drawing a bit of a long bow in my case to finger Firefox, when it was the closing of Vivaldi that made all hell break loose. As i said though, i really have no idea whatsoever why such a bad thing could result from an innocuous action like closing a program.

That aside, thanks for your info, which is upsetting… given over past weeks i have migrated myself from Vivaldi to Firefox, the possibility i’ve inadvertently chosen a trigger-happy browser is a bit disturbing.

Alternatively, maybe my Tower’s poltergeist is now on a time-share scheme with your pc [don’t worry if you don’t get my meaning; tis a bit of a running in-joke here].


#92

I am facing the same problem of the Software Manager icon freezing(in XFCE DE for me) and then causing system freeze. I also noticed that the system does not restart or reboot from the power menu, it just logs me off. From there I need to hard shutdown by holding the power button.