[Stable Update] 2018-09-09 - Kernels, KDE Plasma & Apps, Browsers, Mesa, Deepin, AMDVLK

update
stable

#33

So I decided to follow step 3 when installing amd-ucode, upon rebooting I got a message about how intel-ucode.img wasn’t found then a kernel panic. Reinstalling intel-ucode fixed that.

The briefest of research suggests I probably needed to disable CONFIG_MICROCODE_INTEL for the kernel config, except I have no clue how to do that and google hasn’t been very useful in this case.


#34

XFCE, 4.18.6

Everything went smoothly, albeit the following minor warning:

directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

Luckily, this was easy enough to resolve by running sudo chmod 700 /var/lib/samba/private/

Thanks for the hard work!


#35

hmm, with a new clean profile the problem still exists.
I’ll write a bug report on bugzilla.


#36

Shutdown still with delay (4.18), and workaround for that?


#37

pcmanfm-qt “Open as Root” not work.
My solved
downgrade

dbus


#38

Hi
Problems with youtube-dl:

ERROR: Signature extraction failed: Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/youtube_dl/extractor/youtube.py", line 1210, in _decrypt_signature
    video_id, player_url, s
  File "/usr/lib/python3.7/site-packages/youtube_dl/extractor/youtube.py", line 1121, in _extract_signature_function
    res = self._parse_sig_js(code)
  File "/usr/lib/python3.7/site-packages/youtube_dl/extractor/youtube.py", line 1182, in _parse_sig_js
    jscode, 'Initial JS player signature function name', group='sig')
  File "/usr/lib/python3.7/site-packages/youtube_dl/extractor/common.py", line 972, in _search_regex
    raise RegexNotFoundError('Unable to extract %s' % _name)
youtube_dl.utils.RegexNotFoundError: Unable to extract Initial JS player signature function name; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; see  https://yt-dl.org/update  on how to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.
 (caused by RegexNotFoundError('Unable to extract \x1b[0;34mInitial JS player signature function name\x1b[0m; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; see  https://yt-dl.org/update  on how to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.')); please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; see  https://yt-dl.org/update  on how to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.


#40

https://github.com/rg3/youtube-dl/pull/17464 youtube-dl 2018.09.08 fixes that issue


#41

I just tested search using StartPage and it works in the Firefox 62.0 URL Box.


#42

Many thanks for answer.
Waiting…


#43

Yahoo !

Installed updates and rebooted for the new linux kernal.

2018-09-09 10:30] [ALPM] upgraded network-manager-applet (1.8.16-1 -> 1.8.18-1)
[2018-09-09 10:30] [ALPM] upgraded nm-connection-editor (1.8.14-1 -> 1.8.18-1)

Tested and VERIFIED this ( 1.8.18-1 ) works again. Let me go find my post and mark it as solved.

Connected on a New VPN Connection now.

Looks like one other thing might have gotten fixed. Package Manager was RED before I rebooted. Previously rebooting did not change this. But this time after reboot, Package Manager was no longer Red.


#44

Plasma DE, kernel 4.18.6-1. Smooth ride after re-boot.

Thanks to The Team & Community!:+1:


#45

icewm submenus deleted.


#46

Seems like in VLC 3.0.4 RTP streams are broken. Nothing useful in the error log though


#47

Looks like I’m having issues again with the new version of vlc 3.0.4. Xfce panel sporadically showing on fullscreen timeline click, minor video flickering again when clicking off/on vlc window, and immediate mouse cursor disappearance once the cursor hits vlc video. Pinging @korealinux?


#48

If you really need the new version of youtube-dl right now, you can build a package yourself. Here’s a PKGBUILD for youtube-dl (really poorly made since there’s no verification at all, but hey, it’s just a temporary workaround and it isn’t critical software anyway).

PKGBUILD
# $Id$
# Maintainer: Eric Bélanger <eric@archlinux.org>
# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>

pkgname=youtube-dl
pkgver=2018.09.08
pkgrel=0
pkgdesc="(TEMP) A small command-line program to download videos from YouTube.com and a few more sites"
arch=('any')
url="http://rg3.github.io/youtube-dl/"
license=('custom')
depends=('python' 'python-setuptools')
optdepends=('ffmpeg: for video post-processing'
            'rtmpdump: for rtmp streams support'
            'atomicparsley: for embedding thumbnails into m4a files'
            'python-crypto: for hlsnative downloader')
source=(http://youtube-dl.org/downloads/${pkgver}/${pkgname}-${pkgver}.tar.gz)
sha256sums=('SKIP')

prepare() {
  cd ${pkgname}
  sed -i 's|etc/bash_completion.d|share/bash-completion/completions|' setup.py
  sed -i 's|etc/fish/completions|share/fish/completions|' setup.py
}

package() {
  cd ${pkgname}
  python setup.py install --root="${pkgdir}/" --optimize=1
  mv "${pkgdir}/usr/share/bash-completion/completions/youtube-dl.bash-completion" \
     "${pkgdir}/usr/share/bash-completion/completions/youtube-dl"
  install -Dm644 youtube-dl.zsh "${pkgdir}/usr/share/zsh/site-functions/_youtube-dl"
  install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}

Essentially, I’ve just modified the official Arch Linux PKGBUILD a little bit.

Put the PKGBUILD somewhere among your personnal files, run a makepkg -si and you should be good to go.

EDIT: Added the youtube-dl problem in Wiki post. Suggested to wait for an update, I can add this workaround too.


#49

Everything went smooth in my Machine!

Kernels: linux414, linux49
DE: KDE!


#50

Terrific update. KDE on Linux 4.14.x. No issues.


#51

In fact I am experiencing an minor issue with XFCE4. After the update all the application icons in the context menu of Thunar are missing. They were replaced by an exclamation mark icon (see the screenshot below).

grafik


#52

Seems the latest updates borked py3status on my i3wm setup (Manjaro i3 community edition) . After the updates trying to to run py3status returns:

Traceback (most recent call last):
  File "/usr/bin/py3status", line 11, in <module>
    load_entry_point('py3status==3.12', 'console_scripts', 'py3status
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", 
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", 
    return ep.load()
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", 
    return self.resolve()
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", 
    module = __import__(self.module_name, fromlist=['__name__'], leve
ModuleNotFoundError: No module named 'py3status'

Switching to AUR py3status-git resolves the issue.


#53

having the same issue here