[Stable Update] 2018-09-09 - Kernels, KDE Plasma & Apps, Browsers, Mesa, Deepin, AMDVLK

update
stable

#1

Hi community,

Welcome to another stable update. So what do we have with this one?

  • added some more L1TF patches to most of our kernel series
  • texlive and gcc got updated to the latest versions
  • KDE Plasma5 is now at 5.13.5
  • KDE Apps got updated to 18.08.1
  • manjaro-tools v0.15.9 released
  • mesa got updated to 18.1.8
  • added AMDVLK
  • updated our deepin and xfce4-gtk3 packages
  • fixed crashes within ghostscript
  • updated most of our browsers
  • the usual upstream rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

For more info about L1TF please watch this video:


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.121 [EOL]
  • linux44 4.4.154
  • linux49 4.9.125
  • linux414 4.14.68
  • linux417 4.17.19 [EOL]
  • linux418 4.18.6
  • linux419 4.19-rc2
  • linux414-rt 4.14.63_rt40
  • linux416-rt 4.16.18_rt11

Package Updates (Sun Sep 9 09:06:27 CEST 2018)

  • stable community x86_64: 876 new and 856 removed package(s)
  • stable core x86_64: 39 new and 37 removed package(s)
  • stable extra x86_64: 560 new and 654 removed package(s)
  • stable multilib x86_64: 18 new and 17 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Vulkan not loading with AMDGPU & AMDVLK
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


Thunar Custom Actions icons are missing

After the update all the application icons in the context menu of Thunar are missing. They were replaced by a “File not found” icon. It is reported upstream, a fix is coming soon…
If you can’t wait:

pamac install https://manjaro.moson.eu/pool/overlay/glib2-2.58.0-1.1-x86_64.pkg.tar.xz

youtube-dl : “ERROR: Signature extraction failed:”

This bug is fixed in version 2018.09.08 of youtube-dl. Unfortunately, only version 2018.09.01 is currently available in Manjaro’s official repositories.

Wait for an update.

(UPDATE September 10th, 2018: Version 2018.09.10 now available in repos.)


AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Items from previous update sets

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Application launcher icon is not resizeable
#3

Desktop Cinnamon kernel 4.14 updated fine.


#4

Update went fine. Thank you.

But i noticed that the keyword search doesnt work anymore after reopen firefox. Only g for google works. A for searching on amazon doesnt work after firefox restart (Firefox settings > Search).

Is this a problem of firefox? If so i would open a bug report.


#5

Great Update, but now problems as usual.

Thanks to the Manjaro-Team
caho


#6

No problem with Gnome! Thanks!
:mage::raised_hands::dragon_face:


#7

Man, that was fast!!!


#8

7 posts were split to a new topic: When will Manjaro 18.0 stable be released?


#12

KDE/kernel 4.18.6 … everything is fine
i also got yarn as an orphan package i uninstalled it and everything still fine


#14

KDE and kernel 4.14 went smoothly.
As usual :wink:


#17

Everything just right, as always. Thanks.


#18

Thanks to the ghostscript update, jobs once more remove themselves from the print queue once printing has completed. I have now removed the “IgnorePkg = ghostscript” that I’d needed in pacman.conf. Happy!!


#19

Budgie with Kernel 4.18, no issue to report. Thanks to the team!


#20

flawless update on KDE, thanks for your awesome work, team! :smiley:


#21

smooth update till now, except for these fxxxing vlc and catfish bugs that are still present after months & months


#22

still works fine for me, so probably no general problem :slight_smile:


#23

Updates without problems!
LXQT with Kernel 4.14
XFCE with Kernel 4.18
Thanks!


#24

some fonts are broken after the update
name of the file in the example below is “test тест” (the second word is in russian)

edit:
back to normal after the system restart


#25

I just did a test on my end. Which DE do you use? Works on XFCE:

xfce4-gtk3


#26

I use xfce. Fonts broke while I was running the update
edit:
It’s back to normal after restart