[Stable Update] 2018-09-02 - Deepin, Pamac, Linux419, Firefox-Dev, Upower

update
stable

#43

Same issues. a completely different look and feel with the browser Google-Chrome.


#44

I suppose I could remove the patched FF and then re-add it, but is there a better way?

$ sudo pacman -Syyu
:: Synchronizing package databases...
 core                                                       146.1 KiB  2.50M/s 00:00 [################################################] 100%
 extra                                                     1795.7 KiB  5.85M/s 00:00 [################################################] 100%
 community                                                    4.8 MiB  4.94M/s 00:01 [################################################] 100%
 multilib                                                   181.4 KiB  4.79M/s 00:00 [################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: firefox and firefox-kde-opensuse are in conflict. Remove firefox-kde-opensuse? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: firefox and firefox-kde-opensuse are in conflict

#45

Everything went fine, but got this little curiosity:

(31/44) upgrading linux417                                                  [##########################################] 100%
>>> NOTE, 4.17.19 is the last release of the 4.17.y kernel.
    It is now end-of-life.
    
    It is recommend to move on to linux416-series.
    Use followed cmd to do that: 'sudo mhwd-kernel -i linux418'

So someone should probably fix that typo in the recommendation.
Otherwise great work! :grin:
(and don’t worry, I’m already at 418, I just like to keep old kernels for a bit in case something goes wrong )


#46

Think I’ll start a betting pool, I pick the day and you guys guess how long it takes 4.19 (and 4.18 before it) to shut down. Last two weeks that varied between 2 seconds and 3 minutes. I’d be worried
but a fix will show up sooner or later.


#47

I could not upgrade, nor can I simply remove the patched FF:

$ sudo pacman -Rns firefox-kde-opensuse
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: firefox-i18n-en-us: removing firefox-kde-opensuse breaks dependency 'firefox>=61.0.2'
$ sudo pacman -Rns firefox-i18n-en-us
checking dependencies...

Packages (1) firefox-i18n-en-us-61.0.2-1

Total Removed Size:  0.44 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
(1/1) removing firefox-i18n-en-us                                                    [################################################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
$ sudo pacman -Rns firefox-kde-opensuse
checking dependencies...

Packages (2) kmozillahelper-5.0.2-1  firefox-kde-opensuse-61.0.2-1

Total Removed Size:  126.65 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
(1/2) removing firefox-kde-opensuse                                                  [################################################] 100%
(2/2) removing kmozillahelper                                                        [################################################] 100%
:: Running post-transaction hooks...
(1/3) Updating icon theme caches...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Updating the desktop file MIME type cache...
$ sudo pacman -Syyu
:: Synchronizing package databases...
 core                                                       146.1 KiB  2.16M/s 00:00 [################################################] 100%
 extra                                                     1795.7 KiB  3.49M/s 00:01 [################################################] 100%
 community                                                    4.8 MiB  4.43M/s 00:01 [################################################] 100%
 multilib                                                   181.4 KiB  5.37M/s 00:00 [################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) chromium-69.0.3497.81-0

Total Download Size:    46.21 MiB
Total Installed Size:  164.59 MiB
Net Upgrade Size:        1.15 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 chromium-69.0.3497.81-0-x86_64                              46.2 MiB  4.74M/s 00:10 [################################################] 100%
(1/1) checking keys in keyring                                                       [################################################] 100%
(1/1) checking package integrity                                                     [################################################] 100%
(1/1) loading package files                                                          [################################################] 100%
(1/1) checking for file conflicts                                                    [################################################] 100%
(1/1) checking available disk space                                                  [################################################] 100%
:: Processing package changes...
(1/1) upgrading chromium                                                             [################################################] 100%
:: Running post-transaction hooks...
(1/3) Updating icon theme caches...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Updating the desktop file MIME type cache...


[Testing Update] 2018-09-06 - KDE Apps, Deepin, XFCE4-GTK3, Manjaro-Tools, Firefox-Dev
[Stable Update] 2018-09-21 - Kernels, Pamac, Palemoon, Mesa 18.2.1
#48

After the last update a few days ago. Adapta-nokto-eta-maia and Adapta-nokto-maia theming controls theming uses a dark color for textarea boxes on Firefox, but not Chrome for Hacker News and for the button.

You can see it on HackerNew’s reply boxes.

https://news.ycombinator.com/news

I would prefer it goes back to a light color.

Firefox gives a light color on reply box for this (Manjaro) forum so it is inconsistent.

I am on Manjaro Cinnamon.


#49

After my updates…

systemctl status systemd-modules-load 

● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd- modules-load.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Fri 2018-09-07 11:33:51 +08; 12min ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 1385 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 1385 (code=exited, status=1/FAILURE)

Sep 07 11:33:51 manjaro-lappy systemd[1]: Starting Load Kernel Modules...
Sep 07 11:33:51 manjaro-lappy systemd-modules-load[1385]: Failed to find module      
'vfs_monitor'
 Sep 07 11:33:51 manjaro-lappy systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
 Sep 07 11:33:51 manjaro-lappy systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
 Sep 07 11:33:51 manjaro-lappy systemd[1]: Failed to start Load Kernel Modules.

What should I do about it?
I google about it but seem to cant find the right answer for it.

thanks in advance!


#51

A screenshot of the problem would be more helpful than a link to the site. And which version of Firefox?

But wasn’t text boxes always dark with adapta-nokto? I have to use the widget.content.gtk-theme-override fix with dark themes.


#52

Hi,

Same thing for me ! Bug ?


#53

Hello
I got this message on the last to updates:
Error: failed retrieving file ‘core.db’ from manjaro.barata.pt : The requested URL returned error: 502 Bad Gateway

after this it says the system is up yo date…
Any help?
Thanks


#54

Refresh your mirrors. For example:
sudo pacman-mirrors -f3
Then run the update again.

(You may search internet for ‘error 502’ and find more information about managing your manjaro mirrors by executing man pacman-mirrors.)


#55

Thank you very much Sir.


#56

Example of the bad theming

But wasn’t text boxes always dark with adapta-nokto? I have to use the widget.content.gtk-theme-override fix with dark themes.

Even if it was, it shouldn’t be. It looks horrible with Hacker News and the fact that this text box I am replying to you with is white like the other themes means it is inconsistent.

Firefox 62.0-0


#57

I use Qemu (VGA passthrough with VFIO).
I can’t run Qemu. Returns this error:

qemu-system-x86_64: -device vfio-pci,host=01:00.0,bus=pcie.3,addr=0x00.0,multifunction=on: VFIO_MAP_DMA: -12
qemu-system-x86_64: -device vfio-pci,host=01:00.0,bus=pcie.3,addr=0x00.0,multifunction=on: vfio_dma_map(0x7f4678294dc0, 0x0, 0x80000000, 0x7f446fc00000) = -12 (Cannot allocate memory)
qemu-system-x86_64: -device vfio-pci,host=01:00.0,bus=pcie.3,addr=0x00.0,multifunction=on: VFIO_MAP_DMA: -12
qemu-system-x86_64: -device vfio-pci,host=01:00.0,bus=pcie.3,addr=0x00.0,multifunction=on: vfio_dma_map(0x7f4678294dc0, 0x100000000, 0x180000000, 0x7f44efc00000) = -12 (Cannot allocate memory)
qemu-system-x86_64: -device vfio-pci,host=01:00.0,bus=pcie.3,addr=0x00.0,multifunction=on: vfio error: 0000:01:00.0: failed to setup container for group 1: memory listener initialization failed for container: Cannot allocate memory

dmesg:

vfio_pin_pages_remote: RLIMIT_MEMLOCK (1048576) exceeded

After some investigation, I found out that the file /etc/security/limits.d/99-audio.conf
was missing. I think it happened after the update.

After copying the file, everything works again.


#58

#59

Fixed difference by changing: /Settings/Themes/Use GTK+


#60

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.