[Stable Update] 2018-09-02 - Deepin, Pamac, Linux419, Firefox-Dev, Upower

update
stable

#1

Hi community,

Welcome to another stable update. So what do we have with this one?

  • some new Deepin packages got added
  • we released pamac v7.0
  • a newer snapshot of linux419 and firefox-dev got added
  • we worked on a upower regression
  • removed fd-limits modification in steam-manjaro
  • the usual upstream rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

For more info about L1TF please watch this video:


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.120 [EOL]
  • linux44 4.4.153
  • linux49 4.9.124
  • linux414 4.14.67
  • linux417 4.17.19 [EOL]
  • linux418 4.18.5
  • linux419 4.19-rc1
  • linux414-rt 4.14.63_rt40
  • linux416-rt 4.16.18_rt11

Package Updates (Sun Sep 2 03:29:48 CEST 2018)

  • stable community x86_64: 177 new and 168 removed package(s)
  • stable core x86_64: 3 new and 3 removed package(s)
  • stable extra x86_64: 30 new and 35 removed package(s)
  • stable multilib x86_64: 3 new and 3 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-31           2018-09-02
-------------------------------------------------------------------------------
                        abiword-gtk2              3.0.2-2              3.0.2-3
appimagelauncher 1.0alpha+git20180816.a156d12-1 1.0alpha+git20180830.ba45feb-1
                       bspwm-manjaro              0.9.5-3              0.9.5-4
                       bspwm-scripts               0.38-1               0.39-1
                   deepin-session-ui          4.5.1.1-1.1          4.5.1.2-1.1
      manjaro-bspwm-settings-minimal           20180602-1           20180902-1
                              amarok                - 2.9.0.r245.g68a1f0ecdd-1
                                pspp                    -            1.0.1-2.0


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-31           2018-09-02
-------------------------------------------------------------------------------
                               acpid             2.0.29-2             2.0.30-1
                             aws-cli            1.15.82-1             1.16.5-1
               deepin-control-center              4.6.4-1            4.6.4.1-1
                       deepin-daemon           3.2.24.1-1           3.2.24.2-1
                         deepin-dock            4.7.2.1-1              4.7.3-1
                 deepin-file-manager            1:4.6.7-1            1:4.6.8-1
                       deepin-go-lib             1.2.16-1           1.2.16.1-1
                     deepin-launcher            4.4.5.1-1            4.4.5.2-1
                   deepin-screenshot             4.0.16-1              4.1.0-2
                   deepin-session-ui            4.5.1.1-1            4.5.1.2-1
                            electron              2.0.7-1              2.0.8-1
               elementary-icon-theme              4.3.1-1              4.3.1-2
                              eslint              5.4.0-1              5.5.0-1
           firefox-developer-edition             63.0b1-1             63.0b2-1
  firefox-developer-edition-i18n-ach             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-af             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-an             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ar             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-as             63.0b1-1             63.0b2-1
  firefox-developer-edition-i18n-ast             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-az             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-be             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-bg             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-bn-bd             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-bn-in             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-br             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-bs             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ca             63.0b1-1             63.0b2-1
  firefox-developer-edition-i18n-cak             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-cs             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-cy             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-da             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-de             63.0b1-1             63.0b2-1
  firefox-developer-edition-i18n-dsb             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-el             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-en-gb             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-en-us             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-en-za             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-eo             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-es-ar             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-es-cl             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-es-es             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-es-mx             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-et             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-eu             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-fa             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ff             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-fi             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-fr             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-fy-nl             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-ga-ie             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-gd             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-gl             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-gn             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-gu-in             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-he             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-hi-in             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-hr             63.0b1-1             63.0b2-1
  firefox-developer-edition-i18n-hsb             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-hu             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-hy-am             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ia             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-id             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-is             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-it             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ja             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ka             63.0b1-1             63.0b2-1
  firefox-developer-edition-i18n-kab             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-kk             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-km             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-kn             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ko             63.0b1-1             63.0b2-1
  firefox-developer-edition-i18n-lij             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-lt             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-lv             63.0b1-1             63.0b2-1
  firefox-developer-edition-i18n-mai             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-mk             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ml             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-mr             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ms             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-my             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-nb-no             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-ne-np             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-nl             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-nn-no             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-or             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-pa-in             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-pl             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-pt-br             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-pt-pt             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-rm             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ro             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ru             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-si             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-sk             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-sl             63.0b1-1             63.0b2-1
  firefox-developer-edition-i18n-son             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-sq             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-sr             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-sv-se             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ta             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-te             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-th             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-tr             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-uk             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-ur             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-uz             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-vi             63.0b1-1             63.0b2-1
   firefox-developer-edition-i18n-xh             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-zh-cn             63.0b1-1             63.0b2-1
firefox-developer-edition-i18n-zh-tw             63.0b1-1             63.0b2-1
                         go-ethereum             1.8.13-1             1.8.15-1
      haskell-data-accessor-template           0.2.1.15-3           0.2.1.16-1
                 haskell-descriptive            0.9.4-131              0.9.5-1
                      haskell-hakyll         4.12.3.0-106         4.12.3.0-107
                 haskell-skylighting             0.7.2-20              0.7.3-1
                            influxdb              1.6.0-1              1.6.2-1
                              jgmenu                1.1-1              1.2.1-1
                                jmol           14.29.17-1           14.29.19-1
                               kitty             0.11.3-2             0.12.0-1
                                knot              2.7.2-1              2.7.2-2
                            lollypop            0.9.521-2            0.9.522-1
                           nextcloud             13.0.5-1             13.0.6-1
                          obs-studio             21.1.2-3             22.0.2-1
                             openbve            1.5.3.7-1            1.5.3.8-1
                              pandoc           2.2.3.2-16           2.2.3.2-17
                     pandoc-citeproc         0.14.3.1-123         0.14.3.1-124
                     pandoc-crossref           0.3.2.1-71           0.3.2.1-73
                              parity             1.11.8-1            1.11.10-1
                perl-test-mockmodule               0.15-3            0.170.0-1
                     python-autobahn             18.7.1-1             18.8.1-1
                        python-boto3             1.7.81-1              1.8.5-1
                     python-botocore            1.10.81-1             1.11.5-1
                         python-furl                1.2-2              1.2.1-1
                   python-hypothesis            3.69.12-1             3.70.0-1
                     python-json-rpc             1.11.0-3             1.11.1-1
                 python-pycryptodome              3.6.6-1              3.6.6-2
                  python-ruamel-yaml            0.15.63-1            0.15.64-1
                    python-softlayer              5.5.1-1              5.5.2-1
                        python-txaio             18.7.1-1             18.8.1-1
                    python2-autobahn             18.7.1-1             18.8.1-1
                       python2-boto3             1.7.81-1              1.8.5-1
                    python2-botocore            1.10.81-1             1.11.5-1
                        python2-furl                1.2-2              1.2.1-1
                  python2-hypothesis            3.69.12-1             3.70.0-1
                    python2-json-rpc             1.11.0-3             1.11.1-1
                python2-pycryptodome              3.6.6-1              3.6.6-2
                       python2-txaio             18.7.1-1             18.8.1-1
                                qtox             1.16.3-4             1.16.3-5
                           retroarch              1.7.3-1              1.7.4-1
                           s3fs-fuse               1.83-1               1.84-1
                          shellcheck             0.5.0-83             0.5.0-84
                                 snd               18.6-1               18.7-1
                          spectmorph              0.4.0-3              0.4.1-1
                            startdde             3.1.35-1           3.1.35.1-1
                             toxcore            1:0.2.6-1            1:0.2.7-1
                           uglify-js              3.4.8-1              3.4.9-1
                             unbound              1.7.3-4              1.7.3-5
                               v2ray               3.36-1             3.37.5-1
                             vagrant              2.1.2-1              2.1.4-1
                         x42-plugins           20180812-1           20180812-2
                           xlockmore               5.55-1               5.56-1
                        deepin-turbo                    -              0.0.2-1
                                  go                    -           2:1.10.3-1
                              go-pie                    -           2:1.10.3-1
                            go-tools                  - 2:1.10+2306+25101aad-1
                    iio-sensor-proxy                    -                2.4-4
                     lollypop-portal                    -              0.9.7-1
                             shotcut                    -           18.08.14-4


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-31           2018-09-02
-------------------------------------------------------------------------------
                      linux419 4.19rc1.0826.g5b394b2-1 4.19rc1.0831.g420f51f-1
              linux419-headers 4.19rc1.0826.g5b394b2-1 4.19rc1.0831.g420f51f-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-31           2018-09-02
-------------------------------------------------------------------------------
                            keyutils             1.5.10-2             1.5.11-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-31           2018-09-02
-------------------------------------------------------------------------------
                  linux419-acpi_call           1.1.0-0.11           1.1.0-0.12
                   linux419-bbswitch             0.8-0.11             0.8-0.12
                linux419-broadcom-wl    6.30.223.271-0.11    6.30.223.271-0.12
                   linux419-catalyst   1:15.201.1151-0.11   1:15.201.1151-0.12
                linux419-ndiswrapper            1.61-0.11            1.61-0.12
                     linux419-nvidia        1:396.54-0.11        1:396.54-0.12
               linux419-nvidia-340xx         340.107-0.11         340.107-0.12
               linux419-nvidia-390xx          390.87-0.11          390.87-0.12
                   linux419-nvidiabl            0.88-0.11            0.88-0.12
                      linux419-r8168        8.045.08-0.11        8.045.08-0.12
                        linux419-spl           0.7.9-0.11           0.7.9-0.12
                   linux419-tp_smapi            0.41-0.11            0.41-0.12
                linux419-vhba-module        20161009-0.11        20161009-0.12
   linux419-virtualbox-guest-modules          5.2.18-0.11          5.2.18-0.12
    linux419-virtualbox-host-modules          5.2.18-0.11          5.2.18-0.12
                        linux419-zfs           0.7.9-0.11           0.7.9-0.12
                   manjaro-architect             0.9.15-1             0.9.16-1
                               pamac             6.9.81-1              7.0.0-2
             pamac-tray-appindicator             6.9.81-1              7.0.0-2
                  xfce4-session-gtk3             4.13.0-6             4.13.1-2
                 xfce4-settings-gtk3             4.13.4-2             4.13.4-3


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-31           2018-09-02
-------------------------------------------------------------------------------
                            geoclue2             2.4.11-1             2.4.12-1
                                  go           2:1.10.3-1                    -
                              go-pie           2:1.10.3-1                    -
                            go-tools 2:1.10+2306+25101aad-1                  -
                            ktorrent              5.1.0-3              5.1.1-1
                     perl-date-manip               6.72-2               6.73-1
                       python-crypto              2.6.1-6                    -
                        python-evdev              1.0.0-2              1.1.2-1
                      python2-crypto              2.6.1-6                    -
                       python2-evdev              1.0.0-2              1.1.2-1
                        zabbix-agent             3.4.12-1             3.4.13-1
                 zabbix-frontend-php             3.4.12-1             3.4.13-1
                        zabbix-proxy             3.4.12-1             3.4.13-1
                       zabbix-server             3.4.12-1             3.4.13-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-31           2018-09-02
-------------------------------------------------------------------------------
                       steam-manjaro           1.0.0.55-2           1.0.0.55-3


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-31           2018-09-02
-------------------------------------------------------------------------------
                      lib32-keyutils             1.5.10-1             1.5.11-1
                                wine               3.14-1               3.15-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Items from previous update sets

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension “Workspace to Dock” is bugged

Be careful like there is a bug if you use the Extension “Workspace to Dock”. You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file’s syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name “Everyone” to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


Update issue with 17.0.6
#3

I added the qt5 version of amarok. Let me know if it works on your end. Also I removed the fd-limits within the steam-manjaro update.


#4

Quick Q: with the steam patch removed, FD limits are back to 4K, correct? Just making sure so I don’t forget to change it for proper Steam Play esync support.

I wouldn’t mind a quick explanation why it was removed (if I’m right above) just out of curiosity :slight_smile:


#5

Thanks! Now suspending works again on my laptop.


#6

Welp, it didn’t take long. :upside_down_face:


#7

Maybe I got confused with the reports. Anyway. Is it still needed?


#8

Some games require it to work (I maintain the Steam Play Compatibility Sheet with other volunteers) and most ‘mainstream’ distros have it set to a more sensible value than 4096. It is a requirement of esync and would probably be nice to have it preconfigured out of the box. I don’t recall seeing any issues with raising the FD limit at all especially since Ubuntu/Debian and others ship with it like that.

With Manjaro atm, it satisfies almost all the Steam Play requirements aside from FD limits and LLVM 7, would be great to get FD out of the way since it’s an easy fix :smiley:


#9

According to LLVM themselves, latest release is still 6.0.1.
Why would a feature be requiring a beta dependency? :slight_smile:


#10

I’m not calling for it to be added for that exact reason :slight_smile:
The current LLVM dev is 8.0.0 and I believe 7 is coming soon tm, but I haven’t had any issues with Manjaro and FD limit increased anyway so I don’t know why 7 is referenced as a requirement.

GRAPHICS DRIVERS REQUIREMENTS - GENERAL

DirectX 11 games:

You will need NVIDIA 396.54 or Mesa 18.1.x at a minimum. LLVM7 or above is recommended to play DX11 games without GPU hangs.
https://github.com/ValveSoftware/Proton/blob/proton_3.7/PREREQS.md


#11

Only thing I run into is that the applet of the package manager doesn’t update. (cinnamon) It keeps saying there are updates in the taskbar. But when I open the manager, it says system up-to-date.

**edit : never mind this one. Think it had to do with Blender using too much resources.


#12

I use Webcatalog and Standard Notes which is downloaded as an appImage. Before the last update, both were working fine. Now, neither one will integrate. Something happened with appimagelauncher. Please investigate. Thanks.


#13

I got a “failed to write cache” error while updating.

Rebuilding 32-bit fontconfig cache.../usr/share/fonts/100dpi: failed to write cache
/usr/share/fonts/75dpi: failed to write cache
/usr/share/fonts/Type1: failed to write cache
/usr/share/fonts/cyrillic: failed to write cache
/usr/share/fonts/encodings/large: failed to write cache
/usr/share/fonts/util: failed to write cache
/usr/local/share/fonts/i: failed to write cache
 done.

Seems to come from Arch upstream (https://bbs.archlinux.org/viewtopic.php?id=240026) and apparently its not too big of a deal? Maybe its because the affected folders are almost empty & don’t contain fonts :grin:
EDIT: sorry, missed the wiki post.


#14

Someone missed the wiki post.


#15

You are right, my bad.


#16

Using amd-ucode frees up 300 MiB of memory on my AMD APU systems, running KDE


#17

Ok, sorry, stupid newby question: I have not yet installed the 31-08 updates, was waiting for things to stabilize (no pun intended!). I think that if I update now, it will just sort of catch everything from both updates, as it just syncs with all the current packages?

Thanks! :slight_smile:


#18

Yup, you will upgrade every packages that are more recent in repositories than locally on your system.


#19

Thanks! :slight_smile:

I thought so but didn’t want to bork my system, lol. :slight_smile:


#20

I have a couple of problems since this update, The package manager doesn’t change it’s icon after applying all the updates. (keeps showing available updates icon) The clockworks applet doesn’t work. Nothing happens when I add Clockworks. This broke after the update before this I think. If you need logs, from where should I get those?