[Stable Update] 2018-08-31 - Kernels, Mesa, Qemu, Nvidia, Firefox, Python, Haskell

update
stable

#62

PROBLEM: I am facing the same problem with four three laptops that run Manjaro KDE: after the latest stable upgrade the KDE battery indicator (located in the KDE panel) does not update the status when I plug and unplug the laptop. acpi -i returns the correct battery status (Discharging or Charging). I am NOT facing this problem with the laptop that runs Arch + KDE Plasma. Suggestions are welcome.

EDIT: The solution (thanks, @philm)

sudo pacman -U https://manjaro.moson.eu/pool/overlay/upower-0.99.8-1.1-x86_64.pkg.tar.xz


#63

Thank you. Terrible news for me.

Thank you too.

This act of FF Dev idiocy has rocked me, & makes me now need to reassess my recent decision to migrate to FF… Firefox browser


#64

Why is this idiocy? Reading through the bug report it seems this was a pretty logical decision.

It is a feature you use so it must be annoying, but it is far from idiocy.

This type of functionality could be resurrected via a WebExtension, assuming someone with the requisite skills misses it enough to develop it.


USB headphone is not working on Manjaro i3
#65

Thx for finding the issue. For me reading the commits it was a no-brainer :wink: I reverted b0cdb7e. Please test if that fixes it:

pamac install https://manjaro.moson.eu/pool/overlay/upower-0.99.8-1.1-x86_64.pkg.tar.xz


#66

KDE / Plasma doesn’t seem to recognize that my laptop is plugged in / charging. Battery indicator doesn’t change the to the charging symbol, and the powersaving settings for “on battery” remain applied when plugged in. Hardware recognizes power (ThinkPad power button light blinks when adapter is plugged in), and if I go into kinfo center it shows that the battery is charging.

Kernel 4.18 (which I was running before, but there was an update to the kernel)

EDIT:
Sep 02 00:32:06 pluto systemd-udevd[13514]: Process '/usr/bin/tlp auto' failed with exit code 4.

EDIT: Fix is in the post directly above mine… oops.


#67

After this upgrade font hinting got disabled for me on Plasma (if your text suddenly looks ugly, that’s it). The solution is to change Hinting style under System Settings>Fonts to Full. (Set Use anti-aliasing to Enabled to enable this setting)


#68

Yes works :+1:
Good job! :clap:

Hope you didn’t lose sleep because of this issue :grin:


#69

Hi all,
I’ve Timeshifted back to a pre-update snapshot. I use AirVPN, there client is not working correctly after the update. I haven’t got the time until later to take a closer look but nothing in the list of updates seems the obvious offender to me.
https://aur.archlinux.org/packages/airvpn-git/
and
https://airvpn.org/forum/3-eddie-airvpn-client/


#70

sometimes after an update an AUR package needs to be rebuilt again because of changing libraries, did you try that?


#71

Same here, trying to downgrade upower but not reboot yet because downloading some files.i
After fnishing downloads I will let you know if it is working


#72

Here AirVPN user,
I use the Portable Version, no problems.
You can use Portable version after removing all the openvpn related packages


#73

Thank you! Alternatively,

sudo pacman -U https://manjaro.moson.eu/pool/overlay/upower-0.99.8-1.1-x86_64.pkg.tar.xz

also fixes the issue.


#74

So Amarok got dropped…

Even though it’s off-topic here, I just would like to add my 2c worth of hints. It‘s all a matter of taste, usage and what sound quality you want.

Wrt sound quality: As a pre-condition, I just want bit-perfect playback from any app via ALSA.

For stand-alone music players, I use Audacious and DeaDBeeF.

To me, the best - i.e. most audiophile, most versatile regarding both the playback and music library handling, and nice to look at - audio replay system consists of

  • MPD (Music Player Daemon = the player that works only in the background)
  • plus Cantata (= the GUI front end).

MPD in particular is a bit of an initial hurdle when setting it up, while Cantata is easy. But all efforts do really pay when your expectations wrt computer audio grow.


#75

Same problem here, the AirVPN client (Eddie 2.16.3) just crashes and gets unresponsive after the update. Tried different kernels (no effect) and connecting via the Eddie command line tool and found out that the network lock causes Eddie to crash. If I turn it off, the client works normally.


#76

As suggested I reinstalled Eddie and all is now good.
Before installing the update I disabled network lock in Eddie otherwise they will be connection to reinstall Eddie.
Thanks


#77

I am having a terrible problem like this with xfce on one computer.
Did you find the problem?


#78

After update, I can no longer run project in eric. I found this Issue, and it says that configuring Python environments is needed. After configuring and restarting eric, I can run project again.


#79

I must have missed where it states posts must be in English. Can you show me where it states one must use English?

https://wiki.manjaro.org/index.php?title=Forum_Rules

Maybe it does say it somewhere, I just honestly didn’t see it.

He is the only one with the problem and it appears he can’t speak English, or if he does, he chose German because it would be easier because for him to explain.

I was trying to be helpful and as usual in this day and age, someone is always upset or offended about the smallest thing.

No offense.


#80

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.