[Stable Update] 2018-08-31 - Kernels, Mesa, Qemu, Nvidia, Firefox, Python, Haskell

update
stable

#42

@philm
The new FDLimit introduced by this update made my brightness control behave weirdly.
My solution for now is to delete it, but it will be set again at every update of steam-manjaro.
Is it possible to backup the two files created in /etc/systemd/*.conf.d/ (make .pacnew file) ?
Or put this setting into /etc/systemd/system.conf and /etc/systemd/user.conf as they are already backuped by systemd package ?


Increase FD limits to let Steam Play works reliably
Increase FD limits to let Steam Play works reliably
#43

OMG! Your are right.I don’t use my backlight, after reading your post I tried but it didn’t work :open_mouth: It was working before this update. My DE is Xfce.

System:
 Host: mgundogdu-pc Kernel: 4.14.67-1-MANJARO x86_64 bits: 64 Desktop: N/A 
 Distro: Manjaro Linux 
Machine:
 Type: Laptop System: ASUSTeK product: UX410UQK v: 1.0 
 serial: <root required> 
 Mobo: ASUSTeK model: UX410UQK v: 1.0 serial: <root required> 
 UEFI: American Megatrends v: UX410UQK.301 date: 12/12/2016 
Battery:
 ID-1: BAT0 charge: 21.5 Wh condition: 41.1/48.3 Wh (85%) 
CPU:
 Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP 
 L2 cache: 4096 KiB 
 Speed: 600 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 600 2: 600 
 3: 600 4: 602 
Graphics:
 Device-1: Intel HD Graphics 620 driver: i915 v: kernel 
 Device-2: NVIDIA GM108M [GeForce 940MX] driver: N/A 
 Display: x11 server: N/A driver: intel resolution: <xdpyinfo missing> 
 OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) 
 v: 4.5 Mesa 18.1.7 


#44

Personal preference, Clementine.


#45

Me too. For a different reason however. It seems version 63 will be the “let’s piss off all the users who use the browser differently than we do it” release cycle. Maybe I will start upgrading again in a few weeks. Maybe… :thinking:


#46

Sorry, newbie here.
Since this update Kernel 4.18 and 4.19rc1 won’t boot anymore:


#47

Seems the request for steam created a regression on other places. Can you guys confirm by reverting those changes on your end to have it working normal again?

Please see also here:


#48

A standard update went OK here, many thanks :slight_smile:

P.S:

nobody has ported amarok on qt5 yet?


#49

Upstream is still working on it. 2.9.0 was the last based on qt4. If you still like it, you may try amarok-git.

pamac install https://manjaro.moson.eu/pool/overlay/amarok-2.9.0.r245.g68a1f0ecdd-1-x86_64.pkg.tar.xz


#50

deleting the new FD limit conf file did not help (after reboot):

sudo rm /etc/systemd/system.conf.d/40-fd-limits.conf

any other step required? Or is it maybe not related to this change?


#51

You missed the /etc/systemd/user.conf.d/40-fd-limits.conf file. You also might need to reboot.


#52

oops, you’re right, will try again, thanks


#53
sudo rm /etc/systemd/user.conf.d/40-fd-limits.conf

still no luck :thinking:


Increase FD limits to let Steam Play works reliably
#54

Well, then it might be a regression. Which kernel series worked last?


#55

linux414-4.14.66-1-x86_64.pkg.tar.xz worked fine, I’ll try to downgrade the kernel with firmware packages to see if it helps.

I remember few days ago testing the 4.18 series and it worked as well, so not sure what happened. Unfortunately I deleted the cached package for 4.18 so I’ll be able to test only the 4.14 series.


#56

Thanks for the suggestion.
After re-installing Manjaro and putting back my home directory I noticed the problem just after I restored the ~/.fonts directory. I emptied the ~/.fonts directory: problem solved.
It seems the fontconfig update possibly has a negative effect.


#57

I also have backlit keyboard problem after the update. Asus Vivobook, kernel series 4.18.x

Before the update mine was working fine, definitely due to this update.


#58

Here is the compatibility announcement.


Firefox browser
#59

Don’t blame Linux after last Windows 10 update my backlight stopped working :joy: :joy:


#60

Confirm the issue with keyboard backlight.


#61

OK after several hours of investigation the package upgrade causing this issue is upower, version 0.99.7 to 0.99.8. Looks like a regression.

Arch bug tracker: https://bugs.archlinux.org/task/59865?project=1&string=upower
Upstream issue: https://gitlab.freedesktop.org/upower/upower/issues/73

Workaround: downgrade upower or deselect the update for it
sudo pacman -U /var/cache/pacman/pkg/upower-0.99.7-1-x86_64.pkg.tar.xz


Increase FD limits to let Steam Play works reliably