[Stable Update] 2018-08-25 - Kernels, KDE Apps & Framework, Flatpak 1.0, Nvidia, Cleanup

update
stable

#42

During the installation I had following questions (translated to english):

:: Repalce ca-certificates-cacert with core/ca-certificates ersetzen? [J/n] J
:: Replace qca-qt5 with extra/qca ersetzen? [J/n] J
...
:: qca and qca-qt4 are in conflict. remove qca-qt4 ? [j/N] j

Install: qca-2.1.3-1
Remove  qca-qt4-2.1.3-11 and  qca-qt5-2.1.3-11

I hope this was ok.


#44

After this update, WebGL is not working on Firefox for all three kernels 4.19, 4.18 and 4.14 on my desktop and laptops.
Could this be due removing xf86-amdgpu and xf86-nouveau drivers, since I have only Intel graphics. Solutions on web suggest driver problems. Any pointers on how to solve it. I have tried all of the Firefox support page. Everwhere it says to update drivers or tinker with about:config ( on Firefox ) none of which helped me.


#46

You should ping @philm otherwise he might miss the request. Even better still, start a new thread in the development forum with the request and ping him in that :+1:

Edit: Adding link to topic as original post replied too is being deleted.


#47

look at Known issues and solutions


#48

I’ll do it right away, thanks! :wink:


#49

Just updated a Manjaro KDE system. Not sure about the ‘packages moved to AUR that can be removed’.

yay reports the following:

 -> Local package is newer than AUR: phonon-qt4-gstreamer (4.9.0-4 -> 4.9.0-1)
 -> Missing AUR Packages:  breeze-kde4  mhwd-nvidia-304xx  oxygen-kde4  polkit-qt4
 -> Orphaned AUR Packages:  attica-qt4  automoc4  kdebase-runtime  kdelibs

Most of them are needed by kdebase/kdebase-runtime.

How to proceed? TIA.


#50

See here


#51

\o/ Great News!


#52

remove them if you don’t intentionally use any old KDE4-Stuff that needs them :slight_smile:


#53

Yes. But I shouldn’t remove kdelibs I assume? See:

λ sudo pacman -Rns phonon-qt4
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: kdelibs: removing phonon-qt4 breaks dependency 'phonon-qt4'
:: phonon-qt4-gstreamer: removing phonon-qt4 breaks dependency 'phonon-qt4'

Should I remove without dependency check?


#54

Thanks. Replaced a qt4 app with its qt5 counterpart.


#55

Kernel 4.16 installed and used on my system, update is not starting due to nvidia-utils conflict…

Installation von nvidia-utils (1:396.54-2) verletzt Abhängigkeit 'nvidia-utils=1:396.51', benötigt von linux416-nvidia

Same if I try to install and use kernel 4.18 instead.


#56

4.16 is removed from repos
uninstall this kernel , only existing kernels are kept


#57

When trying to install 4.18 I get:

:: installing nvidia-utils (1:396.54-2) breaks dependency 'nvidia-utils=1:396.51' required by linux414-nvidia
:: installing nvidia-utils (1:396.54-2) breaks dependency 'nvidia-utils=1:396.51' required by linux416-nvidia
:: installing nvidia-utils (1:396.54-2) breaks dependency 'nvidia-utils=1:396.51' required by linux49-nvidia
error: failed to prepare transaction (could not satisfy dependencies)

So it is not just the discontinued 4.16…


#58

OK, removed kernel 4.16, using kernel 4.14 the update is running now…


#59

I got the same question. Any advice on the suggested answer (remove qca-qt4 or not ) ?


#60

I just forwarded fixes for the L1TF issue we had for linux44 and linux49.


#61

Well… My system didn’t inform me about this. I saw “Unsupported” label (or something like that) related to kernel 4.16, but after opening manually the manjaro-settings-manager.

So in my case the update failed. I had to guess that unused (but installed) kernel is not compatible. I didn’t read announcements, because my system is updating automatically (just needs to confirm the update) - that’s how pamac-updater works, right?

So, as an end user I’m expecting automatic removal of incomatible/unused packages or a readable message displayed (“The update process cannot continue. Please remove kernel 4.16 and retry”).

But everything else works like a charm and update was successful. Thank you very much!


#62

after update i get:

$ pandoc
pandoc: error while loading shared libraries: libcmark-gfm.so.0.28.3.gfm.14: cannot open shared object file: No such file or directory


#63

Thx for reporting. Seems there are more packages needed to be updated. Therefore I removed our overlay-package for now. You might have some issue when the normal cmark package is installed, which was fixed already upstream.