[Stable Update] 2018-08-25 - Kernels, KDE Apps & Framework, Flatpak 1.0, Nvidia, Cleanup

update
stable

#21

You can answer yes. This means the tools provided by those packages are now provided by other packages. This is often related with packaging decisions. You’ll feel no difference. When you answer no you are effectively not updating those packages, which can lead you to other kinds of problems or conflicts.


#22

In my case 239.0-2 solved the “wifi connected no internet” issue as well. It seems something is wrong the systemd v239.0-3.


#23

Good update on KDE edition, but phonon-qt4 is in the official repo and in AUR? AUR pacage does not buil/update, because the PGP signatures could not be verified, and there both presently installed (or it looks this way?). Should I de-install one? Also phonon-qt4-gstreamer is double (but does not have a update).


#24

no ! since totay, is not in repos manjaro
For install signature, read comments in aur page


#25

Thank you, that worked (still a bit a newbie and never encountered this kind of problem). But is it still used, or could it be safely de-installed?


#26

Same for me. I had kernel 4.16 installed but not used. Updater should inform an user about incompatible kernel, or should remove old kernel automatically. The message about conflict of nvidia-utils is too enigmatic.


#27

Yep finally gdm dev solve the zombie shell


#28

I went on removing several qt4 packages, but polkit-qt4 and kde-l10n-nl are nowhere to be found. Are they safe to remove completely? (removal of the “now” AUR packages broke nothing)


#29

I have encountered another issue updating but relating to some C/C++ include files.

(144/144) checking for file conflicts                      [###############################] 100%
error: failed to commit transaction (conflicting files)
cmark-gfm: /usr/include/cmark.h exists in filesystem (owned by cmark)
cmark-gfm: /usr/include/cmark_export.h exists in filesystem (owned by cmark)
cmark-gfm: /usr/include/cmark_version.h exists in filesystem (owned by cmark)
Errors occurred, no packages were upgraded.

When I checked the file owners…

/usr/include $ ll cmark*
-rw-r--r-- 1 root root 965 Oct 25  2017 cmark_export.h
-rw-r--r-- 1 root root 19K Oct 22  2017 cmark.h
-rw-r--r-- 1 root root 146 Oct 25  2017 cmark_version.h

How do I fix this?


#30
pacman -S cmark-gfm --overwrite "usr/include/*"

before update


#31

@mbb: Thanks for the clarification.


#32

I was not able to apply your suggestion @papajoke. I have experimented by manually renaming the concerned files just to see what happened after re-updating. All went well so far. But still, thank you for the answer.


#33

i removed them and did not notice any issue yet :slight_smile:


#34

Same thing here except I’m using Octopi , also had to update mirrors and -Syyu . Smooth sailing on KDE with 4.14 after that .


#36

Actually I have to say I don’t like it the way it is now. Userswitch is much(!) slower and flickery as hell. Also I can not just switch to TTY1 and log in with a different user, like it was before. :thinking:
and of course now I don’t see any reason why the first session does not start on TTY1, but TTY2, when there is no GDM running on TTY1 anymore.


#37

I had the same issue too, deleted photon-qt4 and then it worked. (This is my answer to my vote)


#38

Octopi says this:

phonon-qt4
The multimedia framework for KDE4

URL
http://phonon.kde.org/
Version
4.10.1-2 (outdated installed version is 4.10.1-1)
Licenses
LGPL
Depends On
qt4 libpulse phonon-qt4-backend
Optional Deps
pulseaudio : PulseAudio support [installed]
Required By
kdelibs phonon-qt4-vlc
Download Size
0.00 Bytes
Installed Size
1.12 MiB
Packager
Antonio Rojas <arojas@archlinux.org>
Architecture
x86_64
Build Date
Fri. - 27/04/2018 21:04:39
Install Reason
Installed as a dependency for another package

Looking at:

Required By
kdelibs phonon-qt4-vlc

…infers a potential cascade of knock-on dependency clashes if i proceed with simply removing phonon-qt4

kdelibs 
Required By
oxygen-kde4

…but oxygen-kde4 seems to be NOT required by anything… so maybe it is safe after all to remove ALL these…?


#39

I removed all with no ill effects. I simply told octopi to remove phonon-qt4 and it removed 6 (?) other packages. All seem redundant or old since I also have phonon-qt5 installed.


#40

I removed phonon, rebooted and so far have noticed no problems.

Removing selected packages...

checking dependencies...
warning: dependency cycle detected:
warning: phonon-qt4-gstreamer will be removed after its phonon-qt4 dependency
Packages (7) attica-qt4-0.4.2-4 breeze-kde4-5.13.4-1 kdelibs-4.14.38-4 oxygen-kde4-5.13.4-1 phonon-qt4-4.10.1-1
phonon-qt4-gstreamer-4.9.0-4 polkit-qt4-0.112.0+git20180107-1
Total Removed Size: 53.58 MiB

:: Processing package changes...

(1/7) removing oxygen-kde4 
(2/7) removing breeze-kde4 
(3/7) removing kdelibs 
(4/7) removing phonon-qt4 
(5/7) removing phonon-qt4-gstreamer 
(6/7) removing polkit-qt4 
(7/7) removing attica-qt4 

:: Running post-transaction hooks...

Updating icon theme caches...
Arming ConditionNeedsUpdate...
Updating the desktop file MIME type cache...
Updating the MIME type database...

Command finished OK!

#41

mhwd does this automatically. Also it was announced:

Never ever suggest that. It is a known issue with upstream and fixed via cmark-gfm 0.28.3.gfm.15-1.