[Stable Update] 2018-08-18 - Kernels, Xorg-Server, Mesa, Deepin, MATE, Perl, Python

update
stable

#146

3 posts were split to a new topic: OpenGL not detected with primusrun and NVIDIA 390xx


#147

3 systems updated… all ok now!
thx


#148

Slic3r Prusa Edition broke. I had to not only rebuild Slic3r, but uninstall and reinstall all the python dependencies as well. Seems to be working now.


#149

AUR package? :wink:


#150

I’ve seen this message lots of times. But I don’t think it’s anything serious.

Maybe this?


#151

My desktop hit a pretty serious issue with this update.

When I select my kernel in Grub (does not matter which one of the 3 I have installed I choose) I get this:

systemd[1]: Caught <SEGV>, dumped core as pid 409.
systemd[1]: Freezing execution.

Since I found no one else with this problem, and I didn’t have any packages in my cache, I chose to just re-install, since the usual reinstall of kernels, systemd and glibc did not have any impact.

Anyone else experienced this?

Seems it’s related to my NFS shares in my fstab. If I enable them, the new system does not boot either. Disabling them, boots the system.


#152

@Strit
any downgrade systemd works ?


#153

As I said, I didn’t have any packages in my cache, so couldn’t downgrade.
But I did re-install and I think my problem is somewhere in my fstab, since the new install only booted when I commented some stuff out.


#154

Obviously the community/libvirt package was recently updated from version 4.6.0.207.g69c20e1090-1 to 4.6.0.207.g69c20e1090-2 fixing the missing glusterfs dependecy. Thanks :slight_smile:


#155
Packages (473)
...
Total Download Size:   1527,95 MiB
Total Installed Size:  6308,76 MiB
Net Upgrade Size:       -74,50 MiB <<<--- This is what I call an upgrade!

#156

Libreoffice fresh came up with breeze dark icons per default (= totally useless given the not-dark theme of Libreoffice). This was obviously easy to change and the new Karasa Jaga icon set of LO if a real joy!


#157

Thanks for that link but it did not help, boot.log text said all is ok, sudo journalctl -b -1 -r comes up with loads of error from QT to freedesktop (which seems normal?) but nothing about unmount, and i not sure but the error looks like it might say “sd-unmount”, Which even the great Google did not help, and i don’t have SD cards/drives or even USB flash/Drives/Etc plugged in, but i do have 2 HD Drives not solid state, 1 boot and 1 for home, i’ve spent most of today searching Google, Arch Forums etc and have got nowhere, It not really a problem as the computer still shuts down/reboots at a blink of an eye, its just worrying to sort of see it.


#158

Absolutely massive update of 700mb. Everything working great so far, even fixed an annoying bug I had been experiencing in LibreOffice.


#159

What? No issues, like “it shows desktop”… Or really no issues, even effectively using it?

For me (like I think phil may have read on github, and as I was going to comment) open driver tanks viability with fire


#160

You’re absolutely right. Thank you!


#161

XFCE, 4.14.65

Everything upgraded fine and seems to be working properly after reboot. Thanks for the hard work!


#162

New to Manjaro, tried to run the update and it failed.

Getting this error message:
could not satisfy dependencies:
installing glibc (2.28-4) breaks dependency ‘glibc=2.27’ required by lib32-glibc

Guys, any idea how to fix it? Thanks ahead for your help.

Thanks,
R


#163

See " Known issues and solutions" right below the opening post of the thread. Do that every time there is a rolling update. :slightly_smiling_face:

If that doesn’t work, people are going to need more information about what you have tried.


#165

Noted. Thanks mate. :wink:


#166

Do you feel like opening a dedicated topic on this. I also have NFS shares mounted and I’m still waiting before I perform this update. It would be nice to figure out what’s causing this and a solution.