[Stable Update] 2018-08-18 - Kernels, Xorg-Server, Mesa, Deepin, MATE, Perl, Python

update
stable

#126

Why are you saying no to replacing the packages? Do not do that.

You should do:

:: Replace hunspell-en with extra/hunspell-en_AU? [Y/n] y
:: Replace hunspell-en with extra/hunspell-en_CA? [Y/n] y
:: Replace hunspell-en with extra/hunspell-en_GB? [Y/n] y
:: Replace hunspell-en with extra/hunspell-en_US? [Y/n] y
:: Replace libx264-10bit with extra/x264? [Y/n] y
:: Replace libx264-all with extra/x264? [Y/n] y


#127

Thank you for your help. After following what you said I got this…
: Synchronising package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
:: Replace hunspell-en with extra/hunspell-en_AU? [Y/n] y
:: Replace hunspell-en with extra/hunspell-en_CA? [Y/n] y
:: Replace hunspell-en with extra/hunspell-en_GB? [Y/n] y
:: Replace hunspell-en with extra/hunspell-en_US? [Y/n] y
:: Replace libx264-10bit with extra/x264? [Y/n] y
:: Replace libx264-all with extra/x264? [Y/n] y
warning: vocal: local (2.2.0-3) is newer than community (2.2.0-2)
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libx264-10bit breaks dependency ‘libx264-10bit’ required by lib32-libx264-10bit
:: removing libx264-all breaks dependency ‘libx264-all’ required by lib32-libx264-all

Press any key to continue…

Not sure again where to go… any insight would be gratefully received. Thanks


#128

Boot up with a live usb/cd, chroot and go from there tracing the problem. Have a look here: Can't login - black screen - chroot guide

That will get you access to logs and information. If you need help troubleshooting start a thread on one of the main boards.

(Also see 8 posts below - @Mufflon)


#129

lib32-libx264-10bit and lib32-libx264-all seem to be packages from the AUR, right?
Try removing whatever you installed from the AUR that needs them (and by extension these packages) and see if the update goes forward now.


#130

Correct me if i’m wrong, but simply accepting all replacing is not the way to go imho.
In case of Hunspell-en you should decide which of the 4 new en-variants you want to have.


#131

Thank you followed your info and seems to be working. Thank you


#132

followed your info and thanks


#133

Since the update, Firefox (both stable release and Nightly) has WebGL (1+2) disabled.
I suspect it is a firefox problem with some of the updates (xorg-server?, libglvnd?..) because Chromium WebGL still works fine.
If anyone has a good clue what the problem is, here is the bugreport.


#134

With this update, my Mate desktop running in a QEMU/KVM virtual machine boots to a blank desktop screen. (I have autologin enabled in this VM). Run level 3 and SSH login both work OK so it appears to be an issue with X.org, Mate, or the QXL video driver. Tried several experiments and finally found a set of changes that provides a working desktop:

  • Disable auto-login. (Comment out auto-login lines in /etc/lightdm/lightdm.conf).
  • Revert back to the VESA display driver instead of QXL. (Change 90-mhwd.conf symlink in /etc/X11/xorg.conf.d to point at /etc/X11/mhwd.d/vesa.conf).

I don’t understand the failure and the journalctl logs weren’t consistently reproducible between reboots. For example, I saw mate-settings-daemon crash one time. I also run the VM on a Linux host that has a HiDPI (3440x1440) screen so maybe there’s some HiDPI interaction?

Anyhow, hope this helps anyone with a similar issue running Manjaro in a QEMU/KVM guest with QXL.


#135

Manjaro Gnome

Update went fine from terminal Syu apart from when i restart or shut down i see an error about “error unmount” something as it shuts down/restarts to quick to read it, does someone know if a log file might help track this down?


#136

Great update, but i had to install kernel 4.14. With 4.4 the system does not boot. The same message like post #88 from redshift.

Bye, Klaus


#137

At first blush, I tend to agree with you. Should I expound on that or would a simple “+1” suffice? :wink:

In Archlinux, we have updates daily. No announcement is made and only occasionally is there a need to post any warning about recalcitrant packages needing user-intervention during an update. In other words, it’s almost always No Big Effing Deal.

But Manjaro Linux is not Arch, and the updating procedures are not the same, either. Manjaro has always used a batch process, collecting updated packages over a longer period of time and then releasing them in batches once they have been made ultimately suitable for Manjaro (Stable). @philm or his designee then announces and provides the updated and batched packages to their appropriate channels. (The same processes also happen with Unstable and Testing, but to a lesser degree.)

The Poll says that this update had a reported success rate of 82%, and it was a problem for 18% of reporting users. 18%! That’s huge! If 18% of Arch users had problematic updates I doubt it would have survived this long.

And if 82% of the 131 posts here (107) had no updating problems, how is anyone expected to find help when their post (@ 18% = 24) gets lost in the shuffle?

So I end up with a mixed reaction. @philm & Co. most certainly need to know when everything works, but more importantly, when they don’t. That means @philm @ Co. has to read through every one of these posts, including all of the “It worked” posts in order to find the ones they are really looking for.

So perhaps @philm would like to chime in?

regards


#138

I’ve found a solution for Firefox WebGL problem on Arch forum (https://bbs.archlinux.org/viewtopic.php?id=239480):

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


#139

@c00ter: I hardly look into these threads, as they blow up fast. I’m more following the buzz at Arch and filter out unneeded things. This particular update will crash due to following reasons:

  • upstream fixes for L1TF
  • update to Xorg-Server 1.20 series
  • glibc updates to our toolchain
  • issues with Gnome in general, that is why I recommend tty update for this one
  • smaller issues with pamac
  • python and perl updates
  • people not reading the announcement properly and thinking each update is rock-solid.

I even had to respin all ISOs and reupload them. Gave me an 8hour headache releasing this one. So, yes, this update was a mess in some cases - and we may still need to patch it up here and there …


#140

Solution == Moar Minions! :face_with_head_bandage:


#141

Most on vacation :wink: However, when I’ve vacation I do more Manjaro :stuck_out_tongue:


#142

Hi! any ideas with this message?

bash: /usr/lib/python3.6/site-packages/powerline/bindings/bash/powerline.sh: No such file or directory

Tried reinstalling python-powerline-2.7-1 but no luck
I’m using XFCE4.
Thanks!


#143

Me, with Nvidia GPU :frowning:


#144

Thanks a lot!
Workaround works for me.
Left a note about the duplicate bug in the other bug.


#145

It’s in /usr/lib/python3.7/ now. Update your rc file (e.g. .bashrc) or wherever you have sourced this file.