[Stable Update] 2018-08-18 - Kernels, Xorg-Server, Mesa, Deepin, MATE, Perl, Python

update
stable

#86

I have problem with packages libx264 and libx264-all blocking updates but I uninstalled them by using command: pacman -Rdd libx264 libx264-all and after that system updated without any problem.


#87

Noooooooooooo…ooo.oooo…ooo…ooo. O.

Please don’t use sudo pip install for system-wide Python module installation. Use packages for system-wide installation, use pip for user-local installation.

If a repo package needs to be rebuilt, please report that.

If this is an AUR package, then rebuild it.


#88

Just so you’re aware, you’ve broken any application which requires libx264.

Keep that in mind if you come across any odd behaviour e.g. videos not playing.


#89

A post was split to a new topic: One kernel missing from GRUB menu


#90

But when I updated system after that everything work without any problem, updates resolved broken dependencies.


#91

I managed to mount my root partition through manjaro usb installer. Installed 4.18 kernel and still no luck on booting. After examining system journal I found some weird error with gdm and wayland, changed to WaylandEnable=false in /etc/gdm/custom.conf and voila, it’s booting again!

I must have left it WaylandEnable=true and there were no problems with that in the past even if wayland wasn’t working for me…


Kernel 4.18.2-1 module problems
Infinite Login Loop After Update
#92

I ran into an issue with libvirtd.service, which won’t start up anymore…

Aug 18 20:46:27 quad-core-pc libvirtd[1916]: 2018-08-18 18:46:27.800+0000: 1916: error : virModuleLoadFile:53 : Interner Fehler: Failed to load module '/usr/lib/libvirt/storage-backend/libvirt_storage_backend_gluster.so': libgfapi.so.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden

…after cleaning up orphaned dependencies, as I do periodically after system wide updates.

$ sudo pacman -Rsu $(pacman -Qqdt)

It seems the package glusterfs is required as dependecy for libvirtd but it is not in its dependency list anymore. So the fix is to install glusterfs explicitly.

$ sudo pacman --asexplicit -S glusterfs

#93

System: Manjaro XFCE

On restart, system won’t boot to desktop. After grub menu appears and entry selected, boot continues but stalls at last line in image. Tried fallback option in grub menu also, stuck at same point. Unable to enter console at this point.

Any ideas on how to repair system?

Update:
It was the 4.4 kernel. I followed the tip in post #136 and installed kernel 4.14 using the chroot suggestion by grinner his reply. Thanks. Now back to normal.


Can't boot after update can't access login screen
#94

Yikes! I was following the instructions coming from the applet itself.

pip stuff removed, required packages installed from repository, everything working as it should.


#95

3 posts were split to a new topic: Kensington Expert Wireless TB Mouse stopped working


#96

Hey guys, is there another stable update on?

This is what i get now

Πακέτα (12) libnumbertext-1.0-1  libreoffice-fresh-6.1.0-1
            libreoffice-fresh-el-6.1.0-1  libreoffice-fresh-it-6.1.0-1
            linux414-4.14.65-1  linux414-headers-4.14.65-1  linux417-4.17.17-1
            linux417-headers-4.17.17-1  linux418-4.18.3-1
            linux418-headers-4.18.3-1  rpcbind-1.2.5-1
            steam-manjaro-1.0.0.55-1

#97

A small release with some bonus stuff.


#98

ok, thanks
Good to know


#99

Everything went smooth. The only issue I have is that now a mysterious Dynamic User appears on my LightDM user list :eyes:. I would be pleased if someone could help me with that !


#100

Oh nevermind! there’s a post in the arch wiki on how to solve that.


#101

All looks good, except for the fact that locking my screen with light-locker no longer wakes up the screen when I type or move my mouse. Before, it would immediately turn on and I would be looking at the lightdm login screen to input my password. Now, the screen remains totally off until I type my password in. Essentially I’m having to do it blind.


#102

also, catfish have a regression: when you select multiple files and right-click on them, the right click stops work also if, after that, you right-click a single file
Similar to the previous bug


[Stable Update] 2018-09-09 - Kernels, KDE Plasma & Apps, Browsers, Mesa, Deepin, AMDVLK
#103

In the case of others having the same issue I had with Caffeine.

I’ve found a post in the Arch Forum about how to solve it:

Caffeine broken by python updates? [solved by python-ewmh rebuilt]


#104

All went fine on three different machines. Great work, thanks to all who make a great job.


#105

Thanks. It does seem to switch the card in some situations, but doesn’t work as expected. I tried darktable and still no OpenCL support, I tried VLC and video is broken and I tried 2 games (one Steam and one GOG) and they are not producing more FPS. So something is off here :thinking: