[Stable Update] 2018-08-18 - Kernels, Xorg-Server, Mesa, Deepin, MATE, Perl, Python

update
stable

#22

Alway check to which package the file may belong. If locally no package uses it, you may delete or rename it.

phil@development ~ $ pacman -Fo /usr/lib/libstfl.so.0
usr/lib/libstfl.so.0 is owned by community/stfl 0.24-4
phil@development ~ $ pacman -Qo /usr/lib/libstfl.so.0
error: No package owns /usr/lib/libstfl.so.0

#23

Thanks but where is the calendar item in thunderbird 60?


#24

You have to add an account in order to see it.


#25

OK, that’s why.
Thanks.


#26

I get these warnings

dependency cycle detected:
libglvnd will be installed before its mesa dependency
dependency cycle detected:
x264 will be installed before its ffmpeg dependency
dependency cycle detected:
lib32-mesa will be installed before its lib32-libglvnd dependency

Is it safe? What should I do?


#27

Just a minor problem with perl-linux-inotify2 having previously been built in /usr/lib/perl5/5.26/vendor_perl whereas the new Perl release looks in /usr/lib/perl5/5.28/vendor_perl. Simply solved by reinstalling the module to it got rebuilt in the correct place.
I suspect a few other modules built from source may be similar.


[Stable Update] 2018-08-06 - Kernels, Plasma, Jade, Deepin, Firefox, Haskell
#28

This is an AUR package, and AUR packages need to be rebuilt. It’s in the Known Issues post. :wink:


#29

all good here


#30

Yes.

Continue. In fact, the update will have completed anyway as these are simply Warnings.


#31

I get this error after updating when trying to open VS Code

/opt/visual-studio-code/bin/../code: /opt/visual-studio-code/glibc/usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)


#32

Is it an AUR package? Yes it is, so rebuild it before doing anything else.

This is in the Known Issues post (“Something using Perl/Python/glibc broke”).


#33

I have a problem with Thunderbird after the update, I don’t have an entry in the menu bar. I can’t hide TB anymore and TB will be closed down instead. Before the update this worked without problems for years.


#34

Please always check with the AUR and update the package to get it working.


#35

Be more specific with your issues. Also you may read-up on this.


#36

Sounds like you were using an addon to get a system tray icon.

Thunderbird 60 disables incompatible addons by default.

“It’s not a bug, it’s a feature.”


#37

No issues on 3 system updates. All XFCE. Big update though! Good work :+1:


#38

All good for my Xfce, Deepin, Enlightenment, Cinnamon & KDE VMs [kernel 4.18.2]. Also all good for my Lappy’s real KDE, with one exception: the android-tools upgrade broke the Sync function with MyPhoneExplorer again. Downgrading 1 to 2 fixed it again:

*  1) android-tools-9.0.0_r3-1-x86_64.pkg.tar.xz (local)
*  2) android-tools-8.1.0_r33-1-x86_64.pkg.tar.xz (local)

Tomorrow my KDE Tower will get updated too; fingers crossed it’ll be equally successful.


#39

Looks like python-tesserwrap needs a rebuild for Python 3.7.


Manjaro-specific packages which need an update
#40

Could you explain that in a little more detail, please?

My Calendar was working fine, but I decided to experiment on a backup system (fortunately). I deleted the Lightning extension to see what would happen and now I can’t see any way of adding a calendar back into Thunderbird.


#41

Kernel 4.18 should add support for Radeon RX Vega M hybrid cards. However none of my applications seem to detect it. I have installed mesa, mhwd-amdgpu, vulkan-radeon and mesa-vdpau Do I need to install some other package? Or perhaps mhwd needs to be updated?

Update

Actually inxi -Gx shows that graphics card is detected. So question is how do I switch to Vega for OpenGL and OpenCL?

Graphics:  Card-1: Intel driver: i915 v: kernel bus ID: 00:02.0
           Card-2: Advanced Micro Devices [AMD/ATI] Polaris 22 [Radeon RX Vega M GL] driver: amdgpu v: kernel
           bus ID: 01:00.0
           Display: x11 server: X.Org 1.20.1 driver: intel resolution: 3840x2160~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 18.1.6
           direct render: Yes