[Stable Update] 2018-08-18 - Kernels, Xorg-Server, Mesa, Deepin, MATE, Perl, Python

update
stable

#227

After this update my WiFi connection stopped working randomly. Sometimes it came back by disconnecting the USB dongle and reconnecting it, but most of the times I had to reboot.

While trying to troubleshoot the problem I noticed some systemd-resolved errors on fetching addresses from my router. I first tried to downgrade systemd-resolvconf which didn’t work. Then I upgraded systemd-resolvconf to the current version and downgraded systemd. The problem went away.

I haven’t applied today’s update yet. I’ll see if upgrading the kernel in today’s upgrade solves the problem with systemd 239.0-3.

My current systemd packages are the following:

lib32-systemd 239.0-1
libsystemd 239.0-3
systemd 239.0-1
systemd-resolvconf 239.0-3
systemd-sysvcompat 239.0-3

My USB WiFi dongle doesn’t show up on inxi's output:

[mbb@mocho-desktop ~]$ inxi -N
Network:   Card-1: Qualcomm Atheros AR8131 Gigabit Ethernet driver: atl1c

It is a USB3 dongle with a Realtek 8812BU chipset. I think I use the driver rtl8822bu-dkms-git from AUR, but I’m not sure if I built it myself from another source. I only know it is a dkms module which worked wonderfully until this update.

This dongle is connected to a 4-port USB3 PCI-E x1 card.

If this helps, these are my specs:

System:    Host: mocho-desktop Kernel: 4.14.65-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.0 
           Desktop: KDE Plasma 5.13.4 tk: Qt 5.11.1 wm: kwin_x11 dm: sddm Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: P5G41T-M LE v: Rev X.0x serial: <filter> 
           BIOS: American Megatrends v: 1001 date: 08/02/2012 
CPU:       Topology: Quad Core model: Intel Core2 Quad Q9650 bits: 64 type: MCP arch: Penryn rev: A 
           L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 24019 
           Speed: 2001 MHz min/max: 2003/3003 MHz Core speeds (MHz): 1: 2001 2: 2005 3: 2001 4: 2001 
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Redwood XT [Radeon HD 5670/5690/5730] vendor: XFX Pine 
           driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:68d8 
           Display: x11 server: X.Org 1.20.1 driver: radeon compositor: kwin x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD REDWOOD (DRM 2.50.0 / 4.14.65-1-MANJARO LLVM 6.0.1) v: 3.3 Mesa 18.1.6 
           compat-v: 3.1 direct render: Yes 
Audio:     Card-1: Intel NM10/ICH7 Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:27d8 
           Card-2: Advanced Micro Devices [AMD/ATI] Redwood HDMI Audio [Radeon HD 5000 Series] vendor: XFX Pine 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aa60 
           Sound Server: ALSA v: k4.14.65-1-MANJARO 
Network:   Card-1: Qualcomm Atheros AR8131 Gigabit Ethernet driver: atl1c v: 1.0.1.1-NAPI port: ec00 
           bus ID: 02:00 chip ID: 1969:1063 
           IF: enp2s0 state: down mac: <filter> 
           IF-ID-1: wlp3s0u1u1 state: up mac: <filter> 
Drives:    Local Storage: total: 1.31 TiB used: 1.04 TiB (79.6%) 
           ID-1: /dev/sda model: KingSpec KSD-PA25.6-128MS size: 118.24 GiB speed: <unknown> serial: <filter> 
           rev: 0803 scheme: MBR 
           ID-2: /dev/sdb vendor: Seagate model: ST3250823AS size: 232.89 GiB speed: <unknown> serial: <filter> 
           rev: 3.03 scheme: MBR 
           ID-3: /dev/sdc vendor: SanDisk model: SD7SB3Q064G1122 size: 59.63 GiB speed: <unknown> 
           serial: <filter> rev: 0000 scheme: MBR 
           ID-4: /dev/sdh type: USB vendor: Hitachi model: HDT721010SLA360 size: 931.51 GiB serial: <filter> 
           scheme: MBR 
Partition: ID-1: / size: 58.56 GiB used: 40.10 GiB (68.5%) fs: ext4 dev: /dev/sdc2 
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A gpu: radeon temp: 57 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 182 Uptime: 13h 43m Memory: 7.79 GiB used: 2.50 GiB (32.1%) Init: systemd v: 239 
           target: graphical.target Compilers: gcc: 8.2.0 clang: 6.0.1 Shell: bash v: 4.4.23 
           running in: yakuake inxi: 3.0.20

Thanks,


[Stable Update] 2018-08-25 - Kernels, KDE Apps & Framework, Flatpak 1.0, Nvidia, Cleanup
#228

Well, these are the changes made to systemd so far:


#229

I’ll take a look at this when I have time. Thanks.


#230

If I revert lines 90-92

# merge the latest stable commit (fast-foward only to make sure
# the verified tag is in)
git merge --ff-only "${_commit}"

to the previous command

git checkout "$_commit"

it appears to solve the problem (maybe too early, I’m up for 13 mins, but no problems so far).

I’m not experienced enough, nor I know the development/packaging history, to know what exactly is the difference. For what I understand, git checkout replaces files by other of the target commit/branch, while git merge merges the differences of another branch on top of the current branch. You certainly know this much better than me.

Forget about this nonsense. It was too early.


#231

@mbb: maybe check the upstream changes and also look here.


#232

I’m just replying to say I haven’t had time to get into this yet. My family life is crazy at the moment. I don’t even have access to my desktop now.


#233

I solve a similar issue uninstaling libguestfs and then running pacman -Syu


#234

I haven’t seen any activity on this issue in over 20 days. Should I assume this issue is just part of Manjaro now?


#235

As @jonathon stated to you before, your hardware problems appear to be unique to the forum. Why did you not bump the old thread(again)?

Plus it’s GNOME. Maybe 3.30.1 may fix it? (good luck on that)


#236

This was fixed by 2018-09-21 stable update.


#237

Wrong! It wasn’t fixed. I fixed it by changing default from DNSSEC=allow-downgrade to DNSSEC=no. For some reason DNSSEC doesn’t work.


#238

Some DNS providers don’t support DNSSEC. I had to make this change some time ago to get the one I use most to work. I’m not clear why the ‘allow-downgrade’ option fails. :confounded:


#239

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.