[Stable Update] 2018-08-18 - Kernels, Xorg-Server, Mesa, Deepin, MATE, Perl, Python

update
stable

#207

Since the update, i have 2 issues:
First, First, neither CCSM nor Fusion-icon open, when i try to open it in the terminal i have some errors related to python 3.7.
Second, aurman don’t works, when i try to install something this appears:

the following packages are neither in known repos nor in the aur
:: mhwd-nvidia-304xx-1:304.137-1
~~ the following installed packages are found at new locations
:: mhwd-nvidia-304xx moved from core repo to not known
?? Do you acknowledge the new locations of the mentioned packages? N/y: n
2018-08-21 22:23:56,634 - main - show_changed_package_repos - ERROR - User did not read about the changed packages locations, but wanted to install packages on the system.


#208

You said you did not read the message, so aurman exited with a message saying you didn’t read the message.

Either say Y or perform a pacman -R mhwd-nvidia-304xx.

Pro Tip: read messages. :wink:

Pro Tip: read the Known Issues post.


#209

After the update I cannot use primusrun on any wine games. I have tried 3 games wich have worked before the update with primusrun, The Sims 4 and GTA San Andreas, they just give me a Wine error that the games encountered a serious problem and they need to close, the other game Euro Truck Simulator, prompts me with a message that the installation is corrupted and to reinstall the game, so I don’t receive consistent crashes. In terminal primusrun glxgears and optirun glxgears both work. I want to also add that the games run fine and with no problems without primusrun, so I am stuck with the integrated intel card.

Also I have tried Medieval II Total War on Steam which is a native Linux game, it works at first but crashes randomly freezing all the system and requiring a restart, If I enter briefly and then get out the system seems to go crazy, the Latte Dock flickers and cannot open new apps from it, Steam freezes and even if I exit from the system tray leaves the window open but frozen just standing there, navigating trough Application Menu flickers as well and the mouse jumps randomly between App Menu’s items, I cannot Show Hidden icons in Status & Notifications … the system becomes simply unusable and requires a reboot to make all come to normal again.

P.S: all those problems doesn’t appear if I don’t use the primusrun or optirun commands.

My system:
Lenovo y510P Laptop
OS: Manjaro Linux x86_64
Desktop Environment: KDE
Kernel: 4.18.3-1-MANJARO
CPU: Intel i7-4700MQ (8) @ 3.400GHz
GPU: Intel 4th Gen Core Processor
GPU: NVIDIA GeForce GT 750M
Memory: 7895MiB

video-hybrid-intel-nvidia-bumblebee
linux418-bbswitch 0.8-1
bumblebee 3.2.1-20
lib32-primus 20151110-4
primus 20151110-7


#210

Does anyone have any suggestions on the following?: Third monitor stopped working

I’ve sufficiently bloodied my head and the wall trying to figure this one out yesterday, but no luck. This is beginning to impact my ability to work, being down a monitor.


#211

Posting a link to the same issue twice in a different thread isn’t going to help. First time, fine, you’re flagging the issue as related to this update set. Second time, not helpful. If you haven’t had any successfu responses it’s because noone has had the same issue and fixed it, or you haven’t provided enough information, or you need to be patient, or…


#212

Anyone else having connection issues after this update? It appears that on wifi after some time (10 to 30 min) the connection stops working while still active. If I disable the wifi interface and enable it again or suspend it works for another 10-30 min…


#213

A post was merged into an existing topic: Third monitor stopped working


#214

@philm @oberon
Budgie and Mate 17.1.12 are in the OSDN repo :wink:


#215

I use aurman and it stopped working after the Python update. The fix was to “manually” reinstall it with:

git clone https://aur.archlinux.org/aurman.git
cd aurman
makepkg -sci

#216

Hi everyone, just to let those few who uses The Swift programming language that past this update Swift won’t work or compile. This has little to do with Arch or Manjaro, as it is due to the poor support Apple is offering to linux users.


#217

Due to the lack of Linux support maybe Linux users shouldn’t buy buy or use Apple products?


#218

Don’t be too harsh, its open sourced under Apache2. I think it is ok to use…


#219

Well in that case then…


#220

Lol, sorry, I understood that if I knew where they were located now, english isn’t my natal languaje, so sometimes I do not understand well.

I already read it, the problem was compizconfig-python. I have reinstalled compizconfig-python, ccsm and fusion-icon from AUR and problem solved!
Thanks, I will read better next time :sweat_smile:


#221

Ooops the following seems broken after the last update on KDE:

Is there a communication breakdown or is it only again the KDE servers that are down?
Happens with designs, happens with icon sets and persists since two days.


#222

looks like downgrading dhcpcd from 7.0.7 to 7.0.5b solved the issue:
sudo pacman -U /var/cache/pacman/pkg/dhcpcd-7.0.5b-1-x86_64.pkg.tar.xz

hope it will be fixed upstream, whatever change caused wifi issues


#223

Or just wait for dhcpcd 7.0.8?

https://roy.marples.name/projects/dhcpcd

https://roy.marples.name/archives/dhcpcd-discuss/0002158.html


#224

A post was split to a new topic: Wired network stopped working


#225

The systemd-logind.service used to take ~130 ms to start on kernel 4.17, but takes over 2 s on kernel 4.18.


#226

For issues with primusrun, please read the wiki post.