[Stable Update] 2018-08-18 - Kernels, Xorg-Server, Mesa, Deepin, MATE, Perl, Python

update
stable

#181

That is a bug that should be fixed in the design of future versions. Surrendering to tty just ends up allowing developers to ignore such problems they have introduced. Before systemd and gnome3 it was never necessary. On this path we will inevitably end up with upstream-enforced early boot update stage.

At the very least the malfunctioning software should be mentioned when TTY upgrade is recommended, this raises awareness and allows people to at least be aware of what causes the issue.


#182

I didn’t update yet (I might wait for another update, since ~20% users reported some problems), but I will use this recommendation so I have a question: once the upgrade is finished, do we just return to the graphical mode or should we immediately reboot from TTY?


#183

That’s the same problem i now get, and also have read on arch forums about it, I’m just happy that is not only me with this problem.

Maybe i try going back to 4.17 kernel to see if it stops that error.

UPDATE: Yeah it only happens with Kernel 4.18, 4.17 has no sd-unmount error.


#184

Harmless warning?

==> Image generation successful
( 3/25) Updating Grub-Bootmenu
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
/dev/mapper/control: open failed: No such device
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.150 (2018-08-01) and kernel driver (unknown version).
Command failed.
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

#185

When I ctrl + alt + f2 and ctrl + alt +f7, xorg runs incorrectly, but I do nothing indeed.


#186

@mparillo I got the same/similar errors that resulted in a grub that removed my Window 7 disk. I don’t know the cause, but a temporary fix until the next kernel upgrade is to reboot and update-grub. (Italic parts are an edit to add clarity)

See: Incompatible libdevmapper on update-grub
in these forums for more information.


#187

NVIDIA GeForce Go 6100


#188

Yes! But the next kernel update results in the same error again.


#189

Yes, that’s the reason I said I don’t know the cause. I should have stated that this is a temporary fix. I’ll edit my previous post.


#190

Even stranger considering that’s like the predecessor (so, even older) than my MCP76…


#191

Xfce had a perfect update. :wink:

Deepin had one very little bug, had to reinstall keepass.

Thanks for another great update.


#192

Bought the laptop, Compaq Presario F730 new in 2007 and still blazing along with Manjaro. I did upgrade the memory (maxed out at 4GB).


#193

Hi all,

I did the big update(via command line), and then rebooted…and everything went weird and slow. For reference i am sure it is all my fault.

on SDDM i lost x when logging in. nothing would bring up shell and so on.

I removed SDDM and installed LXDM…which kinda did the trick…however I have odd behaviour when running plasma (for example gnome tool bar shows up at the top).

Some apps load very slowly. Clementine takes like 10-15 seconds to load. Firefox seems fine.

/ puzzled


#194

Update on 12 Machines and 1 VB without Problems.

DK3


#195

This helped me:
1. Go to the Advanced section of Thunderbird Preferences and click on Config Editor…
2. Copy or start typing extensions.installedDistroAddon.{e2fda1a4-762b-4020-b5ad-a41df1933103} into the search box
3. When it is listed in the preferences list below, right-click on it and choose Reset from the context menu - the preference now isn’t bold anymore and its value is empty
4. Close the editor, leave the Thunderbird options, open Thunderbird’s add-ons manager and switch to the list of installed extensions
5. If Lightning is listed there, click on Uninstall to the right of the list item
6. Restart Thunderbird

The only problem now is how to change Lightning language to my national? Any help?


#196

Can you check if KDE ISO 17.1.12 has similar speed-limits as you have now?


#197

I already recover lightning with my backup.
And it’s still in english indeed…


#198

xps9550, linux44, KDE, update OK


#199

I had this problem and first I’ve tried with octopi but had the same error, but with sudo pacman -Syu everything went smooth.


#200

Hi guys. No problems on my XPS 16 laptop.
On my workstation I had to erase the NVIDIA 304 driver and it works. But will try to solve the issue when time allows. Here are the inxi output before update/upgrade:

System:
  Host: frydov Kernel: 4.17.4-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.1.1 Desktop: Xfce 4.12.4 tk: Gtk 2.24.32 
  Distro: Manjaro Linux 17.1.11 Hakoila 
Machine:
  Type: Desktop System: ASUS product: All Series v: N/A serial: N/A 
  Mobo: ASUSTeK model: B85M-E v: Rev X.0x serial: <filter> 
  BIOS: American Megatrends v: 2202 date: 02/13/2015 
Graphics:
  Card-1: NVIDIA G71GL [Quadro FX 1500] driver: nvidia v: 304.137 
  bus ID: 01:00.0 
  Display: server: X.Org 1.19.6 driver: nvidia 
  resolution: 1680x1050~60Hz, 1680x1050~60Hz 
  OpenGL: renderer: Quadro FX 1500/PCIe/SSE2 v: 2.1.2 NVIDIA 304.137 
  direct render: Yes 

and now it shows:

System:
  Host: frydov Kernel: 4.18.3-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.0 Desktop: Xfce 4.12.4 Distro: Manjaro Linux 
Machine:
... same ...
Graphics:
  Card-1: NVIDIA G71GL [Quadro FX 1500] driver: nouveau v: kernel 
  bus ID: 01:00.0 
  Display: server: X.Org 1.20.1 driver: nouveau unloaded: modesetting 
  resolution: 1680x1050~60Hz, 1680x1050~60Hz 
  OpenGL: renderer: NV49 v: 2.1 Mesa 18.1.6 direct render: Yes 

Thanks again for another nice update.