[Stable Update] 2018-07-24 - Kernels, Pacman-Mirrors, Vulkan, Nvidia

update
stable

#42

Boot to grub and press E instead of Enter when choosing the boot entry. In edit mode you may add 3 to the linux line. That is the line where you see root=. Press then CTRL+X or F10 to boot. You should land in a shell terminal. Check then the packages you may had installed with the last update: tac /var/log/pacman.log | less.


#43

For some reason one of my manjaro (mate) installs lost the keyboard in this or the previous update. Mouse kept working. It was too hard to debug so i just installed the latest beta, much faster that way since it had no custom configurations.


#44

Got the libutf8proc error; solved as adviced; for the rest, AFAIK, all well. :slight_smile:


#45

For informational purposes, I have the exact same issue here.

I switched from 4.17.9-1 kernel to 4.15.18-3 and I am able to boot into Gnome shell without the cursor freezing. I’ll keep my system up and running to see if it stays that way.

Also, and it’s probably an extension issue, but the dash to panel extension creates a duplicate of itself on the desktop, it freezes, then the shell resets and all is well again. Started with this update.

Terminal


#46

The GTS 450 is a Fermi-based NVIDIA GPU. Have you switched to the 390xx series driver? If not, that would likely explain why an EOL kernel (which hasn’t had a driver update) would still be working.


#47

Thanks Jonathan. I have switched drivers and also had to edit gdm custom.conf file (because I also have Wayland), from the last update. For whatever reason the 417 kernel that I would typically boot into, locks my mouse upon booting into the DE. The 415 kernel (so far at least) does not. The mouse behavior only happened after performing this latest stable update.


#48

Hi, I came to look for a solution to my problem which was the same than MolchanoV, and I found the solution myself :slight_smile:
If you do not want your system to always ask you if you allow Redshift to get the geolocation’s data, you only have to edit one file: /etc/geoclue/geoclue.conf and at the end of that file, just add:

[redshift]
allowed=true
system=false
users=

Deepin 15.7 Night Shift (Redshift) always asking permission
Deepin 15.7 Night Shift (Redshift) always asking permission
#49

Thanx! I used the first solution from arch wiki, with manual setting of location parameters, but yours is more universal. Hope it will be put in postinstall scripts in later updates.


#50

FYI :slight_smile:


#51

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.