[Stable Update] 2018-07-01 - Kernels, KDE, LibreOffice, Browsers, Mesa, Systemd, Deepin

update
stable

#70

A bit confused.

How do we know if we should “install systemd-resolvconf”?

That is, why install it? Who should?


#71

the plasma 5.13.2 is so awesome and the manjaro team too … so fare so good … this is update really deserve the waiting and we are greatful to be members to your community


#72

you have the man

man -H resolvconf

resolvconf — a framework for managing multiple DNS configurations

not multiple DNS config = forget

this manjaro package provide only a sym link “usr/bin/resolvectl” for replace /usr/bin/resolvconf

The resolvectl/systemd-resolve tool also provides ‘resolvconf’ compatibility. It may be symlinked under the ‘resolvconf’ name, in which case it will take arguments and input compatible with the Debian and FreeBSD resolvconf tool.


#73

i have a slight issue when i right click on the app menu and hover on the menu it keeps highlighting all the elements that i move the cursor out from them and also i can’t do a screenshot to show you the issue even by using the screenshot key in the keyboard


#74

Yes, I know what it is, roughly. But why change to systemd-resolvconf?

“You may want to install systemd-resolvconf” is in the top of this post. Why would we “want to install systemd-resolvconf” instead of leaving things the way they are?

How do we know if we should install systemd-resolvconf?


#75

I think this was first noted in the 2018-06-29 testing update:


#76

Updated with minor problems the gnome version.
After update nautilus launch but not show the personal folder. Tried to launch nautilus from terminal to see the error messages but nothing was showed.
Finally launched nautilus from terminal with an URI (anyone is fine) and that solved the problem. Restarted the system and now al work flawlessly


split this topic #77

A post was split to a new topic: Blank screen with a cursor after 2018-07-01 Stable Update


#78

Same thing here. Update worked flawlessly afterwards. Thankfully I saw this thread.


#79

Smooth update, many thanks! :wink:

the versions of catfish and vlc still presents old unresolved bugs.

P.S.

Removing completely engrampa-thunar-plugin package made me unable to use the “create an archive” option in Thunar on my machine.
I resolved with sudo rm /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap , then I reinstalled engrampa-thunar-plugin after the update.


#80

Ditto doubling lines in pamac

Other than that just the usual permissions warnings.
All good and running fine.

Now off to see what all the excitement about Plasma 5.13 - so far nothing earth shattering.


#81

reported and fixed


#82

Everything went well and remembering that the thunar plugin of engrampa in XFCE is no longer needed, but can be installed by removing emgrampa.tap.
Successfully updated to release 17.1.11 Hakoila.


split this topic #83

3 posts were split to a new topic: NetworkManager + dnsmasq + dnscrypt-proxy stopped working together


#84

Yes, just reinstall this dotnet-sdk package.
At the Manjaro is the version 2.1.1+301-1 just like arch.


#85

Same issue. Thanks for posting. :wink:

Sorry @philm. Didn’t see you had already mentioned it. Must learn to slow down & read things, not scroll through. :nauseated_face:

Also had to add ‘sceenfetch’ to my bash.bashrc file. Seems to have got removed.


#86

I want know this too.

As I read, you have tools to manager dns resolve
resolvconf: a 'Debian and FreeBSD resolvconf tool
resolvectl/systemd-resolve: from systemd

and in 239, they add compatibility to resolvconf, install that package, it will symlink resolvectl to resolvconf, means you use systemd tool only and also won’t break any applications rely on resolvconf (I think).

but then I find it confusing about systemd-resolved, /etc/resolv.conf, network-manager, and four modes … someone please explain this.

so it’s that: if you have ‘openresolv’ installed (which provide resolvconf), you can install ‘systemd-resolvconf’ to replace it as it’s compatible with it now. but I don’t know if you need enable systemd-resolve.service, if current it’s disabled.


#88

XFCE, 4.14.52

Ran into the “File conflict engrampa.tap” issue (which is easy enough to fix). I also had file conflicts with node-gyp (which was also easy to fix: sudo rm -rf /usr/lib/node_modules/node-gyp and sudo rm -rf /usr/lib/node_modules/semver). Other than that, everything looks good!

Thanks for the great work!


#89

Edit: solved. see my post directly below this one if you are having the same issue.

Not sure what this is trying to tell me but it is causing the upgrade to fail. Spent about an hour googling and searching in this forum and trying solutions to the “* exists in filesystem error”. Unfortunately I can’t just reinstall python as pacman won’t let me (removing python would break the python dependency according to the error).

:: Proceed with installation? [Y/n] Y 
(486/486) checking keys in keyring                                                          [######################################################] 100% 
(486/486) checking package integrity                                                        [######################################################] 100% 
(486/486) loading package files                                                             [######################################################] 100% 
(486/486) checking for file conflicts                                                       [######################################################] 100% 
error: failed to commit transaction (conflicting files) 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__init__.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/__init__.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/basecommand.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/baseparser.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/build_env.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/cache.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/cmdoptions.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/compat.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/configuration.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/download.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/exceptions.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/index.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/locations.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/pep425tags.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/resolve.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/status_codes.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/__pycache__/wheel.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/basecommand.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/baseparser.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/build_env.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/cache.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/cmdoptions.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__init__.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/__init__.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/check.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/completion.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/configuration.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/download.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/freeze.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/hash.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/help.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/install.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/list.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/search.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/show.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/uninstall.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/__pycache__/wheel.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/check.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/completion.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/configuration.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/download.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/freeze.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/hash.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/help.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/install.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/list.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/search.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/show.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/uninstall.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/commands/wheel.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/compat.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/configuration.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/download.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/exceptions.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/index.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/locations.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/models/__init__.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/models/__pycache__/__init__.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/models/__pycache__/index.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/models/index.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/operations/__init__.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/operations/__pycache__/__init__.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/operations/__pycache__/check.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/operations/__pycache__/freeze.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/operations/__pycache__/prepare.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/operations/check.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/operations/freeze.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/operations/prepare.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/pep425tags.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/req/__init__.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/req/__pycache__/__init__.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/req/__pycache__/req_file.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/req/__pycache__/req_install.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/req/__pycache__/req_set.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/req/__pycache__/req_uninstall.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/req/req_file.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/req/req_install.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/req/req_set.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/req/req_uninstall.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/resolve.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/status_codes.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__init__.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/__init__.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/appdirs.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/deprecation.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/encoding.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/filesystem.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/glibc.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/hashes.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/logging.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/misc.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/outdated.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/packaging.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/setuptools_build.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/temp_dir.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/typing.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/__pycache__/ui.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/appdirs.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/deprecation.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/encoding.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/filesystem.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/glibc.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/hashes.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/logging.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/misc.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/outdated.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/packaging.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/setuptools_build.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/temp_dir.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/typing.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/utils/ui.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/vcs/__init__.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/vcs/__pycache__/__init__.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/vcs/__pycache__/bazaar.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/vcs/__pycache__/git.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/vcs/__pycache__/mercurial.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/vcs/__pycache__/subversion.cpython-36.pyc exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/vcs/bazaar.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/vcs/git.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/vcs/mercurial.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/vcs/subversion.py exists in filesystem 
python-pip: /usr/lib/python3.6/site-packages/pip/_internal/wheel.py exists in filesystem 
Errors occurred, no packages were upgraded.

#90

i guess i’ll just try to manually delete dozens of private python files because the package manager says they’re not owned by any package…

EDIT: well, i guess that was the solution. ended up just deleting the marked as private _internal folder of pip and reran the upgrade, which seemed to have worked.