[Stable Update] 2018-07-01 - Kernels, KDE, LibreOffice, Browsers, Mesa, Systemd, Deepin



Hi community,

Welcome to another stable update. So what do we have with this one?

  • Updated KDE Plasma to v5.13.2
  • KDE Frameworks are now at v5.47
  • QT got updated to v5.11.1
  • Our browsers got updated to their latest versions (Firefox v61.0, v62b4; Chromium; Palemoon)
  • A new set of Deepin and Cinnamon package updates
  • For XFCE 4.14 we got xfdesktop and xfsettings updated.
  • Latest Nvidia legacy drivers
  • We added the latest Mesa 18.1.3, including fixing crashes with illegal instruction vmovq on CPUs without AVX support
  • Systemd introduces v239 series. You may want to install systemd-resolvconf
  • Latest kernels got added. Some are now marked as EOL.
  • Latest LibreOffice v6.0.5
  • We released manjaro-tools v0.15.8
  • Frede pushed out another bugfix release of pacman-mirrors
  • Ramon found time to update our Breath theme for v5.13 series
  • Bernhard updated the realtime kernel for v4.16 series
  • Philip added the latest RC kernel of v4.18 series.
  • Stefano found time to update our Adapta theme series once again
  • Haskell and Python updates/rebuilds.

We hope with all these changes Manjaro to be more efficient for you all.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:

Our KDE fans may try our beta-build with the latest KDE v5.13 instead.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.113 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.138
  • linux49 4.9.110
  • linux414 4.14.52
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.3
  • linux418 4.18-rc2
  • linux414-rt 4.14.40_rt30
  • linux416-rt 4.16.15_rt7

Package Updates (Sat Jun 30 09:40:26 CEST 2018)

  • stable community x86_64: 1116 new and 1095 removed package(s)
  • stable core x86_64: 58 new and 56 removed package(s)
  • stable extra x86_64: 776 new and 860 removed package(s)
  • stable multilib x86_64: 32 new and 26 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Network Manager WiFi problem reloaded
Upgrade over a rolling distro?
GIMP: can't open pictures
Cannot Connect to Public (passwordless) Wifi Networks
[Solved] ERROR: device '/dev/mapper/volumegroup-logicalvolume_root' not found

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Thunar crashes after update

Thunar 1.8.1 contains a bug wherin Thunar will crash if not all User Custom Actions have icons assigned. Workaround is to assign an icon to each. This will be fixed in Thunar 1.8.2

Items from previous update sets

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension “Workspace to Dock” is bugged

Be careful like there is a bug if you use the Extension “Workspace to Dock”. You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file’s syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name “Everyone” to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

Thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem
XFCE pulse audio plugin on panel wrong menu location
Thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem
Pamac showing Error while continue aborted update process
Conflicts with thunar-archive-plugin
Pamac showing Error while continue aborted update process
What's the best kernel version after installating manjaro
Known Issues from Stable Updates Announcements
Problems with "-Syu"
Refresh data basis - infinite loop?

Is worth mentioning that upstream dropped pcmciautils and zd1211-firmware to the AUR, thus are external packages now and are safe to remove

@philm I’ll appreciate when I can work again on iso-profiles


I have been expecting this!

kinda dull not to upgrade for 3 weeks lol

I know, I am bad.


Updated 3 systems on XFCE, no issues noticed. Thanks team :+1:


Clean Update without bugs. Many Thanks to the Dev’s.:+1:


Granted needed access. Please work on the master branch.


great update again :grinning:

Thanks to the manjaro-team.






Everything is fine on my side: laptop with linux417+cinnamon+intel graphics i915


Huge update, but everything OK on KDE+i3.


After this update my system will not boot into a desktop session. It halts at the boot up messages; I’m unable to change to a different TTY.

If I boot to the command line from Grub, the system appears fine. Something went wrong with my system’s graphics due to this update.

Edit - I resolved the issue; it was caused by GDM/Wayland. Somehow the WaylandEnable=false line in /etc/gdm/custom.conf was commented out. This broke my Nvidia/GNOME setup.

I could have sworn I edited this file manually to disable Wayland, so it shouldn’t have been able to change without generating a .pacnew file. Giving the benefit of the doubt, I am going to chalk this issue up to user error.


Anyone who have lvm and updated the system had an error with root not being found?


Thanks for the update :slight_smile:
I had a small issue but resolved it as @philm suggested by removing engrampa-thunar-plugin.


:open_mouth: that was fast I’ve just turn on my PC at 9:30 am and bang updates available,thank you so much Manjaro team!!!


Running Xfce 4.12. Updated 2 of my computers so far. There seems to be an issue that causes thunar 1.8.1-1 to crash involving User Custom Actions and certain icons.

EDIT 6: Found workaround and bug report. Workaround is to make sure that all of your User Custom Actions have icons defined. This bug will be fixed in the next release of Thunar (1.8.2). (Added to wiki post above)

How to add additional functionality to file manger?

Shouln’t this be the Stable Updates Announcements feed?


Update went fine, 2 laptops, Cinnamon DE, kernels 4.14 and 4.17.


During the update I received the following warnings, do I have to do something?

  1. warning: /etc/systemd/logind.conf installed as /etc/systemd/logind.conf.pacnew

  2. warning: /usr/bin/pinentry installed as /usr/bin/pinentry.pacnew

  3. warning: directory permissions differ on /usr/share/doc/nfs-utils/
    filesystem: 644 package: 755

  4. warning: /etc/pulse/default.pa installed as /etc/pulse/default.pa.pacnew


Yes, use search function :wink: