[Stable Update] 2018-06-10 - Kernels, KDE Apps, LibreOffice, Firefox, GCC, Gambas, Deepin


#59

Thanks, & yes, IF you mean what i wrote in my earlier [December] topic, whose last post was
Dell XPS-15 Laptop's Touchpad config problem

…in which topic i described that i need & want my trackpad to still have tap-to-click, edge-scrolling, circular-scrolling etc, per my OP at Dell XPS-15 Laptop's Touchpad config problem. None of those worked back in Dec with xf86-input-libinput, but they work beautifully with xf86-input-synaptics. Hence i intend to keep using xf86-input-synaptics for as long as i can.


#60

xps9550,KDE,linux44, update OK


#61

Me too, normal path

/usr/share/backgrounds

in /usr/share/backgrounds/deepin the wallpaper image is named “desktop.jpg” *

Blur versions, with fantasy names, in

/var/cache/image-blur

  • But I have 4 work spaces, with different pictures, where stored???

How we can change to standard path??? No way :wink:

To refill the bar with alternative wallpapers, go to the appropriate folder (for example /usr/share/backgrounds) and right-click - as background image.

Refill

Maybe this give me also the white page on shutdown-button.

Edit.
I delete the dir /picture/wallpaper/ , no difference.

From github

~/.config/deepin/dde-daemon/appearance/custom-wallpers

One wallpaper.

We need -extra or Variety?

After 2nd restart and change “my” wallpaper in /usr/share/backgrounds I got black background on login/logout screen. I see now everything for restart, etc… . Perfect.

I fixed the dead link in the file “default_background.jpg” by placing a copy in /usr/share

Zusammenfassung

In order to get the previous “blur” instead of the black background, I would have to change the name, but I have 2-3 to choose from. The main thing is the white is gone :wink:

eff.. to 005...??

I changed the name, here we go :wink: blur

convert wallpaper.jpg -filter Gaussian -blur 0x16 wallpaper-blur.jpg

more Deepin Wallpaper Chooser Bug


[Stable Update] 2018-05-26 - Kernels, Nvidia, Xorg-Server, Mesa, Browsers, Deepin, Calamares, Pamac
Manjaro Deepin custom wallpaper results in black screen on Launcher and Logout screen [Solved]
[Testing Update] 2018-06-16 - Kernels, KDE Plasma, Firefox, Haskell, Python
[BUG] White screen after click power button at dock
Manjaro Deepin custom wallpaper results in black screen on Launcher and Logout screen [Solved]
[Stable Update] 2018-05-26 - Kernels, Nvidia, Xorg-Server, Mesa, Browsers, Deepin, Calamares, Pamac
[Testing Update] 2018-06-09 - Kernels, KDE Apps, LibreOffice, Firefox, GCC, Gambas, Deepin
[Testing Update] 2018-06-09 - Kernels, KDE Apps, LibreOffice, Firefox, GCC, Gambas, Deepin
[BUG] White screen after click power button at dock
Deepin Wallpaper Chooser Bug
Deepin Wallpaper and more by SGS
#62

I had the same error when I’ve updated.
I’ll try to use this command.


#63

Help I got this unknown trust thing.

sudo pacman -Syyu
:: Synchronizing package databases...
 core                                        145.0 KiB   296K/s 00:00 [#######################################] 100%
 extra                                      1783.2 KiB  97.6K/s 00:18 [#######################################] 100%
 community                                     4.7 MiB   115K/s 00:42 [#######################################] 100%
 multilib                                    179.6 KiB   288K/s 00:01 [#######################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (206) akonadi-18.04.2-1  akonadi-calendar-18.04.2-1  akonadi-calendar-tools-18.04.2-1
               akonadi-contacts-18.04.2-1  akonadi-import-wizard-18.04.2-1  akonadi-mime-18.04.2-1
               akonadi-notes-18.04.2-1  akonadi-search-18.04.2-1  ark-18.04.2-1  babl-0.1.50+5+g7af0e8c-1
               baloo-widgets-18.04.2-1  binutils-2.30-5  bison-3.0.5-1  blender-17:2.79.b.git2.0385b33f-16
               bluez-5.50-2  bluez-libs-5.50-2  boost-1.67.0-4  boost-libs-1.67.0-4  calendarsupport-18.04.2-1
               calf-0.90.0-3  chromium-67.0.3396.79-1  dcraw-9.28.0-1  dolphin-18.04.2-1  dolphin-plugins-18.04.2-1
               eventviews-18.04.2-1  ffmpegthumbs-18.04.2-1  filelight-18.04.2-1  firefox-60.0.2-1
               flatpak-0.11.8.1-1  gcc-8.1.1+20180531-1  gcc-libs-8.1.1+20180531-1  gegl-0.4.2+14+g190a81b4a-1
               grantleetheme-18.04.2-1  gtkglext-1.2.0-11  gvfs-1.36.2-2  gvfs-afc-1.36.2-2  gvfs-gphoto2-1.36.2-2
               gvfs-mtp-1.36.2-2  gvfs-nfs-1.36.2-2  gvfs-smb-1.36.2-2  gwenview-18.04.2-1  hardinfo-0.5.1-7
               harfbuzz-1.8.0-1  harfbuzz-icu-1.8.0-1  hyphen-2.8.8-2  incidenceeditor-18.04.2-1  k3b-1:18.04.2-1
               kaccounts-integration-18.04.2-1  kaccounts-providers-18.04.2-1  kalarmcal-18.04.2-1
               kamera-18.04.2-1  kate-18.04.2-1  kcalc-18.04.2-1  kcalcore-18.04.2-1  kcalutils-18.04.2-1
               kcontacts-18.04.2-1  kdav-18.04.2-1  kdegraphics-thumbnailers-18.04.2-1
               kdenetwork-filesharing-18.04.2-1  kdenlive-18.04.2-1  kdepim-addons-18.04.2-1
               kdepim-apps-libs-18.04.2-1  kdepim-runtime-18.04.2-1  kdesdk-thumbnailers-18.04.2-1
               kdialog-18.04.2-1  keditbookmarks-18.04.2-1  keyutils-1.5.10-2  kfind-18.04.2-1
               khelpcenter-18.04.2-1  kidentitymanagement-18.04.2-1  kimap-18.04.2-1  kio-extras-18.04.2-1
               kldap-18.04.2-1  kmailtransport-18.04.2-1  kmbox-18.04.2-1  kmime-18.04.2-1  konsole-18.04.2-1
               kontactinterface-18.04.2-1  korganizer-18.04.2-1  kpimtextedit-18.04.2-1  krita-4.0.3-2
               ksmtp-18.04.2-1  ksystemlog-18.04.2-1  ktnef-18.04.2-1  kwalletmanager-18.04.2-1  ladspa-1.13-7
               lib32-bzip2-1.0.6-3  lib32-gcc-libs-8.1.1+20180531-1  lib32-glib2-2.56.1-1  lib32-glu-9.0.0-4
               lib32-libffi-3.2.1-2  lib32-libxdamage-1.1.4-3  lib32-pcre-8.42-1  libarchive-3.3.2-2
               libcmis-0.5.1-9  libelf-0.171-1  libepubgen-0.1.1-1  libfakekey-0.3-1  libgravatar-18.04.2-1
               libid3tag-0.15.1b-9  libinput-1.11.0-1  libiptcdata-1.0.4-4  libixion-0.13.0-2  libkate-0.4.1-6
               libkcddb-18.04.2-1  libkdcraw-18.04.2-1  libkdepim-18.04.2-1  libkexiv2-18.04.2-1
               libkgapi-18.04.2-1  libkipi-18.04.2-1  libkleo-18.04.2-1  libkolabxml-1.1.6-8  libksane-18.04.2-1
               libksieve-18.04.2-1  libmad-0.15.1b-8  libmng-2.0.3-2  libnfnetlink-1.0.1-3  libnih-1.0.3-3
               libodfgen-0.1.6-2  libomxil-bellagio-0.9.3-2  liborcus-0.13.4-2  libquvi-scripts-0.9.20131130-4
               libreoffice-fresh-6.0.4-2  librevenge-0.0.4-2  libstaroffice-0.0.6-1  libtar-1.2.20-4
               libtool-2.4.6+40+g6ca5e224-7  libtorrent-rasterbar-1:1.1.7-2  libunistring-0.9.10-1
               libutempter-1.1.6-3  libva-mesa-driver-18.1.1-1  libxaw-1.0.13-2  libxcomposite-0.4.4-3
               libxdmcp-1.1.2-2  libxext-1.3.3-2  libxft-2.3.2-2  linux414-4.14.48-2  linux416-4.16.14-2
               linux417-4.17.0-2  lua52-expat-1.3.0-4  lua52-lpeg-1.0.1-2  lxc-1:3.0.1-1  mailcommon-18.04.2-1
               mailimporter-18.04.2-1  marble-common-18.04.2-1  mesa-18.1.1-1  mesa-vdpau-18.1.1-1
               messagelib-18.04.2-1  metis-5.1.0.p3-1  mkinitcpio-busybox-1.28.4-1  mono-5.12.0.260-1
               mozilla-common-1.4-5  mtdev-1.1.5-2  mtpfs-1.1-3  nano-2.9.8-1  nodejs-10.4.0-1  nss-mdns-0.10-7
               okular-18.04.2-1  openimageio-1.8.12-1  openjpeg-1.5.2-2  openshadinglanguage-1.9.9-5
               openvdb-5.1.0-2  ostree-2018.5-1  paprefs-0.9.10-7  pcmciautils-018-8  pimcommon-18.04.2-1
               pkcs11-helper-1.23-1  polkit-gnome-0.105-4  portsmf-228-3  print-manager-18.04.2-1
               procps-ng-3.3.15-1.1  pulseaudio-alsa-2-4  python-cachecontrol-0.12.5-1  python-evdev-1.0.0-1
               python-pycurl-7.43.0.2-1  python-pytoml-0.1.16-1  python-requests-2.18.4-3  python-scipy-1.1.0-1
               python-urllib3-1.23-1  python2-beaker-1.10.0-1  python2-notify-0.1.1-14  qrencode-4.0.2-1
               readline-7.0.005-1  sbc-1.3-2  signon-kwallet-extension-18.04.2-1  sound-theme-freedesktop-0.8-3
               spandsp-0.0.6-2  spectacle-18.04.2-1  speexdsp-1.2rc3-3  sqlite-3.24.0-1  squashfs-tools-4.3-5
               suitesparse-5.2.0-1  svgpart-18.04.2-1  vulkan-intel-18.1.1-1  vulkan-radeon-18.1.1-1
               xcb-util-0.4.0-2  xcb-util-image-0.4.0-2  xcb-util-keysyms-0.4.0-2  xcb-util-renderutil-0.3.9-2
               xcb-util-wm-0.4.1-2  xf86-input-evdev-2.10.6-1  xkeyboard-config-2.24-1  xmlsec-1.2.26-1
               xorg-xkbcomp-1.4.2-1  yajl-2.1.0-2  zita-alsa-pcmi-0.2.0-4

Total Installed Size:  3005.01 MiB
Net Upgrade Size:        18.32 MiB

:: Proceed with installation? [Y/n] Y
(206/206) checking keys in keyring                                    [#######################################] 100%
(206/206) checking package integrity                                  [#######################################] 100%
error: gcc-libs: signature from "Bartlomiej Piotrowski <b@bpiotrowski.pl>" is unknown trust
:: File /var/cache/pacman/pkg/gcc-libs-8.1.1+20180531-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] ^C
Interrupt signal received

sudo pacman-key --refresh-keys
[sudo] password for kevin: 
gpg: refreshing 22 keys from hkps://hkps.pool.sks-keyservers.net
gpg: key FC1B547C8D8172C8: 103 signatures not checked due to missing keys
gpg: key FC1B547C8D8172C8: "Levente Polyak (anthraxx) <levente@leventepolyak.net>" not changed
gpg: key 65C110C1EA433FC7: 22 signatures not checked due to missing keys
gpg: key 65C110C1EA433FC7: "Sergej Pupykin <arch@sergej.pp.ru>" not changed
gpg: key CAA6A59611C7F07E: 14 signatures not checked due to missing keys
gpg: key CAA6A59611C7F07E: "Philip M�ller (Called Little) <philm@manjaro.org>" not changed
gpg: key 84818A6819AF4A9B: 9 signatures not checked due to missing keys
gpg: key 84818A6819AF4A9B: "Eli Schwartz <eschwartz@archlinux.org>" not changed
gpg: key EEEEE2EEEE2EEEEE: 10 duplicate signatures removed
gpg: key EEEEE2EEEE2EEEEE: 37 signatures not checked due to missing keys
gpg: key EEEEE2EEEE2EEEEE: 3 signatures reordered
gpg: key EEEEE2EEEE2EEEEE: "Gaetan Bisson <gaetan@fenua.org>" not changed
gpg: key FCF3C8CB5CF9C8D4: 6 signatures not checked due to missing keys
gpg: key FCF3C8CB5CF9C8D4: "Alexander R�dseth <rodseth@gmail.com>" not changed
gpg: key C06086337C50773E: 12 signatures not checked due to missing keys
gpg: key C06086337C50773E: "Jelle van der Waa <jelle@vdwaa.nl>" not changed
gpg: key 39E4B877E62EB915: 9 signatures not checked due to missing keys
gpg: key 39E4B877E62EB915: "Sven-Hendrik Haase <svenstaro@gmail.com>" not changed
gpg: key 51E8B148A9999C34: 25 signatures not checked due to missing keys
gpg: key 51E8B148A9999C34: "Evangelos Foutras <evangelos@foutrelis.com>" not changed
gpg: key A91764759326B440: 34 signatures not checked due to missing keys
gpg: key A91764759326B440: "Lukas Fleischer <lfleischer@lfos.de>" not changed
gpg: key 976AC6FA3B94FA10: 8 signatures not checked due to missing keys
gpg: key 976AC6FA3B94FA10: "Jan de Groot <info@jandegrootict.nl>" not changed
gpg: key 6D1655C14CE1C13E: 2 duplicate signatures removed
gpg: key 6D1655C14CE1C13E: 96 signatures not checked due to missing keys
gpg: key 6D1655C14CE1C13E: 1 bad signature
gpg: key 6D1655C14CE1C13E: 1 signature reordered
gpg: key 6D1655C14CE1C13E: "Florian Pritz <bluewind@xinu.at>" not changed
gpg: key 06096A6AD1CEDDAC: 1 duplicate signature removed
gpg: key 06096A6AD1CEDDAC: 12 signatures not checked due to missing keys
gpg: key 06096A6AD1CEDDAC: 1 signature reordered
gpg: key 06096A6AD1CEDDAC: "Laurent Carlier <lordheavym@gmail.com>" not changed
gpg: key 4AC5588F941C2A25: 18 signatures not checked due to missing keys
gpg: key 4AC5588F941C2A25: "Antonio Rojas <arojas@archlinux.org>" not changed
gpg: key A5E9288C4FA415FA: 10 duplicate signatures removed
gpg: key A5E9288C4FA415FA: 234 signatures not checked due to missing keys
gpg: key A5E9288C4FA415FA: "Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>" not changed
gpg: key A6234074498E9CEE: 71 signatures not checked due to missing keys
gpg: key A6234074498E9CEE: "Christian Hesse (Arch Linux Package Signing) <arch@eworm.de>" not changed
gpg: key B02854ED753E0F1F: 6 signatures not checked due to missing keys
gpg: key B02854ED753E0F1F: "Anatol Pomozov <anatol.pomozov@gmail.com>" not changed
gpg: key 786C63F330D7CB92: 391 signatures not checked due to missing keys
gpg: key 786C63F330D7CB92: "Felix Yan <felixonmars@archlinux.org>" not changed
gpg: key 94657AB20F2A092B: 20 signatures not checked due to missing keys
gpg: key 94657AB20F2A092B: "Andreas Radke <andyrtr@archlinux.org>" not changed
gpg: key BBE43771487328A9: 31 signatures not checked due to missing keys
gpg: key BBE43771487328A9: "Bartlomiej Piotrowski <b@bpiotrowski.pl>" not changed
gpg: key 9C08A255442FAFF0: 5 signatures not checked due to missing keys
gpg: key 9C08A255442FAFF0: "Jonathon Fernyhough <jonathon@manjaro.org>" not changed
gpg: Total number processed: 21
gpg:              unchanged: 21

When I try to update manjaro-keyring

sudo pacman -S manjaro-keyring
warning: manjaro-keyring-20180607-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) manjaro-keyring-20180607-1

Total Installed Size:  0.14 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] Y
(1/1) checking keys in keyring                                        [#######################################] 100%
(1/1) checking package integrity                                      [#######################################] 100%
error: manjaro-keyring: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/manjaro-keyring-20180607-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 


#64

#65

Thank you to the Manjaro team! Update of Manjaro Xfce and upgrade to kernel 4.17 went smoothly.

I’m gathering experience in best practice for updating Manjaro: It is not sufficient to only look at /var/log/pacman.log, but one should watch the terminal output during pacman -Syyu or - better still - copy that output to a log file of your own. The reason is that messages like e.g. “new optional dependencies for package xyz …” show up in the terminal only. (In my case, this holds for Cantata.)

In the process of cleaning up dependencies and rights after the update, I am left with one dependency:
Optionale Abhängigkeiten für python-html5lib python-lxml: lxml treebuilder python-genshi: genshi treewalker
Trying to install python-genshi either via pamac or pacman results in an error:
Ziel nicht gefunden
(target not found). python-lxml is fine.


#66

AFAIK, the update went well, so i will not worry… thanks for the answer. :slight_smile:


#67

Pop-up window error stated:

Could not get file information for usr/share/locale/af/LC_MESSAGES/libgnome-keyring.mo
[Several ‘locales’ listed, af, afn, ast, be, bg, etc. etc]
directory permission differ on /etc/ceph/
filesystem: 755 package: 750
directory permission differ on /var/lib/ceph/
filesystem: 755 package: 750
directory permission differ on /var/log/ceph/
filesystem: 755 package: 750
directory permission differ on /var/lib/mlocate/
filesystem: 755 package: 750

Then the update window stated:

Failed to commit transaction:
transaction not initialized

Building (null)…
Building (null)…
Cloning into ‘(null)’…
Cloning into ‘(null)’…
fatal: cannot copy ‘/usr/share/git-core/templates/description’ to ‘/tmp/pamac-build-steve/(null)/.git/description’: File exists
/tmp/pamac-build-steve/(null)/.git/hooks/: No such file or directory


#68

My Blender issue is starting to impede my system: in order to run the version which allows me to render my videos, i would also need to downgrade boost and boost-libs… which are required to run other programs i use, such as Qbittorrent and LibreOffice.

So from now on i’ll use the official release version of Blender, until things got worked out. :unamused:


#69

Plasma5, screenfetch not opening after the update, optirun-primusrun glxspheres64 not starting


#70

gt


#71

Read the wiki post at the very start of this thread. It clearly tells you what to do.


#72

I have seen argued that the message is informational of what happened, not of what is wrong. So nothing is needed to be done.

edit: thanks to the downvoters, anyone interested in reality can check the folder/file permission before chmodding it. Every time i have seen that message the pacman already changed the permission and the message is a notification of this.


#73

I have this problem whit the update


#74

Nevermind - Feel like an idiot. I missed the wiki post in the start of this thread.

Solution: sudo chmod 755 /var/lib/mlocate/


#75

Firstly, please post text instead of a screenshot when possible.

Secondly,

Thirdly, please never use sudo pip install unless you know exactly why you need to. This issue is one that you have caused.


#76

suspend was not working well too, and bumblebee not working after suspend

everything seems fixed with sudo systemctl enable tlp-sleep as seen here


#77

Thanks


#78

This country not available in your content (gitSoft) IE 40004 return to other page rather than home*