[Stable Update] 2018-06-10 - Kernels, KDE Apps, LibreOffice, Firefox, GCC, Gambas, Deepin


#1

Hi community,

Welcome to another stable update. So what do we have with this one?

  • All our kernels got updated or rebuild against gcc 8.1.1+20180531-1
  • Fixed booting issue with linux49
  • Pamac got fixed in regard of AUR-builds
  • LibreOffice got updated
  • Latest Deepin packages added
  • We updated KDE Apps
  • Firefox offers some fixes and changes
  • Usual upstream rebuilds

We hope with all these changes Manjaro to be more efficient for you all.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.112 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.136
  • linux49 4.9.107
  • linux414 4.14.48
  • linux415 4.15.18 [EOL]
  • linux416 4.16.14
  • linux417 4.17.0
  • linux414-rt 4.14.40_rt30
  • linux416-rt 4.16.12_rt5

Package Updates (Sat Jun 9 10:31:49 CEST 2018)

  • stable community x86_64: 979 new and 965 removed package(s)
  • stable core x86_64: 44 new and 44 removed package(s)
  • stable extra x86_64: 811 new and 805 removed package(s)
  • stable multilib x86_64: 19 new and 19 removed package(s)

A detailed list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


After installing updates, Manjaro won't start
Getting into Emergency Shell after recent updates
17.1.10 Hakoila slow boot due to luks encryption?
Downgrading to a specific kernel version
#2

Known issues and solutions

This is a wiki post; please edit as necessary.

warning: directory permissions differ on /var/lib/mlocate/
filesystem: 750 package: 755

sudo chmod 755 /var/lib/mlocate/


Items from previous update sets

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension “Workspace to Dock” is bugged

Be careful like there is a bug if you use the Extension “Workspace to Dock”. You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file’s syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name “Everyone” to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


#3

update done ,
i have theses reports on upgrade :

==> Please note that due to security reasons from version 0.9 on the 
    minimal mDNS stack included in nss-mdns (dubbed "legacy") is no 
    longer built - nss-mdns will not work unless Avahi is running.
==> To enable IPv4 multicast DNS lookups, append 'mdns4' to the hosts line
    in /etc/nsswitch.conf. Use 'mdns6' for IPv6 or 'mdns' for both.

and

>>> The kernel-mode plugin has a new place.
>>> It's now located under /usr/lib/rp-pppoe/rp-pppoe.so
>>> Change LINUX_PLUGIN to the new path in your /etc/ppp/pppoe.conf

Kernel 4.17.0-1 | Does not see the network cable
#5

KDE Plasma, kernel 4.16.14-2, running smoothly after reboot.

Thanks for the update! :+1:


#6

And now 4.9 does not crash any more at boot :grin:

Thanks to the devs :+1:


#7

All good so far on 3 XFCE systems, kernel 4.14 :+1:


#8

176/176) checking package integrity [################################] 100%
error: hplip: signature from “Andreas Radke andyrtr@archlinux.org” is invalid
:: File /var/cache/pacman/pkg/hplip-3.18.5-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: linux44: signature from “Philip Müller (Called Little) philm@manjaro.org” is invalid
:: File /var/cache/pacman/pkg/linux44-4.4.136-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: linux49: signature from “Philip Müller (Called Little) philm@manjaro.org” is invalid
:: File /var/cache/pacman/pkg/linux49-4.9.107-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

At this stage, I had never seen this notice.

How can I proceed now?

edit//
by reapplying these:

sudo pacman -Sy
sudo pacman -S archlinux-keyring
sudo pacman -Su


#9

Is it safe to ignore this?

warning: could not get file information for usr/share/fonts/encodings/encodings.dir
warning: could not get file information for usr/share/fonts/encodings/large/encodings.dir

#10

No issues noticed on my LXQT systems with kernel 4.16.
Thanks!


#11

I’m having a problem with WiFi, it’s slow and it disconnects sometimes


#12

I removed unnecessary packages after the update with:

sudo pacman -Rns $(pacman -Qtdq)

Amongst other things this removed ceph-libs as it was (supposedly) no longer needed. Then I rebooted and libvirtd crashed with:

error : virModuleLoadFile:53 : internal error: Failed to load module '/usr/lib/libvirt/storage-backend/libvirt_storage_backend_rbd.so': librbd.so.1: cannot open shared object file: No such file or directory

Apparently ceph-libs are required for libvirtd but are not in its dependency list anymore (package bug?). After manually installing ceph-libs again libvirtd started again. Note that I am not using ceph or rbd for libvirtd at all in my setup.


#13

I had to reinstall because of this command. Maybe it works on an arch install but it does evil on manjaro.

This command should be deleted from the wiki. And whoever put it in there mildly beaten.


#14

I’ve just updated & rebooted Lappy, & its KDE/Kernel 4.17.0-2, WiFi, TrackPad etc all seem to be good. I noticed this info in Pamac when i reviewed it post-update pre-reboot:

Upgrading xf86-input-synaptics (1.9.0-1 -> 1.9.1-1)...
>>> xf86-input-synaptics driver is on maintenance mode and
    xf86-input-libinput driver must be prefered over.

Ever since December last year i have deliberately been using xf86-input-synaptics, per my Dell XPS-15 Laptop's Touchpad config problem . I was aware of the maintenance mode status, but now seeing it flagged here prompts me to ask laptop users with xf86-input-libinput driver…

  1. do your trackpads have the full functionality that they used to, or are they still crippled as mine was last December? If crippled, how do you cope?
  2. Any idea of how long “my” driver will remain in the repos, before eventually removed?

#15

yes ignore, it means that these 2 files did not exist on your machine, now they are present


#16

I always check the list of packages to be removed by this command for things that look problematic. If it does break something (like libvirtd here) then there is probably a problem with the broken package itself.

Not that other package managers on other distros cant wreak similar havoc by ‘accidentally’ removing dependencies that are still in use but no longer marked as such.


#17

With this update we now officially provide Deepin Desktop 15.6 :slight_smile:

Screenshot_2018-06-10_00-07-22


#18

It seems to me that:
$ sudo pacman -Rs $(pacman -Qqdt)
would have the same effect on both Arch and Manjaro.

And I think ceph-libs is packaged by Arch (Packager Thore Bödecker foxxx0@archlinux.org), not Manjaro. So, isn’t it an upstream packaging bug?

But thanks for pointing out that this routine, frequently-recommended bit of hygiene can be dangerous in the event of a packaging bug.


#19

I always check pacman -Qtdq ( orphans packages )
and remove only orphans


#20

It was probably (definitely) my fault for doing something really stupid like maybe a typo. Because I couldn’t even open the file manager or pamac afterwards. But I’ve been scarred ever since. :sob:

Anyway, there should be more warnings in that section.


#21

After this update, Freecad does not work anymore.
freecad: error while loading shared libraries: libboost_regex.so.1.66.0: cannot open shared object file: No such file or directory
I can downgrade boost-libs (1.66.0-3 <- 1.67.0-4) but there are other programs also depending on boost-libs (eg. libreoffice) and since I do not foresee to use Freecad soon, I shall wait for it to also be upgraded.