[Stable Update] 2018-05-07 - Kernels, Mesa, Glibc, PHP, Nvidia, Plasma5, Firefox



Not true. I’ve merged ALL changes, even if the change was only a comment on three systems now and currently doing a fourth.

All working fine after the merge. You just have to be careful and know what you’re doing. Not replacing any of your existing settings.


have you shutdown an reboot ?
have you checked in journal ?


Once again you are wrong. Want to try for a third attempt? Like I said, you have to know what you are doing, you obviously don’t. :wink:


Thanks a lot! It works for my computer. My problem is solved.



when i see by option diff -y lines suppressed by .pacnew in
you WILL BROKE one day but not I


Update went relatively alright, as in system was still booting after update :wink:

I still experience the bluetooth problem where my mouse can not pair automatically anymore. This started after the previous stable update and has not been fixed yet.

Also, while mkinitcpio is generating the boot images, I suddenly get this error:

[2018-05-07 09:25] [ALPM-SCRIPTLET] ==> ERROR: file not found:/etc/os-release’`



And there’s your third for the day. Well done :beers:


Hi!! When updating via pamac, it has given me this error and the update stops



If you update via the terminal you can just bypass that error.


Yes!! Solved!!!

I have put these orders in terminal and it has worked:
sudo pacman-mirrors -f 3
sudo pacman -Syyu



This, I use vimdiff and thought “dp” will only put (add) the changes to comment and somehow it took the whole patch, deleted my fstab lines and folded… Confused, I saved and ended up with empty fstab ( glad I checked and recovered from this before reboot).
Nothing wrong with manjaro, just my missunderstanding of vimdiff :smiley:


Good job you noticed! I’m not a huge fan of vimdiff, I do use it though for minor changes. More serious stuff i use meld and go over it all with a fine tooth comb :grinning:


Please add some information to the wiki post regarding the glibc / .pacnew changes. I did read the corresponding wiki pages this morning but I still do not know how to proceed with my nsswitch.conf / nsswitch.conf.pacnew files on my machine using pacdiff.

Are the glibc changes reflected in the pacnew file? Or do I need to overwrite the pacnew file?

Pretty sure I am not the only one trying to understand what to do here. A bit of wiki-post-hand-holding would be very helpful and much appreciated.


RT kenel linux416-rt 4.16.7_rt1 seems to break jack audio. Very choppy sound, much like a normal kernel. Doubling latency (frames/period) helped allot, but did not solve the problem acceptably. 414 works fine. Had to downgrade t use the system.

Is this a consequence of the predictive execution bug fix? Lord, oh lord, I hope not.


split this topic #45

4 posts were split to a new topic: Screen corruption with Nvidia 395.24


Or kompare if you use KDE, great tool.


XFCE desktop:
Read through wiki at top of this post, surveyed replies from other users. Carefully combed through pacnew files.

Everything is great!
Bluetooth reappeared after disappearing 2 updates back and could finally update megasync.

Thank you for the great work, Manjaro team, and all the helpful people who have replied to the update post.


Some debris in the PKGBUILD, apparently. Thanks. Fixing it now.


No issues with update, and dare i say that it seems a long-standing bug in plasma startup got fixed, it does not flicker when switching display mode.


Thank you for this great update, no Errors, all went fine.

System: Host: manjaro Kernel: 4.15.18-1-MANJARO x86_64 bits: 64 Desktop: Cinnamon 3.8.2
Distro: Manjaro Linux 17.1.9 Hakoila
Machine: Type: Desktop Mobo: ASRock model: Z270 Gaming K4 serial: N/A UEFI: American Megatrends v: P1.10
date: 12/05/2016
CPU: Quad Core: Intel Core i5-7500 type: MCP speed: 800 MHz min/max: 800/3800 MHz
Graphics: Card-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/580] driver: amdgpu
v: kernel
Display: x11 server: X.Org 1.19.6 driver: amdgpu resolution: 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: AMD Radeon RX 480 Graphics (POLARIS10 / DRM 3.23.0 / 4.15.18-1-MANJARO LLVM 6.0.0)
v: 4.5 Mesa 18.0.2
Network: Card-1: Intel Ethernet Connection I219-V driver: e1000e
Drives: HDD Total Size: 954.81 GiB used: 167.66 GiB (17.6%)
Info: Processes: 211 Uptime: 1h 27m Memory: 15.63 GiB used: 1.83 GiB (11.7%) Shell: bash inxi: 3.0.07