[Stable Update] 2018-05-07 - Kernels, Mesa, Glibc, PHP, Nvidia, Plasma5, Firefox

update
stable
#299

Bernhard synced with upstream. My question is now if KDE v17.1.10 is now affected by any of this. This was not yet backported to that branch …


0 Likes

#300

it’s certainly is if the ISO was generated before the work of @oberon. I think the best way would be a fix in manjaro-system to remove the DefaultPath in /etc/sddm.conf if it exist (with a .pacsave file in case it was on purpose, but I doubt)

0 Likes

#301

Wouldn’t it be enough to change it to this: DefaultPath=/usr/local/sbin:/usr/local/bin:/usr/bin ? This is now the current setting in master.

0 Likes

#302

it’s suffisant to modify it like as in the master, as it’s how arch change it in the default config and same as how filesystem set it.

0 Likes

#303

… feedback is appreciated.

0 Likes

#304

I use it that way on my installs and works fine.

0 Likes

#305

Fail to load kernel moddules.
I´m writting from windows. I can´t load manjaro.
I´m gonna to install another in a new drive.

0 Likes

#306

Likely your update didn’t complete and left you with non-matching modules for your kernel.
You can either try booting a (hopefully installed) alternative kernel - or you will have to chroot into you installation and start the update again.

1 Like

#307

update installed everything. I did not pay much attention to the updates. The computer continued to work and 7 hours later it was on a black screen with a blinking trace. I had to shut it down and then it did not start again, I tried several versions but they fail kernel modules.
I just recorded the manjaro image and I have to install it on another drive.

0 Likes

#308

I have made a clean installation of Manjaro Gnome 17.1.10 and has not reproduced the problem of entropy that occurred with updates from previous versions. It has also been fixed in Manjaro 17.1.10 pamac blocking to update that had in previous versions

Great work and thanks

(Powered by Google Translator. Sorry for my english) :sweat_smile:

0 Likes

split this topic #309

2 posts were split to a new topic: Can’t make partition

0 Likes

#311

Trying to run Meld as root doesnt seem to be working for me.
Using pkexec…

$ pkexec meld
Unable to init server: Could not connect: Connection refused
Unable to init server: Could not connect: Connection refused
2018-05-13 18:08:43,993 CRITICAL Gtk: gtk_icon_theme_get_for_screen: assertion ‘GDK_IS_SCREEN (screen)’ failed
Traceback (most recent call last):
File “/usr/bin/meld”, line 354, in
setup_resources()
File “/usr/bin/meld”, line 233, in setup_resources
Gtk.IconTheme.get_default().append_search_path(icon_dir)
AttributeError: ‘NoneType’ object has no attribute ‘append_search_path’

Using sudo:

Oxygen::CSS::commit - error reported while parsing:
:21:8not a number

However with sudo, the gui comes up but is unusable. It is a dark themed and when selecting anything all the text is written on top of the previous text rendering anything unreadable.

I’ve searched the manjaro and Arch forums and googled…not finding much.
Using KDE and 4.9 kernel.

0 Likes

#312
pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY meld

and read wiki (polkit plasma)

1 Like

#313

Sorry, I don’t know kde. I think papajoke ^ answered you.

0 Likes

#314

Thats the command you used?
So there was no error anymore on the packagemanager?

Maybe it work on your DE but mine doesn’t work.DEEPIN DE

0 Likes

#315

If pamac doesn’t work on manjaro deepin…MAYBE its good to have the DEEPIN STORE on manjaro deepin with the repositories of manjaro on it. Think of it, MANJARO DEEPIN with DEEPIN STORE!:grin::grin::grin:

0 Likes

#316

I have a problem with the new glibc:
Programs from the avr-toolchain, such as avr-gcc, as, etc. exit with an error:

as: loadlocale.c:130: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_TIME) / sizeof (_nl_value_type_LC_TIME[0]))' failed.

Although my locale is correct, the variable LC_TIME does not seem to be imported correctly by glibc for my specific setting.

The temporary solution is:

$ export LANG=C 

in the current terminal session before running an affected program. (This will then be set for the duration of the terminal session) , or

$ LANG=C program     (for example $ LANG=C avr-gcc)

on a per program instance.

In 2015 I had a similar problem with glibc which affected the variable LC_COLLATE, with the same temporary solution. Seemed that only Arch based distros were affected. This remained for many months until it finally disappeared (fixed).

If you have this similar problem, do not try to downgrade glibc.

0 Likes

#317

Have you been able to solve your problem? I have the exact same issue. Also Deepin

0 Likes

split this topic #318

A post was split to a new topic: Stuck at black screen

0 Likes

closed #319

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

0 Likes