[Stable Update] 2018-05-07 - Kernels, Mesa, Glibc, PHP, Nvidia, Plasma5, Firefox

update
stable
#188

gksu removed successfully. It tried to take a few useful packages with it (Isousb +dependencies) but I was able to reinstall them without incident.

Still having issues with xfce4-sensors-plugin. On login it renames one of my 4 cpu cores and will only display the original 3. Wierd. I’ve uninstalled/reinstalled, tried to make the config file read-only, but it looks like it’s broken upstream.

#189

Regarding the locale problem, it was due to a change in /etc/locale.gen permissions. sudo chmod +r /etc/locale.gen solved it. The same issue happened with /etc/pacman.conf as yaourt wouldn’t function without being able to read the file. This wasn’t related with the update. It happened because I did some pacnew merging as root. However, I did find this:

[2018-05-07 19:28] [ALPM] warning: directory permissions differ on /root/
drwxr-xr-x 25 root root 4096 29.04.2018 00:47 root/

/root is usually not readable, nevertheless executable by others, so:

sudo chmod 700 /root

#190

After the update, the system does not load! :frowning_face:

I have the manjaro for more than a year and the updates have been smooth, but recently they began to break down the system and I start to doubt the choice of the rolling release.:disappointed:

I really like Manjaro, and it would be great for developers to make updates as smooth as before!

#191

I started the update through terminal, then it froze during process.
Now I get this when type command.
I am unable to update.
I am a long term noob. Thanks

[paul@paul-pc ~]$ sudo pacman -Syyu
[sudo] password for paul:
:: Synchronizing package databases…
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to synchronize any databases
error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
if you’re sure a package manager is not already
running, you can remove /var/lib/pacman/db.lck
[paul@paul-pc ~]$

Am I updating and cleaning Manjaro correctly? [SOLVED]
#192

Simply follow the instructions …

sudo rm /var/lib/pacman/db.lck

Pacman uses this file to avoid multiple concurrent instances, it should be automatically removed when pacman update completes, but your update failed so it was not.

#193

Did you accidently overwrite any of these files with pacnew files after your update completed?

/etc/passwd
/etc/group
/etc/shadow
/etc/gshadow

From the second post in this thread … which I hope you read before updating …

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}

To troubleshoot and fix this you’ll have to boot into a live environment and chroot into your installed system.

sudo mount /dev/sdXX /mnt
sudo manjaro-chroot

Now do what the prompt says …

systemctl status polkit.service

… and post the results here.

Also run this command …

systemctl --state=failed

For each service that has failed to load provide the output of …

systemctl status [service-name]

Although if you have directly replaces the files listed above with their pacnew files, I’m not 100% sure how to fix that, other than restoring these files from a backup.

There is definitely more maintenance involved running a rolling release distro, and a willingness to learn and troubleshoot issues when they happen.

Understanding your system and how it hangs together is important. Any questions and the Manjaro community will always help, but you have to ask first.

Manjaro team can only do so much, if you use a rolling release long enough you will encounter issues that will require your attention.

2 Likes
split this topic #194

21 posts were split to a new topic: Manjaro for Linux newbies? Vol. N+1 :wink:

#195

That’s funny . I replaced my /etc/passwdfile with meld, just spaced it out! That first “failed” looks familiar.

Just booted my trusty Arch usb and replaced with a backup. :cold_sweat:

#196

@sueridgepipe

I don’t know why the update failed.

I did read the wiki at the start of this post about pacnew files
I did’nt merge them. All I did was sudo pacman -Syyu at the terminal.
I think there needs to be an easy to understand explaination on what do with pacnew files.

#197

There is… Atleast to me there are, maybe I’ve just been doing it far too long now so it seems easier/clearer than it is for most :thinking:

https://wiki.archlinux.org/index.php/Pacman/Pacnew_and_Pacsave

1 Like
#198

For solving “sambashare error Everyone SID with samba 4.8.1”

Just comment the: group=sambashare

Now you can share directories graphically without problems

PS: Do not forget to restart your smb service

2 Likes
#200

Instead of rm i.e. removing 1 file in /var/lib/pacman/ named db.lck , you chose to go back in time to a snap shot of your system? Then you replaced your whole user stuff ~/. That should work except for the stuff between the snapshot date and the failed update date. Pictures? bookmarks? docs…

Because you went back in time before the update. That timeshift time had no

/var/lib/pacman/db.lck file!
:rofl:

#204

Read my post again, simply explaining why that file is created and why it was most likely orphaned (ie your update failed for some reason).

That post was directed at @Kreon for their polkit boot issue, not your issue.

#211

Same here in the “classic menu” and the application dashboard. As I can see here, it looks as though you have reported it. Good catch on the categories having the same number of entries. :slight_smile:

#212

After a lot of manjaro repair. I can just say you have to verify:

  • You are not restart your distro when updating… ?
  • Verify the health of you HDD/SSD
#219

Oh Holy Zarquon, you mean all this anxiety & research & then pacnew files interrogation, comparison, merging, deleting i’ve been doing today & last night was a total waste of time? Gahhhhhhhhhhhhh.
.
.

…but only just now have i realised that was NOT a blanket statemment for ALL pacnew files. Gahhhhhhhhhhhh.
.
.
https://wiki.manjaro.org/index.php?title=Pacnew_and_Pacsave_Files

These files require manual intervention from the user and it is good practice to handle them right after every package upgrade or removal. If left unhandled, improper configurations can result in improper function of the software, or the software being unable to run altogether.

…but only just now have i realised that pertains to .pacsave files NOT pacnew files. Gahhhhhhhhhhhh.
.
.
I am now off looking for a nice brick wall into which i can run my stupid head a few times. What a galah i am.

Thank you for waking me up from my pacnew nightmare. That said, in many forum posts lately, i seem not to have been the only Manjaroo with pacnew files on their mind…

2 Likes
#220

yay. this did it for me. got my system back thnx.

#227

Ignoring stuff you don’t understand until it breaks is ridiculous … try researching, reading and learning.

Or if you are really clueless about something then create a thread and ask for help.

What next … recommend doing no maintenance until it breaks and just re-install it?

4 Likes
#228

Yes, either do that or install a distro that suits your skill level. Sometimes that is not possible if you want to have access to the latest software.

Without a guide you can be sure such people WILL break their setup if they try to blindly merge all pacnew.

No automatic handling of pacnew is actually the only reason i do not recommend manjaro. If you can handle it you can find it, if i need to recommend it then you are not ready for it.

1 Like
#229

Sorry, We have a discord vocal channel solving for you problems and fails in Manjaro but it’s a french channel.