[Stable Update] 2018-04-28 - Kernels, Cinnamon, Browsers, Mesa, KDE Apps, KDE Framework, Virtualbox

update
stable

#117

Updated XFCE with linux416, I can’t update packages from AUR via pamac anymore. It’s giving me ERROR: PKGBUILD contains CRLF characters and cannot be sourced.


#118

Any AUR package? That error is more likely coming from a faulty PKGBUILD file, thus from a specific package.
Which AUR packages are you trying to update?


#119

I have tried visual-studio-code-bin 1.22.2-1 and discord 0.0.5-2, both gave the same error.

Edit: It was due to autocrlf = true in .gitconfig. Apologies for using this topic.


#120

I just manually removed those libgwengui package related files as you said and it worked! Thanks bogdancovaciu


#121

Hmm, i managed to install both through Pamac without issue, so i don’t have much clue… I use the kernel 4.14 though.


#122

Hi @philm, I ran into a problem with this update that will unpair bluetooth devices on lockscreen, suspend and reboot. I wrote about it in detail in another post.

I have confirmed it on 2 laptop installs with both kernels 4.14 and 4.16. I’d love to help out and solve this annoying bug :slight_smile:


#123

I have an unusual (I’ve never seen before) error during update at the end where it runs ‘update-grub’:

/dev/mapper/control: open failed: No such device
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.146 (2017-12-18) and kernel driver (unknown version).
Command failed
/dev/mapper/control: open failed: No such device
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.146 (2017-12-18) and kernel driver (unknown version).
Command failed

I have a bad feeling about this like if I reboot I won’t be able to get back to Manjaro. I reinstalled device-mapper and no change. Reinstalled linux417, linux 416, and linux415. Also no change.


#125

Well I can reboot. So maybe:

  1. The error messages is itself a result of a coding error or some other error? :flushed:

  2. Something I don’t understand? :thinking:

OR:

  1. This is an error developers like to create to scare the bejesus out of users making us think destruction or our operating system is imminent and our days as Linux users are numbered only to tell us when we ask them “Oh that really isn’t anything to worry about, just ignore that”. :smiling_imp:

Edit: Anyway the error is reported, hope it is helpful or meaningful somehow to someone more knowledgeable than I. :grinning:

Edit: And now I’ve use my emoji quota for month of May…


#126

Hi,

Can be a poltergeist? :scream:


#127

The proprietary drivers doesn’t stay in a working condition

I install video-hybrid-intel-nvidia-bumblebee from system settings - Hardware Configuration
I reboot and the driver is there and working.

I shutdown and boot the driver is, well not really gone, but not working.
I have to uninstall the driver, shutdown, boot, install, shutdown and boot to make them work one more time.
Shutdown is needed it seems. A reboot seems not to install the driver in a working condition.
I have to do this on two laptops. The error is there with kernel 4.14 and 4.16.
I don’t know if the error was the before this update.

Anyone else have this problem?

Driver installed and working
inxi without primusrun:
Graphics: Card-1:
Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: N/A
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 18.0.1

inxi with primusrun:
Graphics:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: N/A
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 390.48

Driver not working
inxi without primusrun:
Graphics:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 390.48
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: N/A v: N/A

inxi with primusrun:
sh: line 1: 2582 Segmentation fault (core dumped) /sbin/glxinfo 2> /dev/null
Graphics:
Card-1: Intel HD Graphics 620 driver: i915 v: kernel
Card-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 390.48
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz
Message: No advanced graphics data found on this system.

From konsole when starting steam:
optirun /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=/app/bin/steam-wrapper --file-forwarding com.valvesoftware.Steam @@u %U @@
Couldn’t find dpkg, please update steamdeps for your distribution.
Running Steam on org.freedesktop.platform 1.6 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1522709999)
Installing breakpad exception handler for appid(steam)/version(1522709999)
Installing breakpad exception handler for appid(steam)/version(1522709999)
OpenGL GLX extension not supported by displayMain.cpp (323) : Assertion Failed: Fatal Error: OpenGL GLX extension not supported by display
Assert( Assertion Failed: Fatal Error: OpenGL GLX extension not supported by display ):Main.cpp:323

Installing breakpad exception handler for appid(steam)/version(1522709999)
assert_20180506103129_5.dmp[130]: Uploading dump (out-of-process)
/tmp/dumps/assert_20180506103129_5.dmp
assert_20180506103129_5.dmp[130]: Finished uploading minidump (out-of-process): success = no
assert_20180506103129_5.dmp[130]: error: Couldn’t connect to server
assert_20180506103129_5.dmp[130]: file ‘’/tmp/dumps/assert_20180506103129_5.dmp’’, upload no: ‘‘Couldn’t connect to server’’


NVIDIA-bumblebee stops working, needs to be reinstalled
#128

I think I was able to fix the slick-greeter background issues by patching both lightdm-settings and lightdm-slick-greeter packages. The updated versions will arrive with next stable update.

For now, try adding this line in your /etc/lightdm/slick-greeter.conf:

draw-user-backgrounds=false

Does that help to display your configured background?


#129

JFYI: KDE:
Update went fine with kernel 4.9.

kernel 4.14.36-1 is now working on my T60 Intel T5500, (which did previously not ).
There was only a long boot delay at black boot screen on the first reboot after kernel upgrade from 4.9 to 4.14.
Thanks.

Machine:   Type: Laptop System: LENOVO product: 1952VA4 v: ThinkPad T60 serial: N/A 
           Mobo: LENOVO model: 1952VA4 serial: N/A BIOS: LENOVO v: 79ETE6WW (2.26 ) date: 04/01/2010 
Battery:   ID-1: BAT0 charge: 36.5 Wh condition: 36.5/47.5 Wh (77%) model: SANYO 93P5030 status: Unknown 
CPU:       Topology: Dual Core model: Intel Core2 T5500 bits: 64 type: MCP arch: Conroe rev: 6 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 6652 
           Speed: 1045 MHz min/max: 1000/1667 MHz Core speeds (MHz): 1: 1057 2: 1015 
Graphics:  Card-1: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics driver: i915 v: kernel 
           bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.6 driver: intel unloaded: fbdev,modesetting,vesa tty: N/A 
           OpenGL: renderer: Mesa DRI Intel 945GM v: 1.4 Mesa 18.0.1 direct render: Yes 
. . . 
Info:      Processes: 150 Uptime: 1m Memory: 1.94 GiB used: 1006.9 MiB (50.6%) Init: systemd Compilers: 
           gcc: 7.3.1 Shell: bash v: 4.4.19 inxi: 3.0.07 
[yankee@T60small64bit ~]$ uname -a
Linux T60small64bit 4.14.36-1-MANJARO #1 SMP PREEMPT Tue Apr 24 19:16:26 UTC 2018 x86_64 GNU/Linux




#130

Fixed with today’s stable update. Thanks.


#131

Oh nooooooooooo, it happened again overnight - identical symptoms. 100% certain that Tower was Suspended late last night, but this morning it was already running again… Not Good [apart from just being plain wrong in principle for Suspend to fail, it’s dangerous… i cover Tower each night with a dust cloth, thus it cannot properly draw cooling air if it runs like that].

Today i will be applying the 20180507 Stable Update to it, so i really hope that solves this.


#132

Which kernel are you using? Which hardware?
In any case. Try a different kernel if possible.


#133

Currently:

$ inxi -Fxz
System:    Host: GA-Z97-HD3-Tower Kernel: 4.16.4-1-MANJARO x86_64 bits: 64 compiler: gcc v: 7.3.1 
           Desktop: KDE Plasma 5.12.4 tk: Qt 5.10.1 Distro: Manjaro Linux 17.1.9 Hakoila 
Machine:   Type: Desktop Mobo: Gigabyte model: Z97-HD3 v: x.x serial: N/A UEFI: American Megatrends v: F7 
           date: 12/08/2014 
CPU:       Topology: Quad Core model: Intel Core i7-4790 bits: 64 type: MT MCP arch: Haswell rev: 3 
           L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 57606 
           Speed: 3514 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3514 2: 3223 3: 3388 4: 3319 5: 3273 
           6: 3285 7: 3169 8: 3683 
Graphics:  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics driver: i915 v: kernel 
           bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.6 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Haswell Desktop v: 4.5 Mesa 18.0.1 direct render: Yes 
Audio:     Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:03.0 
           Card-2: Intel 9 Series Family HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.16.4-1-MANJARO 
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 v: 8.045.08-NAPI 
           port: e000 bus ID: 02:00.0 
           IF: enp2s0 state: up speed: 100 Mbps duplex: half mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    HDD Total Size: 2.05 TiB used: 1.10 TiB (54.0%) 
           ID-1: /dev/sda model: Samsung_SSD_850 size: 232.89 GiB 
           ID-2: /dev/sdb model: ST2000DM001-1ER1 size: 1.82 TiB 
Partition: ID-1: / size: 58.81 GiB used: 23.13 GiB (39.3%) fs: ext4 dev: /dev/sda2 
           ID-2: /home size: 158.46 GiB used: 31.17 GiB (19.7%) fs: ext4 dev: /dev/dm-1 
           ID-3: swap-1 size: 2.01 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C 
           Fan Speeds (RPM): cpu: 670 fan-1: 1027 fan-3: 0 fan-4: 0 fan-5: 0 
Info:      Processes: 444 Uptime: 1d 11h 45m Memory: 30.85 GiB used: 11.61 GiB (37.6%) Init: systemd Compilers: 
           gcc: 7.3.1 Shell: bash v: 4.4.19 inxi: 3.0.07 

…but the 20180507 Stable Update is in the late download phase right now, so pretty soon after rebooting it will be Plasma 5.12.5 & Kernel 4.16.7, etc.

…Aha, it’s just finished, will be rebooting after posting this, so once i go to bed later tonight my Tower will be suspended in this new state. I shall be interested to see Tower’s power status tomorrow morning… hopefully it will still be asleep.


#134

Just don’t wrap it up … :wink:
If you still have issues with suspend try the latest LTS kernel linux414 instead.


#135

My issue seems to be gone with 05/07/2018 update. The issue was this error when update-grub ran:

Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.146 (2017-12-18) and kernel driver (unknown version).
Command failed
/dev/mapper/control: open failed: No such device

in spite of the error message I noticed no loss of system functionality. And now the error message it self is gone so many thanks to Manjaro Team.


#136

Tower was still sound asleep this morning when i dragged it out of bed & threw it into a cold shower to wake up.

Obviously that’s nice, but is far from conclusive, given that there were only two instances of The Poltergeist when Tower still wore Stable 20180428 Clothes. I want to see many more consecutive days in its new Stable 20180507 Clothes sans poltergeist, before i’ll feel comfortable that the bug has gone.


#137

Things go bump in the night if I’m to understand correctly?.. Yikes! :laughing: