[Stable Update] 2018-04-14 - Kernels, Gnome v3.28.1, Libreoffice, Browsers, Mesa, Deepin, Mate

update
stable

#1

Hi community,

welcome to another stable update of Manjaro. It took us a little longer than usual, to get this update-pack fully tested.

Our main focus was on GNOME 3.28, which is the result of 6 months’ hard work by the GNOME community. It contains major new features, as well as many smaller improvements and bug fixes.

One major new feature for this release is automatic downloading of operating systems in Boxes, which takes the work out of creating and running virtual machines – just pick the operating system that you want to create a virtual machine of, and Boxes will now download and install it for you.

Other highlights include improvements to the Calendar and Contacts applications, the ability to star files and folders in the Files application, and improved support for Thunderbolt 3 and Bluetooth LE devices. GNOME’s default UI font has also been overhauled to be more attractive and easy to read, and the on-screen keyboard has been rewritten to be more reliable and has layouts for a number of different locales.

There are many other improvements in GNOME 3.28, which can be read about in the release notes.

The Deepin Desktop also received a lot of package updates including some important bugfixes, namely some rather serious issues with cpu load of deepin-dock and deepin-daemon were fixed.
Additionally we updated Pamac, Mesa, Kernels, Browsers, LibreOffice, GStreamer, PHP, Calamares, Inxi, Haskell and Python to mention a few … Also linux417 got added for our brave beta-testers to play around.

If you wanna test the latest features of the upcoming Manjaro release Illyria, you may checkout our Alpha releases:

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.105 [EOL]
  • linux41 4.1.51
  • linux44 4.4.128
  • linux49 4.9.94
  • linux414 4.14.34
  • linux415 4.15.17
  • linux416 4.16.2
  • linux417 4.17-rc0
  • linux-rt 4.14.29_rt25

Package Updates (Sat Apr 14 07:30:05 CEST 2018)

  • stable community x86_64: 1361 new and 1310 removed package(s)
  • stable core x86_64: 64 new and 62 removed package(s)
  • stable extra x86_64: 931 new and 1023 removed package(s)
  • stable multilib x86_64: 43 new and 46 removed package(s)

A detailed list of all package changes may be found here.


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Manjaro-Cinnamon and -i3 17.1.8
[Testing Update] 2018-04-21 - Kernels, KDE Framework, Mesa, Virtualbox, Browsers, Deepin
#2

Known issues and solutions

This is a wiki post; please edit as necessary.


Users of Gnome may consider to update from within a TTY terminal

Due to several reports not being able to login to the current Gnome session after the user may got logged out, we recomment to use pacman and a TTY terminal for this update. Following steps are therefore needed:

  • logout of your current Gnome session
  • in your display manager session press CTRL+ALT+F3 to open TTY3
  • login with your user or as root and initiate the update via sudo pacman -Syyu
  • after the update completed you may check the pacman.log for issues. Do this with less /var/log/pacman.log. With page-up and page-down you can navigate thru the file. With typing :q you may end less.
  • fix your system as needed and reboot with sudo reboot

Nautilus - Middle click on any location in other-locations:/// closes tab


Noto Sans Mono has incorrect spacing or has vanished (under KDE)

This has been reported upstream but hasn’t yet been fixed. For the meantime please install noto-fonts-compat: sudo pacman -S noto-fonts-compat


[linux417][i915] Could not determine valid watermarks for inherited state


[linux414 and newer] ACPI Error: Needed type [Reference], found [Integer]

During boot you have something like this:

ACPI Error: Needed type [Reference], found [Integer] 00000000cfdd7926 (20170831/exresop-103)
ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [Store] (20170831/dswexec-461)
ACPI Error: Method parse/execution failed \_PR.CPU0._PDC, AE_AML_OPERAND_TYPE (20170831/psparse-550)

Bugreport 198781 [STATUS: RESOLVED WILL_NOT_FIX]

Workaround

Edit /etc/default/grub and add in GRUB_CMDLINE_LINUX_DEFAULT line AFTER quiet word these: vga=current loglevel=3 rd.systemd.show_status=auto rd.udev.log_priority=3
Next update grub : sudo update-grub.
Last thing is creating SYSCTL rule:

sudo bash -c "echo ‘kernel.printk = 3 3 3 3’ > /etc/sysctl.d/20-quiet-printk.conf"

Reboot.



#3

Thank you for the update!

First impressions:

  1. Logging in using Gnome/Wayland sessions was resulting in core dump of gnome-shell
  2. Opening Gnome/XOrg session wasn’t possible until 2nd reboot
  3. Almost all gnome shell extensions are incompatible, including user themes - this may be related to local copies placed in ~/.local/share/gnome-shell/extensions/ (I’ll try to remove them and check again)
kernel: gnome-shell[1702]: segfault at 20 ip 00007f2dfaf70df5 sp 00007fff48fe0cb0 error 4 in libmutter-2.so.0.0.0[7f2dfae6c000+181000]
kwi 14 08:36:53 mobilestation systemd-coredump[1709]: Process 1702 (gnome-shell) of user 1000 dumped core.
                                                      
                                                      Stack trace of thread 1702:
                                                      #0  0x00007f2dfaf70df5 meta_gpu_kms_new (libmutter-2.so.0)
                                                      #1  0x00007f2dfaf72be8 n/a (libmutter-2.so.0)
                                                      #2  0x00007f2dfcf90121 g_initable_new_valist (libgio-2.0.so.0)
                                                      #3  0x00007f2dfcf901da g_initable_new (libgio-2.0.so.0)
                                                      #4  0x00007f2dfaec4216 n/a (libmutter-2.so.0)
                                                      #5  0x00007f2dfaec4d58 meta_init_backend (libmutter-2.so.0)
                                                      #6  0x00007f2dfaf0dea8 meta_init (libmutter-2.so.0)
                                                      #7  0x000056113886dcda n/a (gnome-shell)
                                                      #8  0x00007f2dfd736f4a __libc_start_main (libc.so.6)
                                                      #9  0x000056113886e14a n/a (gnome-shell)
                                                      
                                                      Stack trace of thread 1704:
                                                      #0  0x00007f2dfd80197b __poll (libc.so.6)
                                                      #1  0x00007f2dfca11523 n/a (libglib-2.0.so.0)
                                                      #2  0x00007f2dfca1163e g_main_context_iteration (libglib-2.0.so.0)
                                                      #3  0x00007f2dfca11692 n/a (libglib-2.0.so.0)
                                                      #4  0x00007f2dfca39a2a n/a (libglib-2.0.so.0)
                                                      #5  0x00007f2dfdad408c start_thread (libpthread.so.0)
                                                      #6  0x00007f2dfd80be7f __clone (libc.so.6)
                                                      
                                                      Stack trace of thread 1705:
                                                      #0  0x00007f2dfd80197b __poll (libc.so.6)
                                                      #1  0x00007f2dfca11523 n/a (libglib-2.0.so.0)
                                                      #2  0x00007f2dfca118e2 g_main_loop_run (libglib-2.0.so.0)
                                                      #3  0x00007f2dfd000348 n/a (libgio-2.0.so.0)
                                                      #4  0x00007f2dfca39a2a n/a (libglib-2.0.so.0)
                                                      #5  0x00007f2dfdad408c start_thread (libpthread.so.0)
                                                      #6  0x00007f2dfd80be7f __clone (libc.so.6)
                                                      
                                                      Stack trace of thread 1706:
                                                      #0  0x00007f2dfd806879 syscall (libc.so.6)
                                                      #1  0x00007f2dfca5852d g_cond_wait_until (libglib-2.0.so.0)
                                                      #2  0x00007f2dfc9e3903 n/a (libglib-2.0.so.0)
                                                      #3  0x00007f2dfca3a436 n/a (libglib-2.0.so.0)
                                                      #4  0x00007f2dfca39a2a n/a (libglib-2.0.so.0)
                                                      #5  0x00007f2dfdad408c start_thread (libpthread.so.0)
                                                      #6  0x00007f2dfd80be7f __clone (libc.so.6)
                                                      
                                                      Stack trace of thread 1707:
                                                      #0  0x00007f2dfd80197b __poll (libc.so.6)
                                                      #1  0x00007f2dfca11523 n/a (libglib-2.0.so.0)
                                                      #2  0x00007f2dfca1163e g_main_context_iteration (libglib-2.0.so.0)
                                                      #3  0x00007f2de4936f4e n/a (libdconfsettings.so)
                                                      #4  0x00007f2dfca39a2a n/a (libglib-2.0.so.0)
                                                      #5  0x00007f2dfdad408c start_thread (libpthread.so.0)
                                                      #6  0x00007f2dfd80be7f __clone (libc.so.6)

Hope this applies only to me :slight_smile:


#4

From some reasons next boot into Gnome/Wayland was finally successful. Maybe something was cleaned during Gnome/XOrg session.

In case of problems with logging into Gnome/Wayland, please try to run Gnome/XOrg, then reboot and try again with Gnome/Wayland. You can also try to remove incompatible extensions from ~/.local/share/gnome-shell/extensions


#5

Welcome to Gnome updates :wink:


#6

XFCE doesn’t start after updates:
(2/5) Probing GTK3 input method modules…
/usr/bin/gtk-query-immodules-3.0: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: FcWeightFromOpenTypeDouble
(1/2) Probing GTK2 input method modules…
/usr/bin/gtk-query-immodules-2.0: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: FcWeightFromOpenTypeDouble

Some ideas to fix that?


#7

I was expecting this :slight_smile: I like Gnome for look&feel but updates, incompatibilities, and broken (by design?) extensions are quite weak. I still do not understand how stupid extension may kill whole shell…

As a regular user I’d be f… very angry because of missing all my tools in the top bar.


#8

Have you try to enable the disabling checking compatibility for extensions in dconf? Theorically this feature are gone in 3.26 but re enable in 3.28… But since api of gnome not as more changed most of extensions or theme work well…


#9

By any chance you have some fontconfig issue or use lightdm-gtk-greeter?


#10

Sometimes turning OFF and ON the extensions in the main Extensions option in Tweak Tool, solves some inconsistencies regarding them.


#11

Stop using pacman-prepacked extensions and using them right from the website/gnome-software. This will work much better and is one reason why I always remove those extensions from Pacman right after a fresh install.

Sadly with mesa 18, the night mode of gnome shell is flickery. Other than that it’s working great!


#12

Thank you. My tools are back now.

Most of my extensions was taken from website. I remember that I removed gnome-shell-extensions package days ago. That’s why my user-theme ext wasn’t compatible.


#13

I downgraded pango but now is antoher error:
/usr/bin/gtk-query-immodules-3.0: symbol lookup error: /usr/lib/libcairo.so.2: undefined symbol: FT_Done_MM_Var


#14

@Ste74: I just tried to do an updated v17.1.8 ISO with the new Gnome v3.28.1 release. Neither Gno-Menu nor Arc-Menu seem to work:

28-extension-error

I only installed the relevant manjaro-gnome settings packages. What do I miss? Do we need to recompile the extensions agains the new Gnome release?


#15

Yesterday have reupload new settings for gnome… Check it otherwise this afternoon can look into it Im at my daily job now … Yesterday not checked my last changes because i need to sleep :sweat_smile:

Gnomenu in last changes is disabled and enabled arc menu, also added the key to disable the compatibility check and override arc menu for our need…


#16

Great Update! :clap:
Thank you very much, Team! :muscle::ok_hand::+1:
Additional thanks for updating adapta-maia-theme! It fixes some issues on UI elements, that’s great!
P.S. Mate, kernel 4.14, radeon


#17

Well, seems both don’t work at all. So we have to see why …

Apr 14 09:48:42 joe-pc systemd-coredump[2910]: Process 2891 (gnome-shell-ext) of user 1000 dumped core.
                                               
                                               Stack trace of thread 2891:
                                               #0  0x00007fcd084a2860 raise (libc.so.6)
                                               #1  0x00007fcd084a3ec9 abort (libc.so.6)
                                               #2  0x00007fcd0849b0bc __assert_fail_base (libc.so.6)
                                               #3  0x00007fcd0849b133 __assert_fail (libc.so.6)
                                               #4  0x00007fcd0423a93f n/a (libcairo.so.2)
                                               #5  0x00007fcd04273608 n/a (libcairo.so.2)
                                               #6  0x00007fcd042316a9 cairo_debug_reset_static_data (libcairo.so.2)
                                               #7  0x00007fcd084a57b2 __cxa_finalize (libc.so.6)
                                               #8  0x00007fcd078b2e54 n/a (libgjs.so.0)
                                               #9  0x00007fcd08a52af3 _dl_fini (ld-linux-x86-64.so.2)
                                               #10 0x00007fcd084a5448 __run_exit_handlers (libc.so.6)
                                               #11 0x00007fcd084a549a exit (libc.so.6)
                                               #12 0x00007fcd0848ef51 __libc_start_main (libc.so.6)
                                               #13 0x0000555dc8cdec3a n/a (gnome-shell-extension-prefs)
                                               
                                               Stack trace of thread 2906:
                                               #0  0x00007fcd0855997b __poll (libc.so.6)
                                               #1  0x00007fcd07baf523 n/a (libglib-2.0.so.0)
                                               #2  0x00007fcd07baf8e2 g_main_loop_run (libglib-2.0.so.0)
                                               #3  0x00007fcd0819e348 n/a (libgio-2.0.so.0)
                                               #4  0x00007fcd07bd7a2a n/a (libglib-2.0.so.0)
                                               #5  0x00007fcd0882c08c start_thread (libpthread.so.0)
                                               #6  0x00007fcd08563e7f __clone (libc.so.6)
                                               
                                               Stack trace of thread 2905:
                                               #0  0x00007fcd0855997b __poll (libc.so.6)
                                               #1  0x00007fcd07baf523 n/a (libglib-2.0.so.0)
                                               #2  0x00007fcd07baf63e g_main_context_iteration (libglib-2.0.so.0)
                                               #3  0x00007fcd07baf692 n/a (libglib-2.0.so.0)
                                               #4  0x00007fcd07bd7a2a n/a (libglib-2.0.so.0)
                                               #5  0x00007fcd0882c08c start_thread (libpthread.so.0)
                                               #6  0x00007fcd08563e7f __clone (libc.so.6)
                                               
                                               Stack trace of thread 2907:
                                               #0  0x00007fcd0855997b __poll (libc.so.6)
                                               #1  0x00007fcd07baf523 n/a (libglib-2.0.so.0)
                                               #2  0x00007fcd07baf63e g_main_context_iteration (libglib-2.0.so.0)
                                               #3  0x00007fccf25eef4e n/a (libdconfsettings.so)
                                               #4  0x00007fcd07bd7a2a n/a (libglib-2.0.so.0)
                                               #5  0x00007fcd0882c08c start_thread (libpthread.so.0)
                                               #6  0x00007fcd08563e7f __clone (libc.so.6)
                                               
                                               Stack trace of thread 2908:
                                               #0  0x00007fcd0855e879 syscall (libc.so.6)
                                               #1  0x00007fcd07bf652d g_cond_wait_until (libglib-2.0.so.0)
                                               #2  0x00007fcd07b81903 n/a (libglib-2.0.so.0)
                                               #3  0x00007fcd07bd8436 n/a (libglib-2.0.so.0)
                                               #4  0x00007fcd07bd7a2a n/a (libglib-2.0.so.0)
                                               #5  0x00007fcd0882c08c start_thread (libpthread.so.0)
                                               #6  0x00007fcd08563e7f __clone (libc.so.6)

#18

Maybe typo error in gsettings keys but i can check only this afternoon :pensive:


#19

User themes should be compatible. Its working for me on all systems. :thinking:


#20

I had user-themes extension installed (probably) from gnome extensions website. The extension was located in ~/.local/… path, so it wasn’t upgraded with the system update, and that’s why it wasn’t compatible.

I’ve removed local extensions and installed gnome-shell-extensions package again. Now it works fine.