[Stable Update] 2018-03-14 - Kernels, Browsers, KDE, Vulkan, Python, Haskell

update
stable

#42

I got the following issue:

warning: cannot resolve "openbox-scripts", a dependency of "manjaro-openbox-settings"
:: The following package cannot be upgraded due to unresolvable dependencies:
      manjaro-openbox-settings
:: Do you want to skip the above package for this upgrade? [y/N]

My main desktop env. is openbox.
I’m using the stable branch.

I hope this can be solved, at least in the next update?


Manjaro Openbox Edition 17.1.8
#43

I’ve been experiencing this issue with both kernels 4.14 and 4.15 intermittently, but I discovered today that if switch to virtual console Ctrl+Alt+F2 then back to GUI Ctrl+Alt+F1, it seems to correct the issue, at least temporarily. I’ve been avoiding downgrading the affected package.

Not a huge deal, but glad that I’ve found a way to work around the issue until the upstream libinput package makes it to Stable.


#44

After researching the warnings and error mentioned earlier I decided to just do a restart. After startup I got a notice that ‘manjaro-browser-settings-20180316-2’ install was needed, which I did and FF worked fine. Everything is really fine now and I have more confidence in my Chromebook :joy:

For chromebook users my system runs: Xfce, Kernel49, Acer C720, ‘Peppy’ UEFI: coreboot v: MrChromebox date: 07/14/2017, Haswell CPU, integrated GPU, Network card: Qualcomm Atheros AR9462


#45

Updates on 11 Machines and 1 VB without Problems.

DK3


#47

Previously, ruby provided rubygems. Now, rubygems is a separate package. rubygems depends on ruby and ruby depends on rubygems. Therefore, no matter which package is installed first this warning will show. It can be ignored (as can all warnings of this type).


#48

No issue here, thank you!

P.S. an o.t. question: when glibc 2.27 will be released for arch linux? I have some problems running Citra emulator, that requires glibc 2.27.


#49

A key phrase for starting a new thread. :wink:


#53

Update of librsvg from 2:2.42.2-1 to 2:2.42.3-1 broke my icons, and made almost everything switch back to gnome default theme (but I have xfce, duh!)


#54

Happen to me, in branch Testing: librsvg2:2.42-3 needs cairo-1.15 from extra repository. See if you have installed cairo-infinality-1.14 from aur or other


#55

Wow, thank you.
For some-reason-I-cant-remember I had installed 1.15.2-git.
I installed normal one, and everything was good.


#56

Ehrm… I’m not sure why this has been moved here?
I had this problem while updating yesterday, and I just reported today because I needed time to bisect.


#57

If you updated yesterday, you installed the update from 2018-03-14, which is this topic here. The other one is for the update released today and was therefore the wrong one.


#58

Yes. And I had indeed first posted here.
Fixed.


#59

There is no update till now, my mirrorlist is uptodate and the mirrors that I chose, are uptodate (Germany). sudo pacman -Syu says “Es gibt nichts zu tun.” Sry for my bad english :wink:
"
regards user51


#60

This topic is for an update from 2 months ago. The last update for the Stable Branch was on 7th May:


#61

OK sorry for that, I should be better looking to the date :wink:


#62