[Stable Update] 2018-03-07 - Kernels, LibreOffice, XFCE-Compiz, Haskell, Python

update
stable

#1

Hi community,

welcome to another stable update of Manjaro. We added the latest LibreOffice, worked on better Compiz support in XFCE, renewed most of our kernels and added regular upstream updates.

Here is the list of changes in more details:

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.55
  • linux318 3.18.98 [EOL]
  • linux41 4.1.49
  • linux44 4.4.120
  • linux49 4.9.86
  • linux414 4.14.24
  • linux415 4.15.7
  • linux416 4.16-rc4
  • linux-RT-LTS 4.14.20_rt17
  • linux-RT 4.14.20_rt17

Package Updates (Mon Mar 5 19:08:50 CET 2018)

  • stable community x86_64: 94 new and 90 removed package(s)
  • stable core x86_64: 16 new and 16 removed package(s)
  • stable extra x86_64: 192 new and 191 removed package(s)
  • stable multilib x86_64: 2 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-05           2018-03-07
-------------------------------------------------------------------------------
                  awesome-wallpapers           20180301-1           20180305-1
                      compiz-manjaro     0.9.13.1.r4138-4     0.9.13.1.r4138-5
                          lemonpanel  0.27.r188.b89a3c3-1  0.28.r190.271fc1b-1
                       micro-manjaro              1.4.0-7              1.4.0-8
                             spacefm              1.0.6-1              1.0.6-2
                           sterminal                0.5-1                0.7-1
                           musescore                    -              2.1.0-1
                  xfce4-panel-compiz                    -             4.12.2-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-05           2018-03-07
-------------------------------------------------------------------------------
                                anki        2.1.0beta36-1        2.1.0beta37-1
                               bazel             0.10.1-1             0.11.0-1
                                cuda           9.1.85.1-1           9.1.85.2-1
                             dovecot              2.3.0-2            2.3.0.1-1
                              elixir              1.6.1-1              1.6.2-1
                             fractal             0.1.10-1             0.1.16-1
                           git-annex        6.20180227-13        6.20180227-14
                              gitlab             10.5.0-1             10.5.2-1
                       gitlab-gitaly             0.83.0-1             0.88.0-1
                    gitlab-workhorse              3.6.0-1              3.8.0-1
                haskell-authenticate             1.3.4-56             1.3.4-57
                         haskell-aws              0.19-23              0.19-24
                       haskell-brick             0.34.1-5             0.34.1-6
                  haskell-config-ini           0.2.2.0-15           0.2.2.0-16
                  haskell-connection             0.2.8-60             0.2.8-61
                         haskell-dav             1.3.2-21             1.3.2-22
                      haskell-hakyll          4.11.0.0-23          4.11.0.0-26
                 haskell-hledger-lib               1.5-19               1.5-20
                       haskell-hpack            0.27.0-16            0.27.0-17
                       haskell-hslua              0.9.5-8            0.9.5.1-2
           haskell-hslua-module-text           0.1.2.1-12           0.1.2.1-14
             haskell-http-client-tls           0.3.5.3-21           0.3.5.3-22
                haskell-http-conduit             2.2.4-54             2.2.4-55
                  haskell-megaparsec              6.4.0-5              6.4.1-1
                  haskell-pipes-http            1.0.5-107            1.0.5-108
                       haskell-retry            0.7.6.1-2            0.7.6.1-3
      haskell-tasty-expected-failure          0.11.0.4-13             0.11.1-1
              haskell-tasty-hedgehog            0.1.0.2-9           0.1.0.2-10
                         haskell-tls              1.4.1-5              1.4.1-6
         haskell-tls-session-manager           0.0.0.2-29           0.0.0.2-30
                    haskell-warp-tls           3.2.4.2-15           3.2.4.2-16
             haskell-x509-validation             1.6.9-30             1.6.10-1
                  haskell-yesod-auth            1.4.21-95            1.4.21-96
                             hledger               1.5-29               1.5-30
                         hledger-api               1.5-75               1.5-76
                          hledger-ui               1.5-45               1.5-46
                         hledger-web               1.5-84               1.5-86
                              hoogle            5.0.16-23            5.0.16-24
                      hopenpgp-tools            0.19.5-91            0.19.5-92
                               idris             1.2.0-38             1.2.0-39
                              kcptun           20171201-1           20180305-1
                          latte-dock              0.7.3-1              0.7.4-1
                             libgiac           1.4.9.53-1           1.4.9.55-1
                            openfire              4.2.2-1              4.2.2-2
                     owncloud-client              2.4.0-1              2.4.1-1
                            pacutils              0.6.1-1              0.6.2-1
                              pandoc              2.1.2-1              2.1.2-4
                     pandoc-citeproc          0.13.0.1-22          0.13.0.1-25
                     pandoc-crossref           0.3.0.1-57           0.3.0.1-60
                            parallel           20180122-1           20180222-1
                       phpvirtualbox           5.2_0rc1-4              5.2_0-1
                          pigeonhole            0.5.0.1-1            0.5.0.1-2
                           postgrest           0.4.4.0-66           0.4.4.0-67
                   python-cloudflare              2.1.0-1              2.1.0-2
                      python-msgpack              0.5.4-1              0.5.6-1
                       python-neovim              0.2.1-1              0.2.3-1
                  python-progressbar             3.35.2-1             3.36.0-1
                       python-sphinx              1.7.0-1              1.7.1-1
                     python-tenacity              4.8.0-1              4.9.0-1
             python-virtualenv-clone              0.2.6-3              0.3.0-1
                  python2-cloudflare              2.1.0-1              2.1.0-2
                     python2-msgpack              0.5.4-1              0.5.6-1
                      python2-neovim              0.2.1-1              0.2.3-1
                 python2-progressbar             3.35.2-1             3.36.0-1
                      python2-sphinx              1.7.0-1              1.7.1-1
                    python2-tenacity              4.8.0-1              4.9.0-1
            python2-virtualenv-clone              0.2.6-3              0.3.0-1
                               qtile             0.11.1-1             0.11.1-2
                                rust           1:1.24.0-1           1:1.24.1-1
                           rust-docs           1:1.24.0-1           1:1.24.1-1
                                salt           2017.7.2-1           2017.7.4-1
                           shorewall           5.1.12.1-1           5.1.12.3-1
                      shorewall-core           5.1.12.1-1           5.1.12.3-1
                          shorewall6           5.1.12.1-1           5.1.12.3-1
                               stack             1.6.5-14             1.6.5-16
                             t1utils               1.39-1               1.41-1
                           texstudio             2.12.6-5             2.12.8-1
                           uglify-js             3.3.12-1             3.3.13-1
                               v2ray               3.11-1             3.11.3-1
                              vnstat               1.17-1               1.18-1
                      wireguard-dkms       0.0.20180218-1       0.0.20180304-1
                     wireguard-tools       0.0.20180218-1       0.0.20180304-1
                                xcas           1.4.9.53-1           1.4.9.55-1
                                yarn              1.3.2-1              1.5.1-1
                               dmtcp                    -              2.5.2-1
                    python-jsonlines                    -              1.2.0-1
                   python2-jsonlines                    -              1.2.0-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-05           2018-03-07
-------------------------------------------------------------------------------
                                grub             2.02.0-4             2.02.0-6
                          grub-quiet             2.02.0-4             2.02.0-6
                            linux316            3.16.54-1            3.16.55-1
                    linux316-headers            3.16.54-1            3.16.55-1
                            linux318            3.18.97-1            3.18.98-1
                    linux318-headers            3.18.97-1            3.18.98-1
                            linux414            4.14.23-1            4.14.24-1
                    linux414-headers            4.14.23-1            4.14.24-1
                      linux416 4.16.r180228.gf3afe53-1 4.16.r180305.g661e50b-1
              linux416-headers 4.16.r180228.gf3afe53-1 4.16.r180305.g661e50b-1
                             linux44            4.4.119-1            4.4.120-1
                     linux44-headers            4.4.119-1            4.4.120-1
                             linux49             4.9.85-1             4.9.86-1
                     linux49-headers             4.9.85-1             4.9.86-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-05           2018-03-07
-------------------------------------------------------------------------------
                              man-db              2.8.1-1              2.8.2-1
                             openvpn              2.4.4-1              2.4.5-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-05           2018-03-07
-------------------------------------------------------------------------------
              grub-theme-live-common             17.1.1-1             17.1.1-2
          grub-theme-live-common-dev             17.1.1-3             17.1.1-6
         grub-theme-live-manjaro-dev             17.1.1-4             17.1.1-6
              grub-theme-manjaro-dev             17.1.1-5             17.1.1-6
                  linux316-acpi_call             1.1.0-39             1.1.0-40
                   linux316-bbswitch               0.8-38               0.8-39
                linux316-broadcom-wl      6.30.223.271-18      6.30.223.271-19
                   linux316-catalyst     1:15.201.1151-27     1:15.201.1151-28
                linux316-ndiswrapper              1.61-18              1.61-19
                     linux316-nvidia           1:390.25-2           1:390.25-3
               linux316-nvidia-304xx          1:304.137-9         1:304.137-10
               linux316-nvidia-340xx            340.106-4            340.106-5
                   linux316-nvidiabl              0.88-28              0.88-29
      linux316-open-vm-tools-modules      2:2013.09.16-38      2:2013.09.16-39
                      linux316-r8168           8.045.08-4           8.045.08-5
                  linux316-rt3562sta        2.4.1.1_r4-18        2.4.1.1_r4-19
                        linux316-spl              0.7.5-5              0.7.5-6
                   linux316-tp_smapi              0.41-38              0.41-39
                linux316-vhba-module          20161009-18          20161009-19
   linux316-virtualbox-guest-modules              5.2.8-1              5.2.8-2
    linux316-virtualbox-host-modules              5.2.8-1              5.2.8-2
                        linux316-zfs              0.7.5-5              0.7.5-6
                  linux414-acpi_call             1.1.0-21             1.1.0-22
                   linux414-bbswitch               0.8-21               0.8-22
                linux414-broadcom-wl      6.30.223.271-21      6.30.223.271-22
                   linux414-catalyst     1:15.201.1151-21     1:15.201.1151-22
                linux414-ndiswrapper              1.61-21              1.61-22
                     linux414-nvidia           1:390.25-7           1:390.25-8
               linux414-nvidia-304xx         1:304.137-21         1:304.137-22
               linux414-nvidia-340xx            340.106-9           340.106-10
                   linux414-nvidiabl              0.88-21              0.88-22
                      linux414-r8168           8.045.08-9          8.045.08-10
                  linux414-rt3562sta        2.4.1.1_r4-21        2.4.1.1_r4-22
                        linux414-spl             0.7.5-11             0.7.5-12
                   linux414-tp_smapi              0.41-21              0.41-22
                linux414-vhba-module          20161009-21          20161009-22
   linux414-virtualbox-guest-modules              5.2.8-1              5.2.8-2
    linux414-virtualbox-host-modules              5.2.8-1              5.2.8-2
                        linux414-zfs             0.7.5-11             0.7.5-12
                  linux416-acpi_call            1.1.0-0.3            1.1.0-0.4
                   linux416-bbswitch              0.8-0.3              0.8-0.4
                linux416-broadcom-wl     6.30.223.271-0.3     6.30.223.271-0.4
                   linux416-catalyst    1:15.201.1151-0.3    1:15.201.1151-0.4
                linux416-ndiswrapper             1.61-0.3             1.61-0.4
                     linux416-nvidia         1:390.25-0.3         1:390.25-0.4
               linux416-nvidia-304xx        1:304.137-0.3        1:304.137-0.4
               linux416-nvidia-340xx          340.106-0.3          340.106-0.4
                   linux416-nvidiabl             0.88-0.3             0.88-0.4
                      linux416-r8168         8.045.08-0.3         8.045.08-0.4
                   linux416-tp_smapi             0.41-0.3             0.41-0.4
                linux416-vhba-module         20161009-0.3         20161009-0.4
   linux416-virtualbox-guest-modules            5.2.8-0.1            5.2.8-0.4
    linux416-virtualbox-host-modules            5.2.8-0.1            5.2.8-0.4


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-05           2018-03-07
-------------------------------------------------------------------------------
                                 feh               2.24-1               2.25-1
                               ipset               6.35-1               6.36-1
                            libmspub              0.1.3-1              0.1.4-1
                            liborcus             0.13.3-1             0.13.4-1
                   libreoffice-fresh              6.0.1-1              6.0.2-1
                libreoffice-fresh-af              6.0.1-1              6.0.2-1
                libreoffice-fresh-am              6.0.1-1              6.0.2-1
                libreoffice-fresh-ar              6.0.1-1              6.0.2-1
                libreoffice-fresh-as              6.0.1-1              6.0.2-1
               libreoffice-fresh-ast              6.0.1-1              6.0.2-1
                libreoffice-fresh-be              6.0.1-1              6.0.2-1
                libreoffice-fresh-bg              6.0.1-1              6.0.2-1
                libreoffice-fresh-bn              6.0.1-1              6.0.2-1
             libreoffice-fresh-bn-IN              6.0.1-1              6.0.2-1
                libreoffice-fresh-bo              6.0.1-1              6.0.2-1
                libreoffice-fresh-br              6.0.1-1              6.0.2-1
               libreoffice-fresh-brx              6.0.1-1              6.0.2-1
                libreoffice-fresh-bs              6.0.1-1              6.0.2-1
                libreoffice-fresh-ca              6.0.1-1              6.0.2-1
       libreoffice-fresh-ca-valencia              6.0.1-1              6.0.2-1
                libreoffice-fresh-cs              6.0.1-1              6.0.2-1
                libreoffice-fresh-cy              6.0.1-1              6.0.2-1
                libreoffice-fresh-da              6.0.1-1              6.0.2-1
                libreoffice-fresh-de              6.0.1-1              6.0.2-1
               libreoffice-fresh-dgo              6.0.1-1              6.0.2-1
                libreoffice-fresh-dz              6.0.1-1              6.0.2-1
                libreoffice-fresh-el              6.0.1-1              6.0.2-1
             libreoffice-fresh-en-GB              6.0.1-1              6.0.2-1
             libreoffice-fresh-en-ZA              6.0.1-1              6.0.2-1
                libreoffice-fresh-eo              6.0.1-1              6.0.2-1
                libreoffice-fresh-es              6.0.1-1              6.0.2-1
                libreoffice-fresh-et              6.0.1-1              6.0.2-1
                libreoffice-fresh-eu              6.0.1-1              6.0.2-1
                libreoffice-fresh-fa              6.0.1-1              6.0.2-1
                libreoffice-fresh-fi              6.0.1-1              6.0.2-1
                libreoffice-fresh-fr              6.0.1-1              6.0.2-1
                libreoffice-fresh-ga              6.0.1-1              6.0.2-1
                libreoffice-fresh-gd              6.0.1-1              6.0.2-1
                libreoffice-fresh-gl              6.0.1-1              6.0.2-1
                libreoffice-fresh-gu              6.0.1-1              6.0.2-1
                libreoffice-fresh-he              6.0.1-1              6.0.2-1
                libreoffice-fresh-hi              6.0.1-1              6.0.2-1
                libreoffice-fresh-hr              6.0.1-1              6.0.2-1
                libreoffice-fresh-hu              6.0.1-1              6.0.2-1
                libreoffice-fresh-id              6.0.1-1              6.0.2-1
                libreoffice-fresh-is              6.0.1-1              6.0.2-1
                libreoffice-fresh-it              6.0.1-1              6.0.2-1
                libreoffice-fresh-ja              6.0.1-1              6.0.2-1
                libreoffice-fresh-ka              6.0.1-1              6.0.2-1
                libreoffice-fresh-kk              6.0.1-1              6.0.2-1
                libreoffice-fresh-km              6.0.1-1              6.0.2-1
          libreoffice-fresh-kmr-Latn              6.0.1-1              6.0.2-1
                libreoffice-fresh-kn              6.0.1-1              6.0.2-1
                libreoffice-fresh-ko              6.0.1-1              6.0.2-1
               libreoffice-fresh-kok              6.0.1-1              6.0.2-1
                libreoffice-fresh-oc              6.0.1-1              6.0.2-1
                libreoffice-fresh-om              6.0.1-1              6.0.2-1
                libreoffice-fresh-or              6.0.1-1              6.0.2-1
             libreoffice-fresh-pa-IN              6.0.1-1              6.0.2-1
                libreoffice-fresh-pl              6.0.1-1              6.0.2-1
                libreoffice-fresh-pt              6.0.1-1              6.0.2-1
             libreoffice-fresh-pt-BR              6.0.1-1              6.0.2-1
                libreoffice-fresh-ro              6.0.1-1              6.0.2-1
                libreoffice-fresh-ru              6.0.1-1              6.0.2-1
                libreoffice-fresh-rw              6.0.1-1              6.0.2-1
             libreoffice-fresh-sa-IN              6.0.1-1              6.0.2-1
               libreoffice-fresh-sat              6.0.1-1              6.0.2-1
                libreoffice-fresh-sd              6.0.1-1              6.0.2-1
               libreoffice-fresh-sdk              6.0.1-1              6.0.2-1
                libreoffice-fresh-si              6.0.1-1              6.0.2-1
               libreoffice-fresh-sid              6.0.1-1              6.0.2-1
                libreoffice-fresh-sk              6.0.1-1              6.0.2-1
                libreoffice-fresh-sl              6.0.1-1              6.0.2-1
                libreoffice-fresh-sq              6.0.1-1              6.0.2-1
                libreoffice-fresh-sr              6.0.1-1              6.0.2-1
           libreoffice-fresh-sr-Latn              6.0.1-1              6.0.2-1
                libreoffice-fresh-ss              6.0.1-1              6.0.2-1
                libreoffice-fresh-st              6.0.1-1              6.0.2-1
                libreoffice-fresh-sv              6.0.1-1              6.0.2-1
             libreoffice-fresh-sw-TZ              6.0.1-1              6.0.2-1
                libreoffice-fresh-ta              6.0.1-1              6.0.2-1
                libreoffice-fresh-te              6.0.1-1              6.0.2-1
                libreoffice-fresh-tg              6.0.1-1              6.0.2-1
                libreoffice-fresh-th              6.0.1-1              6.0.2-1
                libreoffice-fresh-tn              6.0.1-1              6.0.2-1
                libreoffice-fresh-tr              6.0.1-1              6.0.2-1
                libreoffice-fresh-ts              6.0.1-1              6.0.2-1
                libreoffice-fresh-tt              6.0.1-1              6.0.2-1
                libreoffice-fresh-ug              6.0.1-1              6.0.2-1
                libreoffice-fresh-uk              6.0.1-1              6.0.2-1
                libreoffice-fresh-uz              6.0.1-1              6.0.2-1
                libreoffice-fresh-ve              6.0.1-1              6.0.2-1
                libreoffice-fresh-vi              6.0.1-1              6.0.2-1
                libreoffice-fresh-xh              6.0.1-1              6.0.2-1
             libreoffice-fresh-zh-CN              6.0.1-1              6.0.2-1
             libreoffice-fresh-zh-TW              6.0.1-1              6.0.2-1
                libreoffice-fresh-zu              6.0.1-1              6.0.2-1
                            nftables            1:0.8.2-1            1:0.8.3-1
                              quagga              1.2.2-1              1.2.4-1
                                 re2           20180201-1           20180301-1
                                sdl2              2.0.7-1              2.0.8-1
                          sdl2_image              2.0.2-1              2.0.3-1
                 texlive-bibtexextra         2017.45810-1         2017.46775-1
                        texlive-core         2017.45811-1         2017.46770-1
                  texlive-fontsextra         2017.45939-1         2017.46787-1
                texlive-formatsextra         2017.45678-1         2017.45845-1
                       texlive-games         2017.44131-1         2017.46791-1
                  texlive-humanities         2017.45709-1         2017.46767-1
                 texlive-langchinese         2017.45677-1         2017.46542-1
                texlive-langcyrillic         2017.45692-1         2017.45751-1
                   texlive-langextra         2017.45591-1         2017.46741-1
                   texlive-langgreek         2017.44917-1         2017.46662-1
                texlive-langjapanese         2017.45699-1         2017.46733-1
                  texlive-latexextra         2017.45733-1         2017.46778-1
                       texlive-music         2017.45674-1         2017.46141-1
                    texlive-pictures         2017.45569-1         2017.46740-1
                    texlive-pstricks         2017.45644-1         2017.46667-1
                  texlive-publishers         2017.45734-1         2017.46790-1
                     texlive-science         2017.45707-1         2017.46789-1
                   wayland-protocols               1.12-1               1.13-1
             xfce4-pulseaudio-plugin              0.3.4-1              0.3.5-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-05           2018-03-07
-------------------------------------------------------------------------------
                        wine-staging               2.21-1                3.3-1
                   wine-staging-nine               2.21-1                3.3-1

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

Known issues and solutions

This is a wiki post; please edit as necessary.


My mouse is jittering like hell!

Seems the new libinput update created some issues with some touchpads. If our new kernel updates don’t solve the issue for you, you may think about downgrading libinput instead, until upstream found a proper solution for you:

sudo pacman -U https://archive.archlinux.org/packages/l/libinput/libinput-1.9.4-1-x86_64.pkg.tar.xz

xorgproto, libxfont, can’t remove… what?

Refresh your mirrors and try the update again. This package conflict should be resolved.

Otherwise, say Yes to replace all the “proto” packages with xorgproto. If it wants to remove any packages, STOP, and run

sudo pacman-mirrors -f 3
sudo pacman -Syyu

KDE Global Menu on all my windows

Check System Settings -> Application Style -> Window Decorations -> Buttons.

Make sure global menu widget is removed from the Titlebar, for some reason it was added in 5.12 when the global menu setting option was removed.


KDE remove green separator line between Titlebar and Window

System Settings>Application Style>Window Decorations>Breeze>Settings Icon
Turn off “Draw separator …”


On KDE my external drives don’t get automounted when I plugged them in

As a workaround put into the KDE/Plasma autostart the program udiskie (just plain like that), after you had installed it. A re-login may be needed to get it active. As alternative start it manually for your current session.


My system won’t boot anymore after this update

Most likely you are using a freetype2 package from the AUR. Due the harfbuzz update, your system is broken. So either install the official supported freetype2 package from our repositories or downgrade to harfbuzz v1.7.4: sudo pacman -U https://archive.archlinux.org/packages/h/harfbuzz/harfbuzz-1.7.4-1-x86_64.pkg.tar.xz

You might try also try Freetype2-ultimate5 — fonts like in Infinality's ultimate5 which is a maintained package.


I get “error: command failed to execute correctly” during a GRUB update

Run sudo update-grub once more to ensure the command has worked correctly.


GNOME shell crashes

It’s probably an issue with an extension which needs to be updated. Disable them in turn until you find the one responsible.

If it’s when inserting USB drives, disable “Places Status Indicator”.


Font-Shadow issue within XFCE

Switch to another theme (e.g. Arc Maia), or execute the following cmd to fix the issue:

xfconf-query -c xfce4-desktop -p /desktop-icons/center-text -n -t bool -s false

This fixes the issue properly. (Can follow the links from Ask-Ubuntu #801478 to what exists for the xfce documentation.)

After the command is run the entry <property name="center-text" type="bool" value="false"/> is created under “desktop-icons” in /home/[user]/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml.


Firefox 58 won’t open

Please check this thread:


I don’t see any updates

That’s because your mirror is out of date. It can take several hours before a mirror get updated. If you want updates right now, run these commands :

sudo pacman-mirrors -f 3
sudo pacman -Syyu

You can always check the state of every mirrors here.


I get a black screen on boot or something doesn’t work

That’s probably because you have a partial set of updated packages. Switch to a text console using CTRL+ALT+F2, log in, then run the commands above.


An AUR package is stopping the update because of a conflict

Remove the AUR package, update, then reinstall the AUR package.


An AUR package says a key is invalid

You need to add the key to your keychain. Do a search of the forum, the answer has already been posted (several times :wink:).


Manual intervention for Gnome,Budgie and Mate:

Because the default icons set has changed from arc-maia to papirus-maia, you need to install papirus-maia-icon-theme manually. Otherwise, fallback icons ( for example, adwaita ) might be used instead.


conflicting files: zita-resampler: /usr/lib/libzita-resampler.so.1 already exists in filesystem

Some users got this error when they tried to update their system. If you have this message, remove /usr/lib/libzita-resampler.so.1 manually before updating.


#3

A light and easy update, especially for 4.15 as there has not been any kernel update since the 28th of last month. Thanks for the work.


#4

Manjaro Mate, kernel 4.14. Everything smooth after rebooting. Cheers.


#5

Desktop Asus Z270 I7-7700 NVidia GT730, Kernel 4.14.24-1 XFCE4.12.4 updated via pamac without problems
Laptop MacBook Pro 8.1 I5-2435M, Intel Graphics Kernel 4.14.24-1 XFCE 4.12.4 updated via pamac without problems.

Many thanks to the developers and maintainers.


#6

No Problems here. Thanks a lot :sunglasses:

regards
caho


#7

Manjaro 17.1.7?


#8

Not yet, as some maintainers still test some stuff …


#9

On one of my KDE laptops after the upgrade, with every boot I get:

Is there a way to no longer get this?
Possibly related, but I think I lost my bouncing cursor, even though it is still set that way in Launch Feedback


#10

I’m on kernel 4.14 and this Update messed up my system (mouse acting really wierd + budgie Ignoring configurations) probably related with the libinput issue described by @philm

For now I’ll just keep on version 4.14.23.


#11

Gnome, update was smooth and no problems here :slight_smile:


#12

10/10. As usual.


#13

All good. XFCE.


#14

Flawless update for Xfce Thinkpad intel integrated gpu kernel 415. You guys are really on top of things - thanks for a beautiful OS.


#15

same. I just reinstalled nvidia driver (manjaro setting - hardware configuration)


#16

After applying this update together with the previous one my system froze with ‘starting reboot’ after the normal ‘watchdog did not stop’, etc. messages. Had to hard reset but all seems good now. :grinning:


#17

xps9550, KDE, linux 44, OK


#18

Another smooth update, Thank you!
P.S. KDE, linux 4.14, mesa radeon.


#19

Mi Notebook Pro, KDE, linux 4.14, intel + nvidia, no issues. Thanks!


#21

That seemed to have worked once (to remove the compositor settings dialog), but the dialog has come back (but not my bouncing cursor).