[Stable Update] 2018-02-20 - Kernels, Mesa, KDE fixes, Driver fixes

Did you get this resolved?

I updated yesterday and noticed I had updates now, just those 2. Odd thing is my machine doesnt have anything nvidia in it and the browser settings entry seems a bit strange. Came looking here before I plan to accept the updates.

Can anyone say if these are legit and should work or if they are a sign of an issue?

Well, seems adopting to some Ubuntu config changes enabled the nvidiafb, which is now creating these issues. Maybe we will revert this to previous behaviour.

1 Like

Any messages on the screen? Try chrooting and revert kernel to 4.14.19.

no messages, tried using dmesg and journalctl. I have kernel 4.14 didn’t work either.

For me There is a difference between 4.14.20 and 4.14.19
Did dmesg show something? Are you able to execute them? Are some messages flashing while booting?

@philm Problem solved! Thank you very much! :+1:

I reported the problem because it did not occur with kernel 4.14 and, obviously, did not realize it could be a problem of nbfc.

Since it is an AUR package you might need to recompile nbfc.

In fact I did so before reporting (I should probably have mentioned in my post).

Did you test the git version yet?

No, just the AUR package, which stated version 1.5.3.r65.ga2465ad-1.

Also check the changelog if there was some improvements made. Also your issue was already reported

:blush: The “solution” reported there, i.e. deleting or renaming StagWare.Plugins.ECSysLinux.dll worked for me as well. That is:

  1. the system boots properly with kernel 4.15 (no black screen any more)
  2. nbfc-service starts and fan control works as expected

update ok

After the update, Mythtv no longer starts. This is the error message I get: error while loading shared libraries: libvpx.so.4: cannot open shared object file: No such file or directory

I tried to locate libvpx.so.4 and this is what returned.
/usr/lib/libvpx.so
/usr/lib/libvpx.so.5
/usr/lib/libvpx.so.5.0
/usr/lib/libvpx.so.5.0.

I am not sure how to proceed. General web searches have not been helpful. Thanks.

MythTV is an AUR package. According to its PKGBUILD, in order to create the package for MythTV, it has to compile the program from source. It might needs a recompilation, because it is looking for an old version of a library.

In order to recompile your program, uninstall its package first, then reinstall it from AUR. It should compile the program using the new version of libvpx.

Busy for work, i only updated this patch few hours ago and got a really strange bug.
First, my pc cannot boot and it say: Dependency failed on /home and /boot/efi after a long time running a bunch of start jobs. Guessed there’s smt wrong with fstab, I checked it but everything looks fine.
I changed the fstab entries from UUID to /dev/sdXY hope this will fix the problem but another problem occurred, it hangs on a start job to Create Volatile files and directories with no time limit. After a little bit search i found a workaround for this problem by remove the /var/log/journal directory.
Finally my pc can boot but it constantly crashes after about 5mins. Now I have to post this reply through a live usb :frowning_face:
Excuse me for my bad English and thanks for your help.

Sounds to me like a problem with VIRTUAL outputs

No issues with Lenovo laptop, Xfce, and Kernel 4.15.4-2. Thanks everyone - I always read all your posts!

After a couple of days using this new upgrade, my laptop is experience random rebooting when I am working on battery. Furthermore, the date on my pc is not sync and I have to set all again. wired!

My laptop is an ASUS X441U, kernel 4.14 and XFCE. If you need more information, in order to fix my problem, please let me know

First thing you could do is upgrade to 4.15 to see if it is fixed by then, most often these are kernel problems, especially when your laptop seems to be very new.

Hello !

Update : now after the 25.02.2018 update the error message is gone !

I also want to report this very same error after the update.
During boot this message appears: nvidiafb: cannot request PCI regions
I will install die new update today on 25.02.2018 and will report if the error disappeared ! (besides the error message the whole system seemed to work fine and stable just as user “themew” reports)

My System speccs:
Kernel: 4.15.4-2-MANJARO x86_64 bits: 64 Desktop: Xfce 4.12.4
GPU: NVIDIA Corporation MCP89 [GeForce 320M] (rev a2)
Driver installed: video-nvidia-340xx, version: 2017.03.12, freedriver: false
OpenGL: renderer: GeForce 320M/integrated/SSE2, version: 3.3.0 NVIDIA 340.106

@Xavoc , it’s another topic for update

Hi @LA-MJ,
I read about VIRTUAL outputs, and try change things, but nothing help. It applies to the second screen, that use the NVIDIA card, but the laptop screen is still with 960x540 resolution.
I’m shure that with the hybrid-nvidia-bumblebee graphic, I’m using the Intel driver, and the NVIDIA it’s only load when I use optirun.
I have another user with i3wm. I enter today, and everything is perfect there. It’s only some setting in the KDE session.

I finally got the solution. Just need to remove the /etc/X11/xorg.conf file.
I opened a new post and @sueridgepipe help me.
Everything is fine now. Thank you.

Just opened a thread with a workaround…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.