[Stable Update] 2018-02-20 - Kernels, Mesa, KDE fixes, Driver fixes

update
stable

#48

Everything looks good on XFCE desktop and kernel 4.14.20 !

Thanks Manjaro Team


#49

No, I can’t remember ever having had Bluetooth work on this machine (System 76 Oryx Pro 1) running KDE.

Not a operator limitation, it’s supposed to work even with sharing the phones wifi connection over Bluetooth (which does not work either) also I’m running Copperhead OS and I don’t think they impose those kind of limitations anyway.


#50

Not sure if this is the right place to report but …

after today’s update (only the following two packages were updated)

[2018-02-21 20:04] [ALPM] upgraded mhwd-nvidia (1:384.111-2 -> 1:390.25-1)
[2018-02-21 20:04] [ALPM] upgraded manjaro-browser-settings (20180218-4 -> 20180220-1)

booting with kernel 4.15.4-2 results in a black screen (once the graphic login would nomally be displayed) and high CPU-load. Luckily I can still boot with kernel 4.14.20-2. I should probably mention that I’m still using intel-ucode 20180108-1 since I haven’t encountered any problems with it.

Furthermore, I also noted that after the last update of kernel 4.15 nbfc (notebook fan control) was not working any more. When trying to launch I got an error message like the following:

NbfcService: File Descriptor does not support writing


#51

Since it is an AUR package you might need to recompile nbfc. Did you test the git version yet? Also check the changelog if there was some improvements made. Also your issue was already reported.


#52

after this update manjaro won’t boot anymore. I had freetype2 from extra. I used all the methods listed in the beginning. none of them worked. Please someone help


#53

This update is really small and only contains kernel updates. Did you test if a fresh v17.1.5 ISO is still booting on your end? The 17th Feb Update was larger, btw.


#54

Hi guys,
After the update, I restarted and now my laptop resolution is 960x540 instead of 1920x1080. It’s an Alienware 14.

inxi -F output:

System:    Host: predator Kernel: 4.15.4-2-MANJARO x86_64 bits: 64 gcc: 7.3.0
           Desktop: KDE Plasma 5.12.1 (Qt 5.10.0) dm: sddm,sddm Distro: Manjaro Linux
Machine:   Device: portable System: Alienware product: Alienware 14 v: A09 serial: N/A
           Mobo: Alienware model: 07MJ2Y v: A01 serial: N/A UEFI: Alienware v: A09 date: 04/23/2014
           Chassis: type: 8 v: A09 serial: N/A
Battery    BAT1: charge: 48.6 Wh 100.0% condition: 48.6/71.0 Wh (68%) volts: 13.0/11.1
           model: Simplo PABAS0241231 serial: 41167 status: Full
CPU:       Quad core Intel Core i7-4700MQ (-MT-MCP-) arch: Haswell rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19154
           clock speeds: min/max: 800/3400 MHz 1: 1893 MHz 2: 2293 MHz 3: 2372 MHz 4: 2336 MHz 5: 2370 MHz
           6: 1568 MHz 7: 2274 MHz 8: 2344 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:0416
           Card-2: NVIDIA GK106M [GeForce GTX 765M] bus-ID: 01:00.0 chip-ID: 10de:11e2
           Display Server: x11 (X.Org 1.19.6 ) drivers: intel (unloaded: nvidia) Resolution: 1920x1200@59.95hz
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile
           version: 4.5 Mesa 17.3.5 (compat-v: 3.0) Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:8c20
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0 chip-ID: 8086:0c0c
           Sound: Advanced Linux Sound Architecture v: k4.15.4-2-MANJARO
Network:   Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx port: 3000 bus-ID: 08:00.0 chip-ID: 1969:e091
           IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: f0:1f:af:6f:62:f9
           Card-2: Qualcomm Atheros AR9462 Wireless Network Adapter
           driver: ath9k bus-ID: 0a:00.0 chip-ID: 168c:0034
           IF: wlp10s0 state: up mac: 34:23:87:5e:94:77
Drives:    HDD Total Size: 750.2GB (78.2% used)
           ID-1: /dev/sda model: WDC_WD7500BPKX size: 750.2GB serial: WD-WX41A93N0625
Partition: ID-1: / size: 46G used: 35G (82%) fs: ext4 dev: /dev/sda7
           ID-2: /home size: 42G used: 30G (76%) fs: ext4 dev: /dev/sda9
           ID-3: swap-1 size: 17.20GB used: 0.00GB (0%) fs: swap dev: /dev/sda8
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 246 Uptime: 2:25 Memory: 3712.8/15925.0MB Init: systemd v: 237 Gcc sys: 7.3.0
           Client: Shell (zsh 5.4.2 running in konsole) inxi: 2.3.56

I’m using the video-hybrid-intel-nvidia-bumblebee driver, since I installed Manjaro, 8 month ago.

I use my laptop with an external monitor of 1900x1200. When the monitor is connected I turn off the laptop display, and only use the external monitor.
I detected the problem, because I had to disconnect the monitor to move to another room. Then, when I restart the laptop the resolution was half of the FHD. The login screen seems to be in FHD resolution, but after login everything is half FHD resolution and there is no way to increase the resolution in the System Setting > Monitor.

What should I try?


#55

Same error here causing GPU to stay ON at startup:

$ dmesg | grep -i bbswitch
[    9.618571] bbswitch: version 0.8
[    9.618576] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    9.618580] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[    9.618687] bbswitch: detected an Optimus _DSM function
[    9.618693] bbswitch: device 0000:01:00.0 is in use by driver 'nvidiafb', refusing OFF
[    9.618694] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on

# I run **$ optirun echo** then:
[   21.684179] bbswitch: disabling discrete graphics

After adding blacklist nvidiafb in /etc/modprobe.d/mhwd-nvidia.conf

$ dmesg | grep -i bbswitch
[   10.422224] bbswitch: version 0.8
[   10.422229] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[   10.422234] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[   10.422335] bbswitch: detected an Optimus _DSM function
[   10.422406] bbswitch: disabling discrete graphics
[   10.500110] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is off

Graphic setup:

Graphics:  Card-1: Intel HD Graphics 530 bus-ID: 00:02.0
           Card-2: NVIDIA GM204M [GeForce GTX 970M] bus-ID: 01:00.0

It also seems to cause crash on other laptops: https://bugs.archlinux.org/task/57578

@philm
So maybe blacklist nvidiafb should be added in /etc/modprobe.d/mhwd-nvidia.conf ?


#56

Did you get this resolved?

I updated yesterday and noticed I had updates now, just those 2. Odd thing is my machine doesnt have anything nvidia in it and the browser settings entry seems a bit strange. Came looking here before I plan to accept the updates.

Can anyone say if these are legit and should work or if they are a sign of an issue?


#57

Well, seems adopting to some Ubuntu config changes enabled the nvidiafb, which is now creating these issues. Maybe we will revert this to previous behaviour.


#58

Any messages on the screen? Try chrooting and revert kernel to 4.14.19.


#59

no messages, tried using dmesg and journalctl. I have kernel 4.14 didn’t work either.


#60

For me There is a difference between 4.14.20 and 4.14.19
Did dmesg show something? Are you able to execute them? Are some messages flashing while booting?


#61

@philm Problem solved! Thank you very much! :+1:

I reported the problem because it did not occur with kernel 4.14 and, obviously, did not realize it could be a problem of nbfc.

Since it is an AUR package you might need to recompile nbfc.

In fact I did so before reporting (I should probably have mentioned in my post).

Did you test the git version yet?

No, just the AUR package, which stated version 1.5.3.r65.ga2465ad-1.

Also check the changelog if there was some improvements made. Also your issue was already reported

:blush: The “solution” reported there, i.e. deleting or renaming StagWare.Plugins.ECSysLinux.dll worked for me as well. That is:

  1. the system boots properly with kernel 4.15 (no black screen any more)
  2. nbfc-service starts and fan control works as expected

#62

update ok


#63

After the update, Mythtv no longer starts. This is the error message I get: error while loading shared libraries: libvpx.so.4: cannot open shared object file: No such file or directory

I tried to locate libvpx.so.4 and this is what returned.
/usr/lib/libvpx.so
/usr/lib/libvpx.so.5
/usr/lib/libvpx.so.5.0
/usr/lib/libvpx.so.5.0.

I am not sure how to proceed. General web searches have not been helpful. Thanks.


#64

MythTV is an AUR package. According to its PKGBUILD, in order to create the package for MythTV, it has to compile the program from source. It might needs a recompilation, because it is looking for an old version of a library.

In order to recompile your program, uninstall its package first, then reinstall it from AUR. It should compile the program using the new version of libvpx.


#65

Busy for work, i only updated this patch few hours ago and got a really strange bug.
First, my pc cannot boot and it say: Dependency failed on /home and /boot/efi after a long time running a bunch of start jobs. Guessed there’s smt wrong with fstab, I checked it but everything looks fine.
I changed the fstab entries from UUID to /dev/sdXY hope this will fix the problem but another problem occurred, it hangs on a start job to Create Volatile files and directories with no time limit. After a little bit search i found a workaround for this problem by remove the /var/log/journal directory.
Finally my pc can boot but it constantly crashes after about 5mins. Now I have to post this reply through a live usb :frowning_face:
Excuse me for my bad English and thanks for your help.


#66

Sounds to me like a problem with VIRTUAL outputs


#67

No issues with Lenovo laptop, Xfce, and Kernel 4.15.4-2. Thanks everyone - I always read all your posts!