[Stable Update] 2018-02-20 - Kernels, Mesa, KDE fixes, Driver fixes

System wont boot with 4.15. Boots with 4.14 that i still also have installed.

I use freetype2 from extra and lib32-freetype2 from multilib. Any advice?

xps9550,linux44,KDE, update OK

Hi, friends. 4.9.82 - no errors

dmesg | grep microcode 4.9.82

[ 0.000000] microcode: microcode updated early to revision 0x7, date = 2013-08-20
[ 0.843770] microcode: sig=0x106e5, pf=0x10, revision=0x7
[ 0.844522] microcode: Microcode Update Driver: v2.01 tigran@aivazian.fsnet.co.uk, Peter Oruba

4.14.20 - errors

[ 0.056700] mce: [Hardware Error]: Machine check events logged
[ 0.056705] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ee0000000100014a
[ 0.056717] mce: [Hardware Error]: TSC 0 ADDR d408bb40 MISC 222c
[ 0.056733] mce: [Hardware Error]: PROCESSOR 0:106e5 TIME 1519204799 SOCKET 0 APIC 0 microcode 7

dmesg | grep microcode 4.14.20

[ 0.000000] microcode: microcode updated early to revision 0x7, date = 2013-08-20
[ 0.676122] microcode: sig=0x106e5, pf=0x10, revision=0x7
[ 0.676776] microcode: Microcode Update Driver: v2.2.

inxi -F

System: Host: rf710 Kernel: 4.14.20-2-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.12.1
Distro: Manjaro Linux
Machine: Device: laptop System: SAMSUNG product: RF510/RF410/RF710 serial: N/A
Mobo: SAMSUNG model: RF510/RF410/RF710 serial: N/A
BIOS: Phoenix v: 02HN.M005.20110303.hkk date: 03/03/2011
Battery BAT1: charge: 32.4 Wh 79.0% condition: 41.1/48.8 Wh (84%)
CPU: Quad core Intel Core i7 Q 720 (-MT-MCP-) cache: 6144 KB
clock speeds: max: 1600 MHz 1: 930 MHz 2: 930 MHz 3: 931 MHz 4: 930 MHz 5: 930 MHz
6: 930 MHz 7: 930 MHz 8: 930 MHz
Graphics: Card: NVIDIA GF108M [GeForce GT 420M]
Display Server: N/A driver: nvidia tty size: 96x42
Audio: Card-1 NVIDIA GF108 High Def. Audio Controller driver: snd_hda_intel
Card-2 Intel 5 Series/3400 Series High Def. Audio driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.14.20-2-MANJARO
Network: Card-1: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter driver: wl
IF: wlp3s0 state: down mac: 92:38:74:4e:35:e8
Card-2: Marvell Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB]
driver: sky2
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: 00:24:54:cb:86:dd
Drives: HDD Total Size: 1000.2GB (33.4% used)
ID-1: /dev/sdb model: Hitachi_HTS54505 size: 500.1GB
ID-2: /dev/sda model: Hitachi_HTS54505 size: 500.1GB
Partition: ID-1: / size: 449G used: 257G (61%) fs: ext4 dev: /dev/sdb1
ID-2: swap-1 size: 9.45GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
Sensors: System Temperatures: cpu: 60.0C mobo: 60.0C gpu: 58C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 207 Uptime: 2:07 Memory: 2381.3/5896.8MB Init: systemd
Client: Shell (bash) inxi: 2.3.56

Intel® Processor Diagnostic Tool: All test ok - pass.

Do you have to wait for the releases of new kernels 4.14.xx? or ignore the mistakes? Or it is possible to correct somehow?

Just tried tethering after the update. Both Wi-Fi and Blueooth ones work fine.
Was it working before the update? Maybe it’s due to your operator limitations?

Or you can use vlc-nightly from Manjaro repo …

Same here.

AMD Ryzen, Kernel 4.14, Xfce, driver Nvidia 390.25 & GeForce GTX 1070.

First i get the regular login screen. After login only wallpaper is shown, no bars, no icons, nothing. Ctrl+Alt+F2, then Ctrl+Alt+F7 somehow fixes the session, the normal full desktop is available.

Related German discussion thread here:
https://bbs.archlinux.de/viewtopic.php?id=31283

Seems like it has to do with anti tearing options in nvidia.conf.

1 Like

Thanks for the reply @ottomops !
Yes, its definitely the full composition option in the nvidia.conf.
Link: Manjaro Linux Forum [Stable Update] 2018-02-17

What the hell is going on with nvidia drivers ??? 390.25 was released long time ago, there even was a post that manjaro updated to this version, but in repos : mhwd-nvidia-1:384.111-2, wtf ???

Try updating your mirrors maybe?

sudo pacman-mirrors -f0

Yeah, I’ve got this too, even in the testing branch. Either it did not need updating or it was overlooked.

I could not boot with any kernel after this update. (Tried 4.15, 4.14, 4.9, 4.1, 3.18).
I was stuck at Loading ram disk. Tried regenerating using mkinitcpio, grup-update, nothing would work.

I had to boot into a liveCD, chroot and change to testing branch and updating,. Every kernel works now.
I’d say the culprit was the intel driver, but no proof.

Smooth update, but one bug … i suspect it might have arisen in a previous update [to Plasma 5.12.0]… i can no longer switch users; instead i must actually log out from User A before can log in as User B, rather than nicely switch back & forth per previously.

This is not mentioned in the Wiki above, but i do recall reading of it previously in the forum, so will go search for possible solution now.

EDIT: Hmmm, well i thought i’d read of the problem in the forum, but so far any posted solution has evaded me. I also thought i read of it in the site https://www.reddit.com/r/kde/, but now can’t seem to find it there either. It was mentioned for Plasma 5.11, here, https://forum.kde.org/viewtopic.php?t=142444 but that never affected me when i still had 5.11 … i wonder if my current 5.12.1 problem is another upstream problem, or if it’s just local to me…

EDIT#2 [the next day]: Nope, it’s not P5.12.1’s fault, it’s something specific to my Tower’s real Manjaro KDE [Stable], whose presumed fault was not present before 5.12, coz the symptom wasn’t. Conversely, my Tower’s Manjaro KDE VM [Testing] continues to happily switch users just fine. My Lappy’s real Manjaro KDE [Testing] also continues to happily switch users just fine. Sigh, i suspect this will be a fun time tracking down the problem root cause…

EDIT#3: I created 2 temporary test user accounts, test1 & test2. I logged out of my primary account, then logged into test1. Therein i attempted to Switch User. This time, unlike my Primary & Secondary accounts which since this fault appeared don’t even offer me the screen to select other user accounts [they each just instantly bounce back into the desktop from which i was trying to switch], i was offered the screen to pick other users EXCEPT… this screen only contains test1, not any of my other three. Grrrr. Next i logged out of test1, & then logged into test2, then repeated the preceding steps, which gave identical misbehaviour [the Switch screen contained only test2]. Finally i fully rebooted Tower, then repeated the preceding… with identical misbehaviour.

Now i feel pretty confused.

  1. My Tower’s VM KDE, & my Lappy’s real Manjaro KDE, prove that it is not a fundamental bug in Plasma 5.12.1, but restricted specifically to my Tower’s real Manjaro KDE. Even though both my Lappy & Tower’s VM were updated to Plasma 5.12.2 this morning [they’re on Testing branch], i know for certain that both were still switching users up til yesterday when they were still Plasma 5.12.1.
  2. I assumed the preceding point thus implied that somehow one of my Plasma config files in both my Primary & Secondary user accounts had become corrupted [which feels a pretty big ask; major coincidence], & hence creation of a temporary test account should confirm it… except that the test accounts also do not switch properly.
  3. What other potential root causes should i suspect?

Everything looks good on XFCE desktop and kernel 4.14.20 !

Thanks Manjaro Team

No, I can’t remember ever having had Bluetooth work on this machine (System 76 Oryx Pro 1) running KDE.

Not a operator limitation, it’s supposed to work even with sharing the phones wifi connection over Bluetooth (which does not work either) also I’m running Copperhead OS and I don’t think they impose those kind of limitations anyway.

Not sure if this is the right place to report but …

after today’s update (only the following two packages were updated)

[2018-02-21 20:04] [ALPM] upgraded mhwd-nvidia (1:384.111-2 -> 1:390.25-1)
[2018-02-21 20:04] [ALPM] upgraded manjaro-browser-settings (20180218-4 -> 20180220-1)

booting with kernel 4.15.4-2 results in a black screen (once the graphic login would nomally be displayed) and high CPU-load. Luckily I can still boot with kernel 4.14.20-2. I should probably mention that I’m still using intel-ucode 20180108-1 since I haven’t encountered any problems with it.

Furthermore, I also noted that after the last update of kernel 4.15 nbfc (notebook fan control) was not working any more. When trying to launch I got an error message like the following:

NbfcService: File Descriptor does not support writing

Since it is an AUR package you might need to recompile nbfc. Did you test the git version yet? Also check the changelog if there was some improvements made. Also your issue was already reported.

1 Like

after this update manjaro won’t boot anymore. I had freetype2 from extra. I used all the methods listed in the beginning. none of them worked. Please someone help

This update is really small and only contains kernel updates. Did you test if a fresh v17.1.5 ISO is still booting on your end? The 17th Feb Update was larger, btw.

Hi guys,
After the update, I restarted and now my laptop resolution is 960x540 instead of 1920x1080. It’s an Alienware 14.

inxi -F output:

System:    Host: predator Kernel: 4.15.4-2-MANJARO x86_64 bits: 64 gcc: 7.3.0
           Desktop: KDE Plasma 5.12.1 (Qt 5.10.0) dm: sddm,sddm Distro: Manjaro Linux
Machine:   Device: portable System: Alienware product: Alienware 14 v: A09 serial: N/A
           Mobo: Alienware model: 07MJ2Y v: A01 serial: N/A UEFI: Alienware v: A09 date: 04/23/2014
           Chassis: type: 8 v: A09 serial: N/A
Battery    BAT1: charge: 48.6 Wh 100.0% condition: 48.6/71.0 Wh (68%) volts: 13.0/11.1
           model: Simplo PABAS0241231 serial: 41167 status: Full
CPU:       Quad core Intel Core i7-4700MQ (-MT-MCP-) arch: Haswell rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19154
           clock speeds: min/max: 800/3400 MHz 1: 1893 MHz 2: 2293 MHz 3: 2372 MHz 4: 2336 MHz 5: 2370 MHz
           6: 1568 MHz 7: 2274 MHz 8: 2344 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:0416
           Card-2: NVIDIA GK106M [GeForce GTX 765M] bus-ID: 01:00.0 chip-ID: 10de:11e2
           Display Server: x11 (X.Org 1.19.6 ) drivers: intel (unloaded: nvidia) Resolution: 1920x1200@59.95hz
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile
           version: 4.5 Mesa 17.3.5 (compat-v: 3.0) Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:8c20
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0 chip-ID: 8086:0c0c
           Sound: Advanced Linux Sound Architecture v: k4.15.4-2-MANJARO
Network:   Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx port: 3000 bus-ID: 08:00.0 chip-ID: 1969:e091
           IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: f0:1f:af:6f:62:f9
           Card-2: Qualcomm Atheros AR9462 Wireless Network Adapter
           driver: ath9k bus-ID: 0a:00.0 chip-ID: 168c:0034
           IF: wlp10s0 state: up mac: 34:23:87:5e:94:77
Drives:    HDD Total Size: 750.2GB (78.2% used)
           ID-1: /dev/sda model: WDC_WD7500BPKX size: 750.2GB serial: WD-WX41A93N0625
Partition: ID-1: / size: 46G used: 35G (82%) fs: ext4 dev: /dev/sda7
           ID-2: /home size: 42G used: 30G (76%) fs: ext4 dev: /dev/sda9
           ID-3: swap-1 size: 17.20GB used: 0.00GB (0%) fs: swap dev: /dev/sda8
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 246 Uptime: 2:25 Memory: 3712.8/15925.0MB Init: systemd v: 237 Gcc sys: 7.3.0
           Client: Shell (zsh 5.4.2 running in konsole) inxi: 2.3.56

I’m using the video-hybrid-intel-nvidia-bumblebee driver, since I installed Manjaro, 8 month ago.

I use my laptop with an external monitor of 1900x1200. When the monitor is connected I turn off the laptop display, and only use the external monitor.
I detected the problem, because I had to disconnect the monitor to move to another room. Then, when I restart the laptop the resolution was half of the FHD. The login screen seems to be in FHD resolution, but after login everything is half FHD resolution and there is no way to increase the resolution in the System Setting > Monitor.

What should I try?

Same error here causing GPU to stay ON at startup:

$ dmesg | grep -i bbswitch
[    9.618571] bbswitch: version 0.8
[    9.618576] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    9.618580] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[    9.618687] bbswitch: detected an Optimus _DSM function
[    9.618693] bbswitch: device 0000:01:00.0 is in use by driver 'nvidiafb', refusing OFF
[    9.618694] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on

# I run **$ optirun echo** then:
[   21.684179] bbswitch: disabling discrete graphics

After adding blacklist nvidiafb in /etc/modprobe.d/mhwd-nvidia.conf

$ dmesg | grep -i bbswitch
[   10.422224] bbswitch: version 0.8
[   10.422229] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[   10.422234] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[   10.422335] bbswitch: detected an Optimus _DSM function
[   10.422406] bbswitch: disabling discrete graphics
[   10.500110] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is off

Graphic setup:

Graphics:  Card-1: Intel HD Graphics 530 bus-ID: 00:02.0
           Card-2: NVIDIA GM204M [GeForce GTX 970M] bus-ID: 01:00.0

It also seems to cause crash on other laptops: https://bugs.archlinux.org/task/57578

@philm
So maybe blacklist nvidiafb should be added in /etc/modprobe.d/mhwd-nvidia.conf ?

1 Like