[Stable Update] 2018-02-03 - Kernels, LibreOffice, Browsers, Thunderbird, PHP, Haskell

update
stable

#61

Hi @philm,
Why don’t you use vte3 package version from Archlinux? In Manjaro this package version is pre-release. I requests from tilix developer that make new release for transparent issue fix. However, it is not needed.


#64

Thank You…It just Work Perfectly…!
@TomaszGasior awesome job…this is only i just wanted… :hugs:


#65

Kernel: 4.14.16-1-MANJARO x86_64 - Desktop: Xfce 4.12.4 - 4.4.0 NVIDIA 340.106

No Problems. Congratulations and thanks to the Manjaro-Team!


#66

I waited till this update; the previous one was getting me nervous… well, it’s got all well, afaik, so thank you all!


#67

A post was merged into an existing topic: Tilix background is transparent


#68

I had trouble to add my printer (Canon Pixma MG4120) on Manjaro Cinnamon 17.1.4 with Print settings. It is automatically detected by Print Settings, but when I try to add it by clicking on the name of my printer, I always get this error.

Here are the last entries of /var/log/cups/error_log log file.

E [04/Feb/2018:20:58:30 -0500] [cups-deviced] PID 5959 (gutenprint52+usb) stopped with status 1!
E [04/Feb/2018:20:58:44 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [04/Feb/2018:20:58:47 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [04/Feb/2018:20:58:47 -0500] copy_model: empty PPD file
E [04/Feb/2018:20:58:47 -0500] [Client 118] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MG4100-series) from localhost
E [04/Feb/2018:20:58:47 -0500] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats.
E [04/Feb/2018:20:58:47 -0500] copy_model: empty PPD file
E [04/Feb/2018:20:58:47 -0500] [Client 122] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MG4100-series) from localhost

Using the cups-filers-driverless 1.19.0-1 (which is a package made by Stefano a while back to test out Solus patch for cups-filters, it should be named differently but whatever) package solved my issue. The printer is automatically detected, I can add it by selecting my printer (it uses driverless by default, and it doesn’t allow you to select a driver at all before adding the printer) and then configure it as I want after (I prefer to use Gutenprint than driverless). Thus, there might be something weird introduced with cups-filters 1.20.0-1. However, I would prefer to keep cups-filters than use cups-filters-driverless.

If I use the ipp address showed by Print Settings when I select my printer, then paste it in “Enter URI”, then manually select driverless for my MG4100, I get the exact same error than before : server-error-internal-error. However, if I do the same steps, but manually select Gutenprint instead of driverless (which is what I want anyway, but when I use automatic detection of my printer, it automatically selects driverless and I can’t change that before I add the printer), I can add my printer and send print jobs to it without any problem. Therefore, since I only have trouble when I try to add my printer using driverless and I don’t have any trouble when I try to add my printer using Gutenprint, I definitely think the new cups-filters package introduced a regression.
sys-config-printer-ipp-address
sys-config-printer-ipp-address-2
sys-config-printer-ipp-address-3
I have no idea if it affects other printers too.


[Testing Update] 2018-02-21 - Plasma, QT5, Kernel v4.16, Mesa, LibDRM, Haskell, Python
[Testing Update] 2018-02-23 - Kernels, Systemd, Haskell, Python
[Testing Update] 2018-02-28 - Kernels, Mesa, Browser, Haskell, Python
[Testing Update] 2018-02-13 - Kernels, LibreOffice, Systemd, Firefox Dev
[Testing Update] 2018-02-08 - Kernels, Browsers, Plasma, GCC, Nvidia, Systemd
Community Editions Update 17.1.2 >3 >4 (Cinnamon, Deepin, i3)
[Testing Update] 2018-02-14 - Kernels, Plasma, KDE Framework, Themes
[Testing Update] 2018-02-15 - Kernels, Firefox Dev, Bluez, Haskell, Python
#69

Hm. Anyone else have this issue? Ideas anyone? @Ste74 ?


#70

Update on 10 Machines without problems.

DK3


#71

Did you run the cups command the update output suggested?


#72

Oxygen icons in Libreoffice are lost. I found a solution here:
https://dnimruoynepo.blogspot.de/2017/08/how-to-add-oxygen-icon-set-to.html
But how can I store the icons in my home directory so that they are still usable after the next update?


#73

No issues on laptop with kernel415.
Was a little worried when I saw:
warning: dependency cycle detected:
warning: freetype2 will be installed before its harfbuzz dependency
But, doing a ‘yaourt freetype’ check confirmed that I did NOT have an aur version of ‘freetype’ so I ignored the warning and everything seems good.


#74

I use the Cinnamon Edition and Synapse no longer seems to work. I found this: https://bugs.launchpad.net/synapse-project/+bug/1747188
The link says it’s been flagged as “invalid”.


#75

@pepito @oberon … my package is at 1.19 version probably is this the difference … i can update this to 1.20 ( if for solus work i don’t understand why not work for us :rage: ) to see but since i don’t have a wifi or lan printer i can’t trace this issue … in arch forum i found this … maybe possible cause ?
https://bbs.archlinux.org/viewtopic.php?id=234180


#76

This appears to be due to the patch included by Arch to make 0.2.99.2 build with the newer Vala 0.38. There’s a new upstream release today (0.2.99.3) which fixes it properly.

It’s flagged as out-of-date in Arch so a new build will filter through as normal. Given this is a package I use and that it is currently broken I’ll build and upload a fixed version for each branch.

Edit:

Packages uploaded, check your mirrors.


#77

A post was split to a new topic: CUPS error “NT_STATUS_ACCESS_DENIED”


#78

@jonathon Thanks…it’s now working!!


#79

My CUPS still don’t working, evn though I changed the permissions. I don’t know what else I can do.


#80

3 posts were split to a new topic: Ffmpeg0.10: installing libx264 breaks dependency


#82

I also can’t print on Canon printer but when I chose the same driver in printer settings it works.


#84

Note: this update seems to have FIXED the problem of the touchpad freezing after waking up from standby (with kernel 4.14 - this issue affected a few of us). COOL!