[Stable Update] 2018-01-26 - Extramodules, Nvidia, Wine, Haskell, Python

update
stable

#1

Hi community,

with this we updated most of our extramodules, especially for linux415 series, updated nvidia to v340.106, released Wine v3.0 and had the usual Haskell and Python rebuilds/updates.

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.52
  • linux318 3.18.92 [EOL]
  • linux41 4.1.48
  • linux44 4.4.112
  • linux49 4.9.77
  • linux412 4.12.14 [EOL]
  • linux413 4.13.16 [EOL]
  • linux414 4.14.14
  • linux415 4.15-rc8
  • linux-RT-LTS 4.9.76_rt61
  • linux-RT 4.11.12_rt16

Package Updates (Sun Jan 21 08:55:07 CET 2018)

  • stable community x86_64: 150 new and 147 removed package(s)
  • stable core x86_64: 7 new and 7 removed package(s)
  • stable extra x86_64: 48 new and 46 removed package(s)
  • stable multilib x86_64: 5 new and 5 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-19           2018-01-26
-------------------------------------------------------------------------------
                          hibernator                0.3-1                0.4-1
                               hyper   1:2.0.0.canary.9-1  1:2.0.0.canary.10-1
                            jwmtools             0.1.78-1                    -
   linux-rt-lts-manjaro-nvidia-340xx            340.104-6            340.106-1
       linux-rt-manjaro-nvidia-340xx            340.104-4            340.106-1
               manjaro-architect-dev  0.9.3.r9.g971a3e0-1 0.9.4.r14.gaa24cce-1
            manjaro-gnome-maia-theme           20171118-1           20180118-1
                          mate-tweak            18.04.1-1            18.04.2-1
                           menulibre              2.1.3-2              2.1.4-1
                               pacui                1.8-1                1.9-1
                  purple-hangouts-hg  r287.574c112aa35c-1                    -
                 purple-skypeweb-git20160710.1.1.32.g32b8255-1               -
                     purple-whatsapp              0.9.0-2                    -
                               sndio           20161106-1           20180120-1
                           timeshift             v17.11-1              v18.1-1
                        xdgmenumaker                1.1-1                1.4-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-19           2018-01-26
-------------------------------------------------------------------------------
                              ccache              3.3.4-2              3.3.5-1
                               cgrep             6.6.22-1             6.6.22-2
                          codeblocks             16.01-11              17.12-1
                               darcs   2.12.5.20170909-22   2.12.5.20170909-23
                            deja-dup               36.3-2               36.3-3
                              devede             4.8.11-1             4.8.11-2
                              dtools            2.078.0-1            2.078.0-2
                              elixir              1.5.3-1              1.6.0-1
                              eslint             4.15.0-1             4.16.0-1
                            flashrom                1.0-1                1.0-2
                     geoip2-database           20171128-1           20180119-1
                    gimp-plugin-gmic              2.1.8-2              2.1.9-2
                           git-annex        6.20180112-15        6.20180112-17
                              gitlab             10.3.4-1             10.3.5-1
                                gmic              2.1.8-2              2.1.9-2
                                gmtk              1.0.9-3              1.0.9-5
                       gnome-mplayer              1.0.9-4              1.0.9-5
                              gramps            2:4.2.6-1            2:4.2.6-2
                               guake             0.8.12-1   3.0.2+6+ge9df754-1
                               gwget             1.0.4-10             1.0.4-11
                 haskell-adjunctions               4.3-41               4.3-42
                    haskell-checkers            0.4.9.5-1            0.4.9.5-2
                     haskell-concise            0.1.0.0-5            0.1.0.0-6
                         haskell-dav            1.3.1-194            1.3.1-195
                         haskell-dns             3.0.0-17             3.0.0-18
                      haskell-either                  5-3                  5-4
                        haskell-free            4.12.4-41            4.12.4-42
                      haskell-hakyll          4.10.0.0-34          4.10.0.0-36
                    haskell-hopenpgp            2.5.5-142            2.5.5-143
                       haskell-http2             1.6.3-15             1.6.3-16
   haskell-insert-ordered-containers           0.2.1.0-38           0.2.1.0-39
                        haskell-jose           0.6.0.3-11           0.6.0.3-12
              haskell-kan-extensions             5.0.2-11             5.0.2-12
                        haskell-keys              3.11-45              3.11-46
                        haskell-lens             4.15.4-8             4.15.4-9
                  haskell-lens-aeson             1.0.2-19             1.0.2-20
                     haskell-pointed                 5-47                 5-48
                    haskell-psqueues            0.2.4.0-3            0.2.5.0-1
                      haskell-rebase              1.2.2-3              1.2.2-4
                    haskell-reducers             3.12.2-6             3.12.2-7
                    haskell-rerebase              1.2.1-3              1.2.1-4
               haskell-semigroupoids              5.2.1-8              5.2.2-1
              haskell-servant-server              0.12-26              0.12-27
             haskell-servant-swagger             1.1.4-16             1.1.4-17
                       haskell-store           0.4.3.2-36           0.4.3.2-37
                    haskell-swagger2                2.2-7                2.2-8
                 haskell-tasty-rerun              1.1.8-5              1.1.8-6
         haskell-tls-session-manager            0.0.0.2-6            0.0.0.2-7
                    haskell-trifecta           1.7.1.1-21           1.7.1.1-22
            haskell-vector-instances               3.4-24               3.4-25
              haskell-wai-app-static          3.1.6.1-124          3.1.6.1-125
          haskell-wai-handler-launch            3.0.2.3-8            3.0.2.3-9
                        haskell-warp            3.2.13-14            3.2.13-15
                    haskell-warp-tls             3.2.4-35             3.2.4-36
            haskell-wl-pprint-extras           3.5.0.5-21           3.5.0.5-22
          haskell-wl-pprint-terminfo           3.7.1.4-21           3.7.1.4-22
                      haskell-xcffib             0.5.1-51             0.5.1-52
                       haskell-yesod            1.4.5-157            1.4.5-158
                  haskell-yesod-auth            1.4.21-35            1.4.21-36
                  haskell-yesod-core          1.4.37.2-26          1.4.37.2-27
               haskell-yesod-default            1.2.0-229            1.2.0-230
                  haskell-yesod-form            1.4.16-52            1.4.16-53
            haskell-yesod-persistent             1.4.3-34             1.4.3-35
                haskell-yesod-static           1.5.3.1-61           1.5.3.1-62
                  haskell-yesod-test           1.5.9.1-17           1.5.9.1-18
                 haskell-zip-archive            0.3.1.1-5              0.3.2-1
                         hledger-api               1.5-19               1.5-21
                         hledger-web               1.5-19               1.5-20
                              hoogle            5.0.14-32            5.0.14-33
                      hopenpgp-tools            0.19.5-46            0.19.5-47
                                iasl           20170929-1           20180105-1
                               idris              1.2.0-7              1.2.0-8
     intellij-idea-community-edition         2:2017.3.2-1         2:2017.3.3-1
                           irssi-otr              1.0.2-3              1.0.2-4
                          irssi-xmpp               0.54-1               0.54-2
                                jmol            14.28.2-1            14.28.3-1
                             krename              4.0.9-8            4.90.90-1
                   krita-plugin-gmic              2.1.8-2              2.1.9-2
                        libmaxminddb              1.3.1-1              1.3.2-1
                   libretro-nestopia                851-1                867-1
                          mmdblookup              1.3.1-1              1.3.2-1
                             mypaint              1.2.1-4              1.2.1-5
                             openttd              1.7.1-2              1.7.2-1
                              pandoc             2.0.6-17             2.0.6-18
                     pandoc-citeproc          0.12.2.5-18          0.12.2.5-19
                     pandoc-crossref            0.3.0.1-5            0.3.0.1-6
                              pifpaf              2.0.1-1              2.0.2-1
                          pigeonhole              0.5.0-2            0.5.0.1-1
                              pitivi               0.99-2               0.99-4
                           postgrest            0.4.4.0-7            0.4.4.0-9
                            powerdns              4.0.5-3              4.1.0-2
           pycharm-community-edition           2017.3.2-1           2017.3.3-1
                      python-aiohttp              2.3.6-1              2.3.9-1
                        python-boto3             1.5.18-1             1.5.19-1
                    python-braintree             3.39.1-1             3.40.0-1
                        python-bsddb              6.2.5-1              6.2.5-2
                      python-certifi          2017.11.5-1          2018.1.18-1
                        python-cliff             2.10.0-1             2.11.0-1
                   python-hypothesis            3.44.16-1            3.44.18-1
                    python-multidict              3.3.2-1              4.0.0-1
                        python-raven              6.4.0-1              6.5.0-1
               python-setuptools-scm             1.15.6-1             1.15.7-1
                       python-sphinx              1.6.5-2              1.6.6-1
                     python-werkzeug               0.14-1             0.14.1-1
                         python-yarl             0.18.0-1              1.0.0-1
                   python2-braintree             3.39.1-1             3.40.0-1
                       python2-bsddb              6.2.5-1              6.2.5-2
                     python2-certifi          2017.11.5-1          2018.1.18-1
                       python2-cliff             2.10.0-1             2.11.0-1
                  python2-hypothesis            3.44.16-1            3.44.18-1
                      python2-pifpaf              2.0.1-1              2.0.2-1
                       python2-pyrtf               0.45-1               0.45-2
                       python2-raven              6.4.0-1              6.5.0-1
              python2-setuptools-scm             1.15.6-1             1.15.7-1
                      python2-sphinx              1.6.5-2              1.6.6-1
                    python2-werkzeug               0.14-1             0.14.1-1
                              reaver              1.6.3-1              1.6.4-1
                                rust           1:1.22.1-1           1:1.23.0-2
                           rust-docs           1:1.22.1-1           1:1.23.0-2
                               stack             1.6.3-36             1.6.3-38
                sugar-activity-clock                 19-1                 20-1
                       syncthing-gtk          1:0.9.2.7-1          1:0.9.2.7-3
                              sysdig             0.19.1-3             0.20.0-1
                      tamarin-prover             1.2.2-60             1.2.2-61
                         uboot-tools            2017.07-1            2018.01-1
                             unbound              1.6.7-3              1.6.8-1
                virtualbox-guest-iso              5.2.6-1              5.2.7-1
                      wireguard-dkms       0.0.20171221-1       0.0.20180118-1
                     wireguard-tools       0.0.20171221-1       0.0.20180118-1
                          youtube-dl         2018.01.14-1         2018.01.18-1
                                zart              2.1.8-2              2.1.9-2
                        gst-validate                    -             1.12.4-1
                 perl-module-install                    -               1.19-1
                perl-module-scandeps                    -               1.24-2
                      perl-test-file                    -              1.443-1
                      perl-test-utf8                    -               1.01-1
                         python-perf                    -              1.5.1-1
                        python2-perf                    -              1.5.1-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-19           2018-01-26
-------------------------------------------------------------------------------
                      linux-firmware   20180104.65b1c68-1   20180119.2a713be-1
                      linux415 4.15.r180118.gdda3e15-1 4.15.r180121.gd517bb7-1
              linux415-headers 4.15.r180118.gdda3e15-1 4.15.r180121.gd517bb7-1
                       mhwd-catalyst      1:15.201.1151-1      1:15.201.1151-2
                   mhwd-nvidia-340xx            340.104-1            340.106-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-19           2018-01-26
-------------------------------------------------------------------------------
                              gnutls             3.5.16-1             3.5.17-1
                            libtasn1               4.12-2               4.13-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-19           2018-01-26
-------------------------------------------------------------------------------
                             ckbcomp              1.155-1              1.175-1
               linux316-nvidia-340xx            340.104-6            340.106-1
                      linux316-r8168          8.044.02-11           8.045.08-1
               linux318-nvidia-340xx           340.104-11            340.106-1
                      linux318-r8168          8.044.02-17           8.045.08-1
                       linux41-r8168           8.044.02-9           8.045.08-1
               linux412-nvidia-340xx            340.104-1            340.106-1
                      linux412-r8168          8.044.02-14           8.045.08-1
               linux413-nvidia-340xx            340.104-9            340.106-1
                      linux413-r8168          8.044.02-11           8.045.08-1
               linux414-nvidia-340xx           340.104-13          340.106-1.0
                      linux414-r8168          8.044.02-13           8.045.08-1
                  linux415-acpi_call           1.1.0-0.12           1.1.0-0.13
                   linux415-bbswitch             0.8-0.12             0.8-0.13
                   linux415-catalyst   1:15.201.1151-0.12   1:15.201.1151-0.13
                     linux415-nvidia       1:384.111-0.12       1:384.111-0.13
               linux415-nvidia-304xx       1:304.137-0.12       1:304.137-0.13
               linux415-nvidia-340xx         340.104-0.12         340.106-0.13
                   linux415-nvidiabl            0.88-0.12            0.88-0.13
                linux415-vhba-module        20161009-0.12        20161009-0.13
   linux415-virtualbox-guest-modules           5.2.6-0.12           5.2.6-0.13
    linux415-virtualbox-host-modules           5.2.6-0.12           5.2.6-0.13
                linux44-nvidia-340xx           340.104-20            340.106-1
                       linux44-r8168          8.044.02-33           8.045.08-1
                linux49-nvidia-340xx           340.104-20            340.106-1
                       linux49-r8168          8.044.02-41           8.045.08-1
                  nvidia-340xx-utils            340.104-3            340.106-1
                 opencl-nvidia-340xx            340.104-1            340.106-1
                linux415-ndiswrapper                    -             1.61-0.4
                      linux415-r8168                    -         8.045.08-0.2
                   linux415-tp_smapi                    -             0.41-0.2


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-19           2018-01-26
-------------------------------------------------------------------------------
                               conky             1.10.6-3             1.10.7-1
                           debugedit          4.13.0rc1-1                    -
                             doxygen             1.8.13-3             1.8.14-1
                        doxygen-docs             1.8.13-3             1.8.14-1
                                 git             2.15.1-2             2.16.0-1
                                 gjs           1:1.50.2-1           1:1.50.3-1
                      gnome-shell 3.26.2+9+ga3736d3a3-1 3.26.2+14+g64c857e3f-1
               libnautilus-extension             3.26.2-2             3.26.2-3
                              libraw             0.18.6-1             0.18.7-1
                               libuv             1.19.0-2             1.19.1-1
                              libzip              1.3.0-1              1.3.2-1
                          mutter 3.26.2+31+gbf91e2b4c-1 3.26.2+43+g77dd1bf63-1
                            nautilus             3.26.2-2             3.26.2-3
                             ocl-icd             2.2.11-1             2.2.12-1
                perl-async-interrupt               1.21-6               1.22-1
                                qpdf              7.0.0-3              7.1.0-1
                               rsync              3.1.2-8          3.1.3pre1-1
        xf86-video-intel 1:2.99.917+802+gaf6d8e9e-1 1:2.99.917+805+g26f54068-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-19           2018-01-26
-------------------------------------------------------------------------------
            lib32-nvidia-340xx-utils            340.104-1            340.106-1
           lib32-opencl-nvidia-340xx            340.104-1            340.106-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-01-19           2018-01-26
-------------------------------------------------------------------------------
                      lib32-libtasn1               4.12-1               4.13-1
                       lib32-ocl-icd             2.2.11-1             2.2.12-1
                                wine             3.0rc6-1                3.0-1

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

Known issues and solutions

This is a wiki post; please edit as necessary.


GNOME shell crashes

It’s probably an issue with an extension which needs to be updated. Disable them in turn until you find the one responsible.

If it’s when inserting USB drives, disable “Places Status Indicator”.


I don’t see any updates

That’s because your mirror is out of date. Run:

sudo pacman-mirrors -f 3
sudo pacman -Syyu

I get a black screen on boot or something doesn’t work

That’s probably because you have a partial set of updated packages. Switch to a text console using CTRL+ALT+F2, log in, then run the commands above.


An AUR package is stopping the update because of a conflict

Remove the AUR package, update, then reinstall the AUR package.


An AUR package says a key is invalid

You need to add the key to your keychain. Do a search of the forum, the answer has already been posted (several times :wink:).



How to Update to Electrum 3.0.5?
#3

When i checked for update, pacman says nothing to do.


#4

Update your mirrors @Maggie …

sudo pacman-mirrors -f0

No issues here so far. XFCE edition.


#5

Thanks for the help, updated without any issues KDE edition.


#6

Small update. Only 18 packages for me. :slight_smile:


#7

Any specific reason why only virtualbox-guest-iso gets an update to 5.2.7 and not virtualbox itself or the kernel module packages?, which are still at 5.2.6 after this update? Doesn’t matter much, but just curious.


#8

From the Arch update message.

Due to their boked release Oracle recommends to use a testing version:

Important: The Guest Additions which come with VirtualBox 5.2.6 and 5.1.32 do not work properly on Linux guests with 3D enabled.

https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/virtualbox-guest-iso&id=737e9ba154774921fba750d0d9b4ea066c24e5cc


#10

No Problems here.

With the extramodules of kernel 4.15 now is this issue solved:

Thanks to all
regards
caho


#11

4.15 runs great, finally got the missing r8168 driver, very happy camper!!


#12

@philm

Please add Firefox 58, Kernel 4.14.15 and 4.15-rc9. Thanks.


[Testing Update] 2018-01-26 - Kernels, Firefox, XFCE-Settings, GCC, Mesa, Haskell
#13

No issues, always checking mirrors before update(with vpn, changing uuid…)
Also, no need for -Syyu, -Syu is enough(as long as the branch is same, aka stable), or -Sy with pacman and -Su with powerpill(mutithreaded download).
That’s it :slight_smile:


#14

Hi !
It rolls !
No probs with KDE 64 and Nvidia non-free.

Many thanks !


#15

No WLAN after update apparently because of a version issue for iwlwifi in linux-firmware.


Any idea how to fix this?


#16

Gnome-shell doesn’t work properly after update in my computer. What are the following notes in gnome logs? Before I didn’t see them.


#17

@Phenyl @jeyhunn Can we assume you’ve tried the update steps in the Known Issues post?


#18

I updated using -Syyu if it’s what you’re asking :slight_smile: . For the rest, it doesn’t really match with my problem.

What I can see so far is that the module requests iwlwifi-8000C-34.ucodewhich exists in /lib/firmware/ and the kernel says “maximum version supported: iwlwifi-8000C-34”. So it should not be a problem. However direct load fails with error code 22 (bad argument?).


#19

Hello
How do I solve this:


and this:
networkmanager

thanks.


#20

@bardo I don’t understand the first one. For the second one, run:

sudo chmod 700 -R /etc/NetworkManager/system-connections/

#21

Partly; did you also update your mirror list to make sure you have fully up-to-date package lists?


@bardo Somehow your installed menulibre package is “newer” than the one in the repo (technical detail: it has an epoch in the version number); switch to the repo version with

sudo pacman -Syuu menulibre