[Stable Update] 2018-01-19 - Kernels, KDE Apps & Framework, Browsers, Virtualbox, Systemd, Mesa

update
stable

#6

Got this:
error: failed to commit transaction (conflicting files)
snapd: /snap exists in filesystem
snapd: /usr/share/dbus-1/services/io.snapcraft.Launcher.service exists in filesystem
Errors occurred, no packages were upgraded.

I had to remove snapd to upgrade.


#7

After the update, when suspending the system Gnome shell (Xorg) crashes then turns off the screen. When I turn on the desktop is not locked up as usual and I can use the computer without the need of a password.

Any other file I can provide to help?

EDIT: Fixed by uninstalling the Arc menu extension.

Thanks


#8

you must REBOOT after UPDATE not RESUME !


#9

Thanks, but rebooted twice already same result.


#10

I was told on a group to run
grep . /sys/devices/system/cpu/vulnerabilities/*
to test for the Meltdown & Spectre fix but it returned No such file or directory. Am I misunderstanding that Manjaro Stable update has applied this?


#11

Our effort and all the needed information about the new security risk can be found here. You may install spectre-meltdown-checker


#12

Ran 2 tests & same result. Simple question is it activated for STABLE branch? If so what should I do? Checked the link & so much info is confusing.

EDIT - the update announce wasn’t working until I ran the update via the terminal (last updated a couple of days ago) & 89 updates were there. All done & command works now to show patch in place. Yes I should have spotted the update was 19th - my bad :roll_eyes:


#13

Running KDE desktop on kernel 4.14.14-1. Smooth update after rebooting.

However, same niggle as the last time, albeit nothing drastic as such: Octopi Notifier is still not functioning, it only flashes red after synchronizing directly through Octopi itself.

Thanks for the update Manjaro Team - you guys have been pushing hard since December!


#14

On my installation the 2018-01-07 update wasn’t shown by Octopi Notifier, but this update was.


#16

No issues noticed. 3x XFCE systems kernels 4.14 on all. :+1:


#17

Super smooth on my end, same ol same ol :smiley:


#18

Octopi is working for me now, although it’s still not notifying me of AUR only updates. Pamac however, has still not notified me of today’s update.


#19

Smooth update xfce 4.14. Ongoing congratulations to Manjaro team. :clap:

(Very much like the new power icon on the panel. :smiley:)


#20

Updated xfce 4.14 kernel. Perfect. :ok_hand:


#21

Greg Kroah-Hartman mentioned that command in his blog post, but I don’t think it works on all distros.

There is alternate command,

grep -q "cpu_insecure\|cpu_meltdown\|kaiser" /proc/cpuinfo && echo "patched :)" \ || echo "unpatched :("

But even this will give the wrong result on an older kernel. The best thing to do right now is to check posts on every distro’s blog/forum. @philm mentioned the link in his post above. spectreattack.com does provide some useful info as well.


#22

All seemed to work smoothly for me, but like Frenchy, I didn’t get a ‘red’ Octopi until I did a sync (so thanks for that tip lol). I was kind of waiting for it to show up until I saw Frenchy’s notification. Seems fine after the reboot.


#23

It worked great AFTER the update & restart.


#24

I had to remove snapd-git in order to proceed.


#25

Did the update in my laptop and I don’t get a working network connection.
I did what @philm wrote in the first post:

sudo pacman -U https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.10.0-1-x86_64.pkg.tar.xz

and marked networkmanager to not be updated in /etc/pacman.conf.
After reboot the wireless connection does not come up and I see a pop-up message saying no secrets were supplied. Clicking the network icon in the panel and connecting manually works all the time.
In other words the credentials are known but they are not supplied when mounting the network automatically.


#26

All updates works fine, but I have not network with kernel 4.15 - look there
https://forum.manjaro.org/t/no-network-with-kernel-415/38665

regards
caho