[Stable Update] 2017-12-23 - Kernels, KDE-Apps, Cinnamon, Deepin, Xorg, LibreOffice

update
stable

#1

Hi community,

Normally you calm down a little in December, however it is a little busy for us getting Manjaro v17.1 ready before ending this year. So with this update you get new install medias to try out. Also we worked on improving our graphical installer and also ship the architect installer with our v17.1-rc2 medias.

We mostly worked on the network issue we had with the e1000e Intel driver for linux318, linux44, linux49 and linux414 kernel series. Also some JADE patches went into our new desktop environment. Cinnamon got usual updates, Firefox-Developer-Edition got added and VirtualBox got upgraded.

KDE fans will love the new Apps v17.12. Also we ship now QT v5.10. Calamares recognizes now existing LVM volumes and is able to install on them now. We fixed some small things in Mesa v17.3 and updated Haskell and Python as usual.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.51
  • linux318 3.18.89 [EOL]
  • linux41 4.1.48
  • linux44 4.4.107
  • linux49 4.9.71
  • linux412 4.12.14 [EOL]
  • linux413 4.13.16 [EOL]
  • linux414 4.14.8
  • linux415 4.15-rc3
  • linux-RT-LTS 4.9.68_rt60
  • linux-RT 4.11.12_rt16

Package Updates (Sat Dec 23 09:57:11 CET 2017)

  • stable community x86_64: 564 new and 456 removed package(s)
  • stable core x86_64: 41 new and 41 removed package(s)
  • stable extra x86_64: 801 new and 816 removed package(s)
  • stable multilib x86_64: 24 new and 24 removed package(s)

A detailed list of package changes can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2

Known issues and solutions

this is a wiki post; please edit as necessary


A thing stopped working after I upgraded the kernel

Reboot!


gdm doesn’t behave as expected

If you saw

warning: /etc/gdm/PostLogin/Default installed as /etc/gdm/PostLogin/Default.pacnew

during the update then you have a .pacnew that needs merging.



#3

OK, Manjaro XFCE :wink:


#4

Ok on KDE-edition.


#5

So, firefox-developer-edition is now in Arch’s community. Not sure how to feel 'bout it

I wonder how often it will be updated.


#6

yeah… thats so “uhm?”


#7

Smooth Update on Manjaro Gnome. Thanks…


#8

Another smooth update here. Many thanks to the Manjaro team! :smiley:


#9

So what about e1000e problem? https://bugzilla.kernel.org/show_bug.cgi?id=198047 they say there is a patch and it works, did you apply it to your kernel builds?


#10

Update went okay. After first reboot I got

systemd-udevd[234]: could not read from '/sys/module/pcc_cpufreq/initstate': No such device

Message disappeared after a second reboot. - /pcc_cpufreq/ does not exist locally.

However there is now recurrent error message to another nonexistent location

avahi-daemon[328]: Failed to read /etc/avahi/services.

even though avahi-daemon.service correctly starts and works. No problem caused that I can tell (hope my log gets cleaner later). :smile:


#11

Do not think so. Still got the network problem.


#12

need to manually create “services” directory in /etc/avahi


#13

Seemed OK at first, but since this update, Handbrake is coredumping within a few seconds of starting to encode.

Since neither Handbrake itself and glibc (mentioned in the dump) were included in this update, I assume it’s another library in the update, though I can’t work out which.

Running “gdb ghb” returns:

GNU gdb (GDB) 8.0.1
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ghb...(no debugging symbols found)...done.
(gdb) r
Starting program: /usr/bin/ghb
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffe5c54700 (LWP 27412)]
[New Thread 0x7fffe5453700 (LWP 27413)]
[New Thread 0x7fffe4921700 (LWP 27415)]
[New Thread 0x7fffd7fff700 (LWP 27416)]
[New Thread 0x7fffd77fe700 (LWP 27417)]
[New Thread 0x7fffd6ffd700 (LWP 27418)]
[New Thread 0x7fffd67fc700 (LWP 27419)]
[New Thread 0x7fffd5ffb700 (LWP 27420)]
[New Thread 0x7fffd4f78700 (LWP 27422)]
[New Thread 0x7fffcffff700 (LWP 27423)]
[New Thread 0x7fffcf7fe700 (LWP 27424)]
[New Thread 0x7fffceffd700 (LWP 27425)]
[New Thread 0x7fffce7fc700 (LWP 27426)]
[New Thread 0x7fffcdffb700 (LWP 27427)]
[New Thread 0x7fffcd7fa700 (LWP 27428)]
[New Thread 0x7fffccff9700 (LWP 27429)]
[New Thread 0x7fffc7fff700 (LWP 27430)]
[Thread 0x7fffc7fff700 (LWP 27430) exited]
[Thread 0x7fffd67fc700 (LWP 27419) exited]
[Thread 0x7fffcffff700 (LWP 27423) exited]
[Thread 0x7fffd77fe700 (LWP 27417) exited]
[Thread 0x7fffd6ffd700 (LWP 27418) exited]
[Thread 0x7fffce7fc700 (LWP 27426) exited]
[Thread 0x7fffd7fff700 (LWP 27416) exited]
[Thread 0x7fffe4921700 (LWP 27415) exited]
[Thread 0x7fffceffd700 (LWP 27425) exited]
[Thread 0x7fffcf7fe700 (LWP 27424) exited]
[New Thread 0x7fffceffd700 (LWP 27432)]
[New Thread 0x7fffcf7fe700 (LWP 27434)]
[Thread 0x7fffd5ffb700 (LWP 27420) exited]
[New Thread 0x7fffd5ffb700 (LWP 27435)]
[New Thread 0x7fffe4921700 (LWP 27436)]
[Thread 0x7fffe4921700 (LWP 27436) exited]
[New Thread 0x7fffe4921700 (LWP 27437)]
[New Thread 0x7fffd7fff700 (LWP 27438)]
[New Thread 0x7fffce7fc700 (LWP 27439)]
[New Thread 0x7fffc77fe700 (LWP 27440)]
[New Thread 0x7fffc6ffd700 (LWP 27441)]
[New Thread 0x7fffc67fc700 (LWP 27442)]
[New Thread 0x7fffc5ffb700 (LWP 27443)]
[New Thread 0x7fffc57fa700 (LWP 27444)]
[New Thread 0x7fffc4ff9700 (LWP 27445)]
[New Thread 0x7fff8bfff700 (LWP 27446)]
[New Thread 0x7fff8b7fe700 (LWP 27447)]
[New Thread 0x7fff8affd700 (LWP 27448)]
[New Thread 0x7fff8a7fc700 (LWP 27449)]
[New Thread 0x7fff89ffb700 (LWP 27450)]
[New Thread 0x7fff897fa700 (LWP 27451)]
[New Thread 0x7fff88ff9700 (LWP 27452)]
[New Thread 0x7fff887f8700 (LWP 27453)]
[New Thread 0x7fff87ff7700 (LWP 27454)]
[New Thread 0x7fff877f6700 (LWP 27455)]
[New Thread 0x7fff86ff5700 (LWP 27456)]
[New Thread 0x7fff867f4700 (LWP 27457)]
[New Thread 0x7fff85ff3700 (LWP 27458)]
[New Thread 0x7fff857f2700 (LWP 27459)]
[New Thread 0x7fff84ff1700 (LWP 27460)]
[New Thread 0x7fff847f0700 (LWP 27461)]
[New Thread 0x7fff83fef700 (LWP 27462)]
[New Thread 0x7fff837ee700 (LWP 27463)]
[New Thread 0x7fff82fed700 (LWP 27464)]
[New Thread 0x7fff827ec700 (LWP 27465)]
[New Thread 0x7fff81feb700 (LWP 27466)]

Thread 45 "ghb" received signal SIGABRT, Aborted.
[Switching to Thread 0x7fff857f2700 (LWP 27459)]
0x00007ffff21a1860 in raise () from /usr/lib/libc.so.6
(gdb) bt full
#0  0x00007ffff21a1860 in raise () at /usr/lib/libc.so.6
#1  0x00007ffff21a2ec9 in abort () at /usr/lib/libc.so.6
#2  0x00007ffff21e4437 in __libc_message () at /usr/lib/libc.so.6
#3  0x00007ffff227492f in __fortify_fail_abort ()
    at /usr/lib/libc.so.6
#4  0x00007ffff22748f2 in  () at /usr/lib/libc.so.6
#5  0x000000000049c95f in  ()
#6  0x0000000000000000 in  ()
(gdb) q
A debugging session is active.

        Inferior 1 [process 27408] will be killed.

Quit anyway? (y or n) y

#14

terminal update went fine, but gnome autologin does not work anymore. i had to delete /etc/gdm/postlogin/default in order to get it working again.


#16

I don’t have problems with e1000e anymore (Kernel 4.14.8 and 4.9.71)


#17

Not delete it… Better open the default file and comment the line. If you only delete it At the next update it show again…


#18

No more network problems (e1000e) since kernel 4.14.8-1. Even after waking up from suspend-mode is now properly connected to the network again.


#19

Manjaro Cinnamon updated fine on 2 laptops.


#20

ok, thanks.

but when commented, the black screen (right before entering the desktop) flickers multiple times, which is kind of annoying…

anything else i can do to reach the state before this very update (black screen - login screen wallpaper - desktop)?


RPG Maker MV & Dialog Window Crash(libQT5Core.so.5)
#21

Manjaro XFCE , looks OK after the upgrade, thank you.