[Stable Update] 2017-12-16 - Kernels, Mesa, Deepin, Firefox, Python, Haskell

I love learning this cool handy stuff – thanks!

1 Like

You are welcome

SF: Have you found that more frequent releases helps build up your community of users?
PM: We release when needed. We can release more often, but then it would be just a monthly release and therefore pushing and working on specific features will not get the needed attention to get it done best.

3 Likes

Why the “Jade-Application-Kit” and not use a utility like ICE? This would not only allow the user to easily adjust which browser the \webapp\ uses for any particular site, but it also allows them to create and edit any of their choice easily. Seems like it would have been more useful. Otherwise great update!

Me, too. Deepin is completely broken now! The menu items don’t autohide, left clicking onto panel items freezes the Window Manager and never unfreezes, it’s unusable right now.

any idea when firejail will be updated to 0.9.52, the latest update? The previous update is from october and this system update seems to have made kodi and firefox not function properly when run via firejail anymore, so I had to disable it for now. Hoping the new firejail version will have some updated profiles for these applications.

1 Like

Here are my commentaries about the XFCE release candidate.

The following command clears the cache but keeps the latest two versions (currently installed and previous):

sudo paccache -rvk2

7 Likes

Thanks @jonathon. I installed all the gstreamer 0.1 packages and the update was successful

In my Manjaro Gnome I have only that cursor problem, but I change cursor theme and it’s OK. On Deepin I have few problems also. My deepin panel in efficient mode is not in the top like it should be:


I can’t close settings panel or wallpapers panel (and can’t scroll them by mmb).

1 Like

Oh @Bertie, thank you; that’s a FANTASTIC compromise cake-&-eat-it solution. Very nice.

If life were that simple, it would have been caught and dealt with by GNOME devs, or even the Arch maintainers before reaching manjaro’s extra repo. However, bugs do slip through the net at times.

the testing phase works the same way for any linux distribution and is heavily reliant on users with different hardware being able to contribute. from experience with fedora and other bleeding edge/rolling distributions, ‘stable’ is always to be taken as a relative term.

if only one person reports a very minor issue like auto-connect not working, then it isn’t going to hold back the release of a new update that provides additional benefits or vulnerability fixes that outweigh a seemingly isolated and trivial issue.

the maintainers aren’t able to predict from the report of one user how many others will be affected, so of course it will be noted but if they held back every affected update because of one user’s report of a trivial issue the distribution would never move forward.

2 Likes

Updated two machines, no issues here. Thanks Manjaro team. :slight_smile:

Ah, that’s an interesting link. In hindsight, what we have there are two issues.

The first is the e1000e which is unrelated to Network Manager.

The second (auto-connecting wifi) was solved by removing and re-adding the connection rather than downgrading the package. Yes, downgrading will work, because that makes Network Manager use the existing settings schema, but the “correct” fix is to remove and re-add the connection settings - this is a “normal”/“known” step when network connections don’t work.

1 Like

No issues on my end running Xfce and kernel 4.9.68. Still no wifi connection (realtek 8723be) possible with kernel 4.14.5 though.

No ethernet on KDE. 4.9 and 4.14

Looks like it’s pretty much a dead system now. I’ve tried two different USB wifi adapters and both of them just keep asking for the wifi password (both connect fine on my HTPC), so I can’t see anyway I’ll be getting out of this one.

I’ve got into an XFCE live USB from October (i think), and installed on a new partition, which is now working. As soon as I update packages I lose ethernet here too (just finished reinstalling again so I can at least have a working system).

1 Like

That does not work for me. I run Manjaro KDE. Removing and re-adding the connection does not solve the problem here.

3 Likes

It seems that you do not read the forum at all.

With this approach, you can stay without users

It seems that you need to take it easy and not piss off people who try their best to help.

If the Manjaro approach does not work for you please find another distro. Arch might be worth a look.

9 Likes

xps9550, KDE, smooth update.