[Stable Update] 2017-11-04 - Kernels, Gnome, Deepin, Mate, Mesa, Libreoffice

Hi community,

we worked on our profile settings for each Manjaro edition, updated our adapta-themes, libre-office, mesa and our kernels. Also released the latest deepin, gnome and mate packages. The last time reported pango issue is now properly fixed.

Issue/Regression

Seems there is an issue with libinput v1.9.1 on some laptops. The Manjaro Spitfire is not affected by this. Would be great if someone, who is affected help us to git-bisect the issue, so we may point upstream to a proper solution. We have now added some files for general testing. See also the proposed fix for linux49. On stable branch we have now downgraded to v1.8.4. We are happy for any findings from our community.

Please report back and give us feedback for given changes made to our repositories.


Current supported Kernels

  • linux316 3.16.49
  • linux318 3.18.79 [EOL]
  • linux41 4.1.44
  • linux44 4.4.96
  • linux49 4.9.60
  • linux412 4.12.14 [EOL]
  • linux413 4.13.11
  • linux414 4.14-rc7 (x86_64)
  • linux-RT-LTS 4.9.47_rt37 (x86_64)
  • linux-RT 4.11.12_rt15 (x86_64)

Package Updates (Fri Nov 3 05:54:35 CET 2017)

  • stable community i686: 256 new and 252 removed package(s)
  • stable community x86_64: 277 new and 271 removed package(s)
  • stable core i686: 22 new and 22 removed package(s)
  • stable core x86_64: 24 new and 24 removed package(s)
  • stable extra i686: 211 new and 214 removed package(s)
  • stable extra x86_64: 228 new and 231 removed package(s)
  • stable multilib x86_64: 18 new and 18 removed package(s)

Package Updates (Sat Nov 4 06:30:47 CET 2017)

  • stable community i686: 17 new and 12 removed package(s)
  • stable community x86_64: 24 new and 19 removed package(s)
  • stable core i686: 1 new and 1 removed package(s)
  • stable core x86_64: 1 new and 1 removed package(s)
  • stable extra i686: 2 new and 2 removed package(s)
  • stable extra x86_64: 2 new and 2 removed package(s)
  • stable multilib x86_64: 1 new and 1 removed package(s)

A detailed package list can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:

10 Likes

Known issues and solutions

Can be collected here; it’s a wiki post.


My HP laptop keyboard stopped working

There’s a regression in libinput=1.9.1 when used with kernel 4.9. Workarounds:

  • Downgrade to libinput 1.8.3
  • Disable hp_wmi
  • Install and use kernel 4.13

util-linux and rfkill are in conflict. Remove rfkill?

This is fine to remove; rfkill is now supplied by util-linux.


2 Likes

Everything OK in Gnome so far.

Cute video…“So worthless. The Manjaro.”

Replace rfkill with core-util-linux (Y/n)

util-linux and rfkill are in conflict. Remove rfkill?

Edit: Solved? https://bbs.archlinux.org/viewtopic.php?id=231367

Edit 2: For those that get this, follow the instructions and say YES to remove rfkill and continue on with the update.

Flawless on XFCE.

6 Likes

All OK on Samsung Laptop - 4.9 series Kernel - Manjaro MATE

# yo @ yo-gs in ~ [21:38:46] 
$ pacman -Fo /usr/bin/rfkill
usr/bin/rfkill is owned by core/rfkill 0.5-1

# yo @ yo-gs in ~ [21:38:54] 
$ pacman -Qs rfkill
local/util-linux 2.31-1 (base base-devel)
    Miscellaneous system utilities for Linux

A bit weird but rfkill is still there and working.

util-linux includes rfkill now. There is no more need for the extra rfkill package. If the rfkill package is installed, pacman will asked you to replace this packages since util-linux provide the rfkill command.

How can I see that? I get the same output like Yoy0. The binary /usr/bin/rfkill is still owned by rfkill package and util-linux does not contain any rfkill binary according to pacman -Fl util-linux.

I am confused.

Hi, after this update the keyboard of my laptop and the touchpad don’t work anymore, I can’t enter to my desktop because I can’t write my password. Also can’t enter to TTY. Only works the bright keys.

However, with Windows 7 and the live session of Manjaro I don’t have such issue.

What could I do?

Thanks!!

First do a refresh

pacman -Fy

and then

pacman -Fl util-linux | grep rfkill

The extra refresh is important, because this is a separate database. Also the mirror needs to be up to date.

And it is normal that befor you do this update, /usr/bin/rfkill is own by the package rfkill. Only after the update is /usr/bin/rfkill owned by util-linux.

I think that I’m going to reinstall again, don’t have any idea…

About compiz, with this update worked fine?

no known problems with this update. thank you manjaro team :slight_smile:

This update, with a new version of Pango, has solved this regression (Messy file display (non-uniform columns) in file manager) in Thunar on my computer.

I’ve reinstalled with the same result. As @vertebrate pointed above I think that libinput 1.9 can cause this issue. I’m going to try to install again, but before updating I’m going to install the last kernel 4.13.

I can confirm that I have the issue with kernel 4.4 and 4.9 after the last stable update.

pango 1.40.13-2 solved regression nautilus, kernel 4.9

Well, after upgrading the system with the kernel 4.13 running I can enter as always on my desktop. So, I confirm that there is a problem with libinput 1.9 and LTS kernels.

For the moment I will remain with that kernel.

I do not know if I should warn @philm about the problem…

Cheers

2 Likes

I didn’t see compiz-manjaro in the list.
I assume Compiz lovers are not a priority :sob:

1 Like

all OK

Forum kindly sponsored by