[Stable Update] 2017-10-29 - KDE, Gnome, Deepin, Firefox, Mesa, Kernels

There’s a difference between *-i686.pkg.tar.xz packages and lib32-*-x86_64.pkg.tar.xz packages. The first are 32-bit packages, the second are multilib packages. As Phil already said, multilib packages aren’t going anywhere.

2 Likes

Did I miss something?
101 Arch Linux 32 archlinux32.org
73 Manjaro Linux To Drop 32-bit Support - Phoronix phoronix.com

What’s the question?

archlinux32 is a community-run effort to build 32-bit packages for Arch Linux. Arch Linux are dropping their own 32-bit packaging efforts.

Manjaro uses Arch Linux as an upstream, so if there aren’t any 32-bit packages we can’t use them.


32-bit != multilib

multilib packages are 64-bit packages built to support 32-bit applications (e.g. Steam) running on a 64-bit OS.

3 Likes

Okay, I understand now.

so, no problems :slight_smile:

After upgrading via TTY I lost the Windows 7 entry.

sudo grub-update

no such entry

Am I dead?

Should I follow this guide:

I used then
-Ss grub | grep installed
ls /etc/grub.d/

Can boot into Win 7 now - I feel so happy!

1 Like

I don’t see the point of keeping old packages in frozen state in repos. Users will have them installed locally on their systems anyway and it’s their choice what to do next.

However Manjaro shouldn’t allow for new installations by keeping packages in repos as there won’t be any bugfixes and security updates anymore.

There could be one month delay and announcement before final delete.

2 Likes

hello, thank’s for this good job. manjaro-compiz is broken after protobuf update. Please update the manjaro-compiz package, thank’s. :wink:

I have this issue too on Thunar. File names are on one line even if they’re long, and file columns are absurdly large.

Here’s a screenshot.

This looks god awful. I hope this will be fixed really soon. It cannot seriously stay like this.

4 Likes

According to the followings posts, Pango 4.10.13 caused a regression on many DE that uses this.


Here’s the changelog for Pango : http://ftp.gnome.org/pub/gnome/sources/pango/1.40/pango-1.40.13.news

I suggest that an update is pushed on stable as soon as possible and we don’t wait for the next big update announcement.

1 Like

did not solve the problem for me. i did however create a new user. logged into the new user and enabled gnome-shell-extension-radio. plugged my mp3 stream url in, and it played. so i know it’s some config problem somewhere. i have no idea where to look for this problem. how can i narrow down where my problem is? the only thing in dconf i saw was a switch that enabled the use of the extension, and .gse-radio is just a list of the radio streams . i have no clue where to look at where exactly these extensions live so i can compare how the two users have something different with the same gnome shell extension that allows it to play the stream in one user but not the other :frowning: .

I’m all for ending i686 support (for many years) but ithink the archive should be created and maintained until support for “Gellivara” ends. After that date dump the archive and then either remove all the old i686 downloads from SourceForge or place a fairly clear warning that there is no support for any i686(32-bit) version.
That’s only 4 months for 1-yr support cycle, 16 months for 2 years since the March 2017 release of Gellivara. Not very long …
I agree with salome too that packages need to be promoted out of AUR if there is a working 64-bit version in AUR, but disagree with maintaining any 32-bit version just because there is no 64-bit.

In the same breath I’d like to see python2 go the same way as i686 Arch. I mean this hangover of v.2 now for, what?, almost 10 years, is ludicrous.

Whatever y’all decide, Thank you for all the time and hard work for Manjaro. …

What exactly is the problem?
Why don’t you create a new Post for that?

turns out; it wasn’t a problem with dconf /user. it was a corrupted ./config/pulse file. i renamed it. relogged and all my streams are playing in gnome radio …including in rhythmbox as well. thought this would be valuable information for someone else.
WE CAN CALL THIS FIXED

1 Like

Legacy tray is gone and the “Hide Legacy Tray” extension is broken. Even when I remove the “hide legacy tray” extension, the legacy tray does not appear when mouse is moved to the bottom left corner.

I think 32 bit packages should be kept in some archive, not necessarily a usable mirror, but at least on a ftp server from where someone could directly download the package.

If not for anything else, they might come useful for some archaeological study 1000 years down the line :grin:

1 Like

After this update my laptop failed to boot. It got stuck at “starting TLP” I have been running manjaro well on this laptop until this last update. I did a bunch of research and the help articles all seem to relate to nvidea graphic (or some other graphics) issue.

I have an HP Elitebook 840 G2 it has integrated graphics and these have worked fine until the new kernel.

I temporally fixed the issue by removing the new kernel and rebooting. However, I would welcome any advice. It is odd to me that although nothing about my system has changed (i.e. I am not installing on a new machine like many help articles referred to) I am just having this issue after a kernel update. After the very large update only a couple day ago everything ran smoothly. I am not sure what package the issue or if it was a kernel configuration. Other than to remove the newest kernel I have not trouble shooted much. I tried disabling the tlp service when I did it just hung at “starting graphical environment” (or something similar)

Right now I am just booting the 4.4.95 kernel from the advanced GRUB menu so I can actually access the system.

I can not remove the 4.9.59 kernel due to linux49-virtualbox-host-modules dependency. If I attempt to remove the dependency
error: failed to prepare transaction (could not satisfy dependencies)
:: virtualbox: removing linux49-virtualbox-host-modules breaks dependency 'VIRTUALBOX-HOST-MODULES’
I try to remove virtualbox-host-modules and it say no package exists. Well I am new to this so… That makes no since at all. Are we dealing with quantum bits, a package both exists and doesn’t exist? Can I time travel next? :smile:

I am running KDE the kernel 4.9.59 is installed (even though I tried several times to removed it) but it is not running. If I I am running 4.4.95 which as far as I can tell I have no issues booting, rebooting, as long as I choose advanced from GRUB and go to the last kernel. Sigh…

Thanks for any help

1 Like

There is a bug in sddm 0.16, you will need to downgrade to sddm 0.15.

Lots of posts and threads on this issue, you should always check the announcement thread prior to updating, to understand what is in the update and check if other users had any issues.

Here are instructions on how to downgrade sddm manually.

Removing or downgrading a kernel is never a good idea either, for future reference.

1 Like

Painless update, Manjaro Gnome works well, thank you for the good work. :ok_hand:
The new Manjaro Gnome wallpaper is a beauty.

Pretty nice experience that my old Thinkpad 410 runs like a doper on Gnome and Kernel 4.14.

1 Like

Smooth update of Manjaro KDE on four laptops. Thank you, Manjaro devs!

Forum kindly sponsored by Bytemark