[Stable Update] 2017-10-29 - KDE, Gnome, Deepin, Firefox, Mesa, Kernels

Hi community,

this will, most likely, be the last update for our i686 architecture. So we wonder, what we should do with this architecture in future. We already discussed within our team, to drop it for good. However, that doesn’t mean that we may also delete the current packages yet. Please tell us what you, the community think about it:

  • Archive i686 packages
  • Remove i686 packages for good, as there will be no more updates

0 voters

With this update we have fixes for KDE, Gnome and Deepin desktop environments. We updated Chromium and Firefox to their latest versions, pushed out the latest kernels, added the latest Mesa and PHP packages and rounded it up with Haskell updates.

Please report back and give us feedback for given changes made to our repositories.

Best, Philip


Current supported Kernels

  • linux316 3.16.49
  • linux318 3.18.78 [EOL]
  • linux41 4.1.44
  • linux44 4.4.95
  • linux49 4.9.59
  • linux412 4.12.14 [EOL]
  • linux413 4.13.10
  • linux414 4.14-rc6 (x86_64)
  • linux-RT-LTS 4.9.47_rt37 (x86_64)
  • linux-RT 4.11.12_rt15 (x86_64)

Package Updates (Sun Oct 29 08:59:45 CET 2017)

  • stable community i686: 278 new and 277 removed package(s)
  • stable community x86_64: 282 new and 280 removed package(s)
  • stable core i686: 17 new and 18 removed package(s)
  • stable core x86_64: 19 new and 20 removed package(s)
  • stable extra i686: 234 new and 234 removed package(s)
  • stable extra x86_64: 251 new and 251 removed package(s)
  • stable multilib x86_64: 8 new and 9 removed package(s)

Package changes can be reviewed here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:

10 Likes

A post was merged into an existing topic: Can’t bootup laptop after update, kernel crash

10 posts were split to a new topic: Messy file display (non-uniform columns) in Nautilus

Smooth update. Much :joy: for all Manjaro peeps.

Sad to see the i686 archive looks like it might not happen. :cry: Even 2 or 3 servers could go a long way but I suppose it’s the principle that matters? Good to see what peeps think. :ballot_box_with_check:

1 Like

Thank you for you support and your hard work for Manjaro :slight_smile:

I have this issue with thunar:
https://forum.manjaro.org/t/messy-file-display-non-uniform-columns-in-nautilus?source_topic_id=33669

Regarding the i686 architecture, I’m for the drop it, but maintaining the packages that haven’t a 64bit version yet, and gradually replace them with their 64bit version, if it’s possible.
A good example could be pcsxr, that it’s a 32bit package, but have a 64bit version on the aur : https://aur.archlinux.org/packages/pcsxr-git

2 Likes

@salome: we won’t drop multilib.

5 Likes

No issues updating Xfce on thinkpad T530 using Kernel: 4.9.59-1. Thanks for a beautiful distro and to the members for helping me to learn more!

3 Likes

smooth update for me. however i still have a problem with “gnome-shell-extensions-radio” . it still does not want to play mp3 streams; only acc streams. i looked on the extension page and googled around. there is nothing out there with this problem. streams i was previously able to play no longer play. and this happened with the upgrade to gnome 3.26. im wondering if this extension is even being supported anymore. its not a system problem because i can stream mp3 links from terminal, smplayer and chrome and firefox browsers. so its the extension that is broken . it wouldn’t be such a big deal, but i use this every day. unless someone else has another solution or app that works well with manjaro specifically to house internet radio url’s and play them conveniently. …or how to fix this extension problem. all i get is “stream error” . not much to go on :frowning:
everything else is fine with the updates. no issues
p.s. - i downloaded and installed rhythmbox, still no joy with playing the mp3 streams

1 Like

Try to rename the file user into .config/dconf folder and relogin… can be strange but in the past lollypop have the same error… re generate a user configuration solve the issue…

Considering the lib32 pkgs (93) and counting, I have a problem with dropping everything. What happens to the system after that?

There’s a difference between *-i686.pkg.tar.xz packages and lib32-*-x86_64.pkg.tar.xz packages. The first are 32-bit packages, the second are multilib packages. As Phil already said, multilib packages aren’t going anywhere.

2 Likes

Did I miss something?
101 Arch Linux 32 archlinux32.org
73 Manjaro Linux To Drop 32-bit Support - Phoronix phoronix.com

What’s the question?

archlinux32 is a community-run effort to build 32-bit packages for Arch Linux. Arch Linux are dropping their own 32-bit packaging efforts.

Manjaro uses Arch Linux as an upstream, so if there aren’t any 32-bit packages we can’t use them.


32-bit != multilib

multilib packages are 64-bit packages built to support 32-bit applications (e.g. Steam) running on a 64-bit OS.

3 Likes

Okay, I understand now.

so, no problems :slight_smile:

After upgrading via TTY I lost the Windows 7 entry.

sudo grub-update

no such entry

Am I dead?

Should I follow this guide:

I used then
-Ss grub | grep installed
ls /etc/grub.d/

Can boot into Win 7 now - I feel so happy!

1 Like

I don’t see the point of keeping old packages in frozen state in repos. Users will have them installed locally on their systems anyway and it’s their choice what to do next.

However Manjaro shouldn’t allow for new installations by keeping packages in repos as there won’t be any bugfixes and security updates anymore.

There could be one month delay and announcement before final delete.

2 Likes

hello, thank’s for this good job. manjaro-compiz is broken after protobuf update. Please update the manjaro-compiz package, thank’s. :wink:

I have this issue too on Thunar. File names are on one line even if they’re long, and file columns are absurdly large.

Here’s a screenshot.

This looks god awful. I hope this will be fixed really soon. It cannot seriously stay like this.

4 Likes

According to the followings posts, Pango 4.10.13 caused a regression on many DE that uses this.


Here’s the changelog for Pango : http://ftp.gnome.org/pub/gnome/sources/pango/1.40/pango-1.40.13.news

I suggest that an update is pushed on stable as soon as possible and we don’t wait for the next big update announcement.

1 Like

Forum kindly sponsored by