[Stable Update] 2017-09-30 - Timeshift, Kernels, Nvidia, JADE, Haskell, JDK9, Snap Support

update
stable

#153

deed the kernel update on Dell Precision via Octopi Console, seems to work well

cat /sys/block/sda/queue/scheduler
noop deadline cfq [bfq-sq]

PS spooke to early… getting again kernel lock randomly, back to deadline


#154

Can you tell me the exact error you get. Is it still line 790?

I updated also pamac now:

### BoxIt memo ###

User philip created a snapshot of branch 'testing' to 'stable'.

 - stable core i686:  2 new and 2 removed package(s)
 - stable core x86_64:  2 new and 2 removed package(s)
 - stable extra i686:  4 new and 4 removed package(s)
 - stable extra x86_64:  4 new and 4 removed package(s)

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-30           2017-10-04
-------------------------------------------------------------------------------
                            linux413             4.13.4-2             4.13.4-3
                    linux413-headers             4.13.4-2             4.13.4-3


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-30           2017-10-04
-------------------------------------------------------------------------------
                            linux413             4.13.4-2             4.13.4-3
                    linux413-headers             4.13.4-2             4.13.4-3


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-30           2017-10-04
-------------------------------------------------------------------------------
                               pamac              6.0.2-3              6.0.3-1
                           pamac-dev              6.0.2-3              6.0.3-1
         pamac-dev-tray-appindicator              6.0.2-3              6.0.3-1
             pamac-tray-appindicator              6.0.2-3              6.0.3-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-09-30           2017-10-04
-------------------------------------------------------------------------------
                               pamac              6.0.2-3              6.0.3-1
                           pamac-dev              6.0.2-3              6.0.3-1
         pamac-dev-tray-appindicator              6.0.2-3              6.0.3-1
             pamac-tray-appindicator              6.0.2-3              6.0.3-1

#155

4.13.4-3 seems to work here!
Removed elevator=cfq from grub, and after update-grub no more troubles with the Samsung SSD 850 Evo.


#156

Thx for your feedback. As we are still wondering what might caused it. Even upstream is not sure.


#157

well, strange behavior this time
after removing deadline from grub at first boot kernel was running very fast repeating lines from 700 hundred till 1000 something but I can read the numbers after that because to fast in changing numbers…

but after power off rebooted four or five times with no apparently problems
4.13.4-2

sorry I can’t test more now, going out all night


#158

does the patches correct this ?

i have got this on cold Boot , with UDEV rules with BFQ-SQ and DEADLINE.
there is no journalctl report in this case , only fast screenshot is possible


#159

mmh… after e fresh boot kernel problems again
now the kernel stuck at 32xxxxxxx, then jump to 61xxxxx then i power off

back again to deadline, fine now

tomorrow i will see


#160

4.13.4-3 is working fine for me with bfq-sq


#161

Experiencing random lockups after boot. I t will run fine for a few hours then freeze, have to do hard reboot… Also random disconnects of bluetooth for apple magic touchpad (1/minute). See Bluetooth crashes since updated to kernel 4.13.2. LMK what info is needed to debug and I’ll provide.

rich[~]$  inxi -Fxzc0
System:    Host: ZaManjCin Kernel: 4.9.52-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
           Desktop: Cinnamon 3.4.6 (Gtk 3.22.21) Distro: Manjaro Linux
Machine:   Device: desktop System: MSI product: MS-7823 v: 1.0 serial: N/A
           Mobo: MSI model: Z87M-G43 (MS-7823) v: 1.0 serial: N/A
           BIOS: American Megatrends v: V2.2 date: 06/07/2013
CPU:       Quad core Intel Core i7-4770 (-HT-MCP-)
           arch: Haswell rev.3 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27211
           clock speeds: max: 3900 MHz 1: 3900 MHz 2: 3899 MHz 3: 3895 MHz
           4: 3887 MHz 5: 3871 MHz 6: 3883 MHz 7: 3886 MHz 8: 3870 MHz
Graphics:  Card: NVIDIA GF108 [GeForce GT 620] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.3 ) driver: nvidia
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GT 620/PCIe/SSE2
           version: 4.5.0 NVIDIA 384.90 Direct Render: Yes
Audio:     Card-1 NVIDIA GF108 High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Bose driver: USB Audio usb-ID: 003-005
           Sound: Advanced Linux Sound Architecture v: k4.9.52-1-MANJARO
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8168 v: 8.044.02-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 14250.8GB (21.1% used)
           ID-1: /dev/sdb model: WDC_WD1002FAEX size: 1000.2GB
           ID-2: /dev/sda model: Crucial_CT120M50 size: 120.0GB
           ID-3: /dev/sdd model: M4 size: 128.0GB
           ID-4: /dev/sdc model: ST1000LM024_HN size: 1000.2GB
           ID-5: USB /dev/sde model: Expansion_Desk size: 8001.6GB
           ID-6: USB /dev/sdf model: My_Book_1230 size: 4000.8GB
Partition: ID-1: / size: 73G used: 60G (87%) fs: ext4 dev: /dev/sda2
           ID-2: /boot size: 494M used: 287M (62%) fs: ext2 dev: /dev/sda1
           ID-3: /home size: 917G used: 461G (53%) fs: ext4 dev: /dev/sdc1
           ID-4: swap-1 size: 17.82GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:78C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 346 Uptime: 5:06 Memory: 8599.8/15993.1MB
           Init: systemd Gcc sys: 7.2.0 Client: Shell (bash 4.4.121) inxi: 2.3.40

#162

4.13.4-3 seems fixed :smiley:


#163

I didn’t have any problems until yesterdays kernel update. Got some scheduler error loop at boot. Hard reset and it booted up fine this morning. Installed 4.13.4-3 this morning and it still booted fine afterwards. So far only one occurrence of the error on this kernel, yesterday. Reminded me it was time to make some backups again :grin:


#164

4.13.4-3 seems to works will see tonight
@philm
added : cold boot is ok with this version 4.13.4.3 , i use udev rules with deadline / bfq-sq


#165

THis is the last thing in journalctl for about a minute before lockup, looks like it might be something to do with vpn? Even though it is turned off.:

-- Reboot --
Oct 04 20:05:06 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:05:06 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:05:00 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:05:00 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:57 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:57 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:51 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:51 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:48 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:48 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:45 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:45 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:37 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:37 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:32 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:32 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:27 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:27 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:21 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:21 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:15 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:15 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:08 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:08 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:04:05 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821

LMK If I can provide more useful info.


#166

Problem with Emacs screen corruption as described here: https://bugs.freedesktop.org/show_bug.cgi?id=88584

(BTW: COGL_ATLAS_DEFAULT_BLIT_MODE=framebuffer in /etc/environment doesn’t make a difference.)


#167

No issues Linux49 Xfce Thinkpad T530 Evo SSD. I always read the thread - thanks everyone.


#168

VPN stopped working after these updates - the saved OpenVPN configs in /etc/NetworkManager/system-connections/ have been altered, and no longer work (no password or certificates stored). Any attempt to change these settings via the nm-settings GUI fails, as changes aren’t preserved. Giving nm-settings admin rights makes no difference.

I always do a backup using Timeshift before any updates/system changes, so I just copied the pre-update configs back to /etc/NetworkManager/system-connections/ - this works, but any attempt to change these, or add new connections via nm-settings still fails.

I doubt that I’ll need to add a new VPN connection, so not a problem for me (I’d set it up on another non-Arch install and copy over if necessary), but others will need a fix.

A limited inxi:

System:    Kernel: 4.9.52-1-MANJARO x86_64 bits: 64 Desktop: MATE 1.19.0
           Distro: Manjaro Linux
Machine:   Device: laptop System: SAMSUNG product: N/A serial: N/A
           Mobo: SAMSUNG model: N/A serial: N/A
           BIOS: Phoenix v: 03PA.M001.20110312.XW date: 03/12/2011
CPU:       Dual core Intel Core i3 M 380 (-HT-MCP-) speed/max: 933/2533 MHz
Graphics:  Card: NVIDIA GT218M [GeForce 315M]
           Display Server: N/A drivers: nouveau (unloaded: modesetting)
           tty size: 80x24
Network:   Card-1: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter
           driver: wl
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8168
Drives:    HDD Total Size: 250.1GB (27.4% used)
Info:      Processes: 188 Uptime: 1:09 Memory: 1022.2/5833.2MB Init: systemd
           Client: Shell (bash) inxi: 2.3.40

#169

what about using mq-deadline?


#170

Resolved. I said I did a hard reboot but had not. computer needed to be shut all the way down. after that I have been running without a lockup for a day or so now.


#171

Still suffering bluetooth/apple magic trackpad woes though. Bluetooth crashes since updated to kernel 4.13.2


#172

xfce4-clipman is not working now.
xfce4-clipman: error while loading shared libraries: libqrencode.so.3: cannot open shared object file: No such file or directory