[Stable Update] 2017-09-16 - Kernels, Mesa, VirtualBox, Pamac, KDE, GCC, Removal of OpenRC

update
stable

#41

Ah. AUR, yeah. Ran into the same thing.

You probably are reinstalling then, or migrating in some direction (per philm’s suggestions, or somewhere else).


#42

My system don’t start. Good.

Yours doesn’t control AUR ok, and the mirrors? Who send this updates? This appear for magic form?


#43

I think that i have time to Manjaro switch-off 32 bits in october to change the system, no in this mode.


#44

Thanks for your great works!
I get this error when I try to update:

Failed to prepare transaction:
could not satisfy dependencies:
unable to satisfy dependency 'gcc=7.2.0-2' required by gcc-fortran

#45

Try this:

sudo pacman -Sy gcc-fortran-multilib
sudo pacman -Su

#46

Pamac now have pictures! And is still fast, it leaves the other software GUI stores eating dirt.
Thanks Manjaro team, you guys rocks!


#47

It will …


#48

The message about gcc slipped by me, even though I thought I read the op carefully :stuck_out_tongue_winking_eye: smooth update after that.


#49

Thank you so much. It worked. I installed updates smoothly :slight_smile:


#50

After update I no longer had sound in some programs – most notably two favorites cantata and pithos. Sound did work for deepin-music, audacity, and opera. Strange.

Found the post below in the forum. Deleting everything in ~/.config/pulse and rebooting fixed my problem:


Sound Coming from Google Chrome and Gnome Settings, but not VLC or GooBox
[Stable Update] 2017-09-23 - Kernels, Mesa, PulseAudio, GST, Python, Haskell
#51

Hi there,

Unfortunately after the latest update and upgrading my kernel to 4.9, I couldn’t boot into my OpenRc machine, I get a “Inittab file not found” error

I’ve been able to chroot in etc and I tried switching to Systemd as suggested by @thefallenrat here

However, I run into errors with all packages, this is what I get;

pacman -S systemd libsystemd systemd-sysvcompat
resolving dependencies…
looking for conflicting packages…
:: systemd and eudev-systemd are in conflict (systemd-tools). Remove eudev-systemd? [y/N] y
:: systemd and eudev are in conflict (udev). Remove eudev? [y/N] y
:: systemd-sysvcompat and sysvinit are in conflict. Remove sysvinit? [y/N] y
:: systemd-sysvcompat and acpid-openrc are in conflict. Remove acpid-openrc? [y/N] y
:: systemd-sysvcompat and alsa-utils-openrc are in conflict. Remove alsa-utils-openrc? [y/N] y
:: systemd-sysvcompat and at-openrc are in conflict. Remove at-openrc? [y/N] y
:: systemd-sysvcompat and avahi-openrc are in conflict. Remove avahi-openrc? [y/N] y
:: systemd-sysvcompat and bluez-openrc are in conflict. Remove bluez-openrc? [y/N] y
:: systemd-sysvcompat and cpupower-openrc are in conflict. Remove cpupower-openrc? [y/N] y
:: systemd-sysvcompat and cronie-openrc are in conflict. Remove cronie-openrc? [y/N] y
:: systemd-sysvcompat and cryptsetup-openrc are in conflict. Remove cryptsetup-openrc? [y/N] y
:: systemd-sysvcompat and cups-openrc are in conflict. Remove cups-openrc? [y/N] y
:: systemd-sysvcompat and dbus-openrc are in conflict. Remove dbus-openrc? [y/N] y
:: systemd-sysvcompat and device-mapper-openrc are in conflict. Remove device-mapper-openrc? [y/N] y
:: systemd-sysvcompat and dhcpcd-openrc are in conflict. Remove dhcpcd-openrc? [y/N] y
:: systemd-sysvcompat and displaymanager-openrc are in conflict. Remove displaymanager-openrc? [y/N] y
:: systemd-sysvcompat and elogind are in conflict. Remove elogind? [y/N] y
:: systemd-sysvcompat and eudev-openrc are in conflict. Remove eudev-openrc? [y/N] y
:: systemd-sysvcompat and haveged-openrc are in conflict. Remove haveged-openrc? [y/N] y
:: systemd-sysvcompat and hdparm-openrc are in conflict. Remove hdparm-openrc? [y/N] y
:: libsystemd and libeudev are in conflict (libudev.so). Remove libeudev? [y/N] y
:: libsystemd and libeudev-systemd are in conflict. Remove libeudev-systemd? [y/N] y
:: systemd-sysvcompat and lvm2-openrc are in conflict. Remove lvm2-openrc? [y/N] y
:: systemd-sysvcompat and mdadm-openrc are in conflict. Remove mdadm-openrc? [y/N] y
:: systemd-sysvcompat and netifrc are in conflict. Remove netifrc? [y/N] y
:: systemd-sysvcompat and nfs-utils-openrc are in conflict. Remove nfs-utils-openrc? [y/N] y
:: systemd-sysvcompat and ntp-openrc are in conflict. Remove ntp-openrc? [y/N] y
:: systemd-sysvcompat and openssh-openrc are in conflict. Remove openssh-openrc? [y/N] y
:: systemd-sysvcompat and openvpn-openrc are in conflict. Remove openvpn-openrc? [y/N] y
:: systemd-sysvcompat and rpcbind-openrc are in conflict. Remove rpcbind-openrc? [y/N] y
:: systemd-sysvcompat and rsync-openrc are in conflict. Remove rsync-openrc? [y/N] y
:: systemd-sysvcompat and syslog-ng-openrc are in conflict. Remove syslog-ng-openrc? [y/N] y
:: systemd-sysvcompat and virtualbox-guest-utils-openrc are in conflict. Remove virtualbox-guest-utils-openrc? [y/N] y
:: systemd-sysvcompat and wpa_supplicant-openrc are in conflict. Remove wpa_supplicant-openrc? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: device-mapper-nosystemd: removing eudev breaks dependency ‘eudev’
:: dhcpcd-nosystemd: removing eudev breaks dependency ‘eudev’
:: elogind-openrc: removing elogind breaks dependency ‘elogind’
:: elogind-openrc: removing eudev-openrc breaks dependency ‘eudev-openrc’
:: libusb-nosystemd: removing eudev breaks dependency ‘eudev’
:: lvm2-nosystemd: removing eudev breaks dependency ‘eudev’
:: openrc-sysvinit: removing sysvinit breaks dependency ‘sysvinit’
:: rpcbind-nosystemd: removing libeudev breaks dependency ‘libeudev’

Any help solving this issue, or the inittab one, would be great, either here or via private message, thanks!


#52

Thank you. wanted updates.
Reboot makes miracle.


#53

Pamac v. 6.0 is the worst version ever: it resemble more an app-store than a package manager, is relly less usable.
I hate it, there are any chance to return to the old interface?

Now it’s a totally different application (for dumbs, in my opinion)


#54

@salome

I’m glad you think that way. Even if it took all this time :slight_smile:
May I suggest you give pacman and the terminal a go? There really is nothing like pacman. For AUR support, if you need it, I suggest either going manual and learn a lot about the Arch build system, or use pacaur.

But if you wish to discuss this further I suggest opening a new thread.


#55

maybe add options for:

  • disable the applications’ icons
  • display the search items on the right (like previous versions)
  • display the applications’ names instead the generic name (example: xfce-appfinder only instead " Application Finder (xfce4-appfinder)"

could be the right way. In short: make the use able to use a more traditional package-manager interface if they want.


#56

Agreed.
Love the new Pamac. :heart_eyes:
Wish the search box was back where it was always available. I used it like 8 times a day on average.


#57

Please do this first :

sudo pacman -Rs sysvinit openrc eudev libeudev

But do it in chroot


#58

Oh, come on. Its every bit as usable as before.
I would like the search box front and center, but other than that it work fast as always.

You are upset that something changed. I suggest Linux is the wrong platform for you.


#59

Everything ok in here using kernel 4.13, the only problem i have is that my netbook screen resolution is 1024x600 and the pamac window is way too big for the screen so a portion of pamac is not viewable and because of that i can’t maximize the window or resize it. I use a’n external monitor that is 1366x768, havent tried with it because its broken and only turns on when theres high temperatures and humidity(i know wonders of technology).


#60

I simply found the new interface less usable and dressed up with uneusefuf fancies and with a less intuitive search and information panel.
I just found old-style package managers like octopi and synaptic more usable.